1. Deleted User

    OP Deleted User Newbie

    This guide was created when the browser exploit was unreliable on anything higher than v5.5.1. Since that's no longer the case, this guide is probably useless for >99% of people.

    This guide is for people who want to use the internet browser as their primary entrypoint because they don't want to pay for Haxchi. If you plan on buying a DS game and installing Haxchi or CBHC, then there is no reason to follow this guide. Haxchi users can go ahead and update normally to v5.5.3/v5.5.4.


    Note from Cyan :
    Since PokeAcer is banned and deleted his website's guide, here is a new one from Lacius.

    Guide from Lacius

    Update: There is a browser exploit for the v5.5.2/v5.5.3/v5.5.4 browser, but it is unreliable. If you already installed the v5.5.2/v5.5.3/v5.5.4 browser and you plan on using homebrew on a regular basis, you can use the exploit to install Haxchi. If you're on v5.5.1 or lower (particularly if you don't have Haxchi), it is recommended that you not update your browser to the v5.5.2/v5.5.3/v5.5.4 version, since the v5.5.1 browser exploit is very reliable.
    • This guide is for Wii U systems on system versions too low to use CFW. This guide is also for people who want to update to v5.5.3/v5.5.4 while keeping the v5.5.1 browser for its reliable exploit.
      • If you have Haxchi or plan on installing Haxchi, it is safe to connect to the internet and install v5.5.3/v5.5.4 instead of following this guide. You should immediately block updates after you're done.
      • If you plan on using the internet browser as your primary exploit because you don't want to spend money to install Haxchi, this guide is for you.
    • Your Wii U needs to be on v5.3.2, v5.4.0, v5.5.0, v5.5.1, v5.5.2, or v5.5.3 for this guide to work.
      • If your Wii U is on v5.3.1 or lower, you will need to update to v5.3.2, v5.4.0, v5.5.0, v5.5.1, v5.5.2, or v5.5.3 using a game disc before you can use this guide.
      • If your Wii U is on v5.5.2/v5.5.3/v5.5.4 already and you have the v5.5.2 browser installed, then there's no reason to follow this guide. You can connect to the internet and update to v5.5.3/v5.5.4 normally.
    • If you use my title lists, this guide will update your console to v5.5.3/v5.5.4, but it will update/keep the browser version at v5.5.1 in order to retain the reliable v5.5.1 browser exploit.
    • Do not disable your DNS filtering after updating, or the browser will update itself to the latest v5.5.2 version!
      • In addition to the using the proper DNS filters, you can also follow this guide to delete the update folder on your NAND to block updates. Using both methods (DNS filters and deleting the update folder) to block updates is recommended.
      • Never remove your DNS filters. If you need to use the eShop or update games, just use NNU-Patcher.
      • If you don't block updates and Nintendo releases a new system version, your Wii U will automatically download and install the update, potentially removing your entrypoint and/or CFW. Block updates!
    Required Files
    Everything except Java and the common.key file can be downloaded at the bottom of the thread.
    • OSTitleDownloader
    • wupinstaller_y_mod_without_blacklist
    • Java
    • common.key (find it yourself)
    • USA title lists (only for USA consoles)
    • EUR title lists (only for European consoles)
    • JAP title lists (only for Japanese consoles)
    Instructions

    Install OSv10 (000500101000400A) last, as it will freeze your Wii U (this is normal).
    1. Extract OSTitleDownloader.
    2. Download and extract the title list for your Wii U's version and region. Alternatively, you can make your own title list.
    3. Put your title list into the folder with titledownloader.jar and rename the title list as LIST.txt
    4. Find common.key online and put it into the folder with titledownloader.jar and your title list.
    5. Open a terminal/command prompt in that folder and type: java -jar titledownloader.jar -l LIST.txt
    6. Once it’s done, copy the install folder to your SD card.
    7. Extract and copy wupinstaller_y_mod_without_blacklist into your Wii U apps folder on your SD card.
    8. Run WUPInstaller Y-Mod from the Homebrew Launcher using the entrypoint of your choice.
    9. Select all titles except OSv10 (000500101000400A) and hit install to NAND.
    10. Once all titles are installed, install OSv10 (it will freeze, and this is normal).
    11. Reboot.
    Your Wii U should now be on v5.5.3 or v5.5.4 if you used one of my title lists, but the browser will still be on the reliable v5.5.1 version that can launch the Homebrew Launcher consistently.

    Offline and official updates

    You can also update offline using a game disc. It doesn't involve homebrew at all.

    Games containing the v5.5.1 update:
    • Cars 3: Driven to Win
    • Darksiders: Warmastered Edition
    • Just Dance 2017
    • Minecraft: Story Mode - The Complete Adventure
    • Paper Mario Color Splash
    • Shantae: Half-Genie Hero
    • Skylanders: Imaginators
    • The Legend of Zelda: Breath of the Wild










    I have migrated the guide to GitHub, with version data lists etcetera.
    It is now accessible at https://pokeacer.github.io/WiiU551/

    There is also a potentially new and improved method, at https://pokeacer.github.io/WiiU551/NewMethod

    The old version is below, incase anybody wants it.

    Have you left your Wii U off, and now cannot upgrade to 5.5.1 because 5.5.2 is out? If so, this is for you!

    WARNING: You could potentially brick if your Wii U powers off before all update titles are completely installed; I am not responsible if this occurs!
    Do not use a NUS Title List that is not from your region!
    Please note this copy of WUPInstaller has no security checks; if you install the wrong title version, again, I am not responsible!
    You will need:
    • The 5.5.1 update files
    • My unsafe version of WUPinstaller, downloadable here
    • A lot of patience
    • A PC
    Obtaining the 5.5.1 Update files:
    Remember, these cannot be legally obtained without going to NUS or dumping from your own discs; they are copyrighted content.

    Disc Method:
    If you already have a Wii U with 5.5.1, or a friend with one, you can use WUDump and extract the update partition using VGMToolbox. Follow the VGMToolbox instructions on how to open a WUD, and then extract the partition starting with "UP" - please note that you will be installing titles you may not need to reinstall, so I suggest NUS method.

    NUS Method:
    Go to the ninupdates page for your region: PAL, NTSC-U, NTSC-J, and look for titles that have updated since your version. For example, if you are on 5.4.0E and you have seen that ErrEula is updated between 5.4.0 and 5.5.0, install the 5.5.0 version. However, Internet Browser was updated in 5.5.0, and 5.5.1, so you want to install the version 5.5.1 has - if you install a version to just update it again, you will waste your time. This method is now a lot simpler!
    Go to the NUS List (Scroll down a bit) and find your version number and region (It has to be your region!). There will be a list of title IDs and the versions to download. Use a tool that can download encrypted from NUS - JNUSTool and NUSGrabber both work.
    If you use NUSGrabber, the command syntax is: "nusgrabber.exe TITLEID versionumber".
    If you use JNUSTool, the command syntax is "java -jar JNUSTool.jar TITLEID vVERSIONNUMBER -dlEncrypted"


    NUS Title Lists (aka what titles to download)
    Europe (PAL)
    5.3.2E -> 5.5.1E (spoofed to 5.5.2)

    0005001B10051000 v116
    0005001B10052000 v64
    0005001B10053000 v48
    0005001010041200 v560
    0005001010040200 v196
    0005001010047200 v178
    0005001B10059200 v162
    000500301001020A v180
    000500301001220A v241
    0005001B10068000 v8
    000500301001A10A v49
    000500101000400A v15702
    5.4.0E -> 5.5.1E (spoofed to 5.5.2)
    0005001010041200 v560
    000500301001220A v241
    0005001B10051000 v128
    0005001B10052000 v64
    0005001B10053000 v48
    0005001B10059200 v162
    0005001B10068000 v8
    000500301001A10A v66
    000500101000400A v15702
    5.5.0E -> 5.5.1E (spoofed to 5.5.2)
    0005001010041200 v560
    000500301001220A v241
    0005001B10051000 v128
    000500301001A10A v66


    USA (NTSC-U)
    5.3.2U -> 5.5.1U (spoofed to 5.5.2)

    TBD
    5.4.0U -> 5.5.1U (spoofed to 5.5.2U)
    000500101000400A 15702
    0005001010047100 197
    0005001B10051000 116
    0005001B10052000 64
    0005001B10053000 48
    0005001B10067100 18
    0005001B10068000 8
    0005001B10059100 162
    000500301001010A 197
    000500301001210A 241
    000500301001A10A 49
    0005001010041100 560
    5.5.0U -> 5.5.1U (spoofed to 5.5.2)
    0005001010041100 560
    000500301001210A 241

    Japan (NTSC-J)
    5.3.2J -> 5.5.1J
    0005001B10051000 v128
    0005001B10052000 v64
    0005001B10053000 v48
    0005001010041000 v560
    0005001010047000 v178
    0005001010040000 v226
    0005001B10059000 v162
    000500301001000A v180
    000500301001200A v241
    0005001B10068000 v8
    000500301001A10A v66
    000500101000400A v15702

    5.4.0J -> 5.5.1J (Spoofed to 5.5.2)
    0005001B10051000 v128
    0005001B10052000 v64
    0005001B10053000 v48
    0005001010041000 v560
    0005001010040000 v226
    0005001B10059000 v162
    000500301001200A v241
    0005001B10068000 v8
    000500301001A10A v66
    000500101000400A v15702

    5.5.0J -> 5.5.1J (Spoofed to 5.5.2)
    0005001B10051000 v128
    0005001010041000 v560
    0005001010040000 v226
    000500301001200A v241
    000500301001A10A v66
    Steps:
    NOTE: It is advised that you install the OS title last (OSv10 000500101000400A), as it may freeze your Wii U
    1. Make sd:/install/ and put in the contents of one of your title update's folders, and install to NAND.
    2. Delete contents, delete title you've upgraded from your PC, use next folder, repeat.
    Yes, this is tedious, however I am not personally able to do anything about this. If a Wii U dev wants to help out, they simply need to alter dimok789's WUPInstaller to add a feature that scans a folder, and installs all titles in the folder. You will also need to change L297 of src/main.c - where it says "0", change to "1". If someone does this, please inform me!

    Credits
    • @Kafluke for inspiring me to try this (This sounds snarky but I'm being serious, he genuinely made me want to try)
    • @trololo for testing this, and providing the 5.4.0U -> 5.5.1U update list
    • @Ryccardo for JPN lists and EUR lists
    Help Me Out!
    I clearly don't want donations, but I do need help. I need:
    • USA update lists for <5.3.2, 5.3.2
    • JAP update lists for <5.3.2, 5.3.2, 5.4.0, and 5.5.0
     

    Attached Files:

    Last edited by Lacius, Jan 29, 2020
  2. iAqua

    iAqua
    Member

    Joined:
    Dec 7, 2015
    Messages:
    2,848
    Country:
    United Kingdom
    ayy!
     
    Deleted User likes this.
  3. trololo

    trololo Member
    Newcomer

    Joined:
    Jul 23, 2017
    Messages:
    13
    Country:
    United States
    Yeah this really works - I went from 5.4 merely spoofed to 5.5.2 (thanks @iAqua for making that easy) to fully haxchi'd.
     
    iAqua and Deleted User like this.
  4. Ryccardo

    Ryccardo watching Thames TV from London
    Member

    Joined:
    Feb 13, 2015
    Messages:
    7,097
    Country:
    Italy
    For EUROPE

    Code:
    5.3.2 -> 5.5.1 EUR
    (5.5.2 version number)
    0005001B10051000 v128
    0005001B10052000 v64
    0005001B10053000 v48
    0005001010041200 v560
    0005001010040200 v196
    0005001010047200 v178
    0005001B10059200 v162
    000500301001020A v180
    000500301001220A v241
    0005001B10068000 v8
    000500301001A10A v66
    000500101000400A v15702
    
    5.3.2 -> 5.5.2 EUR
    (5.5.1 browser)
    0005001B10051000 v116
    0005001B10052000 v64
    0005001B10053000 v48
    0005001010041200 v560
    0005001010040200 v196
    0005001010047200 v178
    0005001B10059200 v162
    000500301001020A v180
    000500301001220A v241
    0005001B10068000 v8
    000500301001A10A v49
    000500101000400A v15702
    
    5.4.0 -> 5.5.1 EUR
    (5.5.2 version number)
    0005001010041200 v560
    000500301001220A v241
    0005001B10051000 v116
    0005001B10052000 v64
    0005001B10053000 v48
    0005001B10059200 v162
    0005001B10068000 v8
    000500301001A10A v49
    000500101000400A v15702
    
    5.4.0 -> 5.5.2 EUR
    (5.5.1 browser)
    0005001010041200 v560
    000500301001220A v241
    0005001B10051000 v128
    0005001B10052000 v64
    0005001B10053000 v48
    0005001B10059200 v162
    0005001B10068000 v8
    000500301001A10A v66
    000500101000400A v15702
    
    5.5.0 -> 5.5.1 EUR
    (5.5.2 version number)
    (Why are you even bothering)
    0005001010041200 v560
    000500301001220A v241
    
    5.5.0 -> 5.5.2 EUR
    (5.5.1 browser)
    0005001010041200 v560
    000500301001220A v241
    0005001B10051000 v128
    000500301001A10A v66
    for JAPAN
    (the System Updater was also updated for undocumented reasons)

    Code:
    5.3.2 -> 5.5.1 JPN
    (5.5.2 version number)
    0005001B10051000 v116
    0005001B10052000 v64
    0005001B10053000 v48
    0005001010041000 v560
    0005001010047000 v178
    0005001010040000 v212
    0005001B10059000 v162
    000500301001000A v180
    000500301001200A v241
    0005001B10068000 v8
    000500301001A10A v49
    000500101000400A v15702
    
    5.3.2 -> 5.5.2 JPN
    (5.5.1 browser)
    0005001B10051000 v128
    0005001B10052000 v64
    0005001B10053000 v48
    0005001010041000 v560
    0005001010047000 v178
    0005001010040000 v226
    0005001B10059000 v162
    000500301001000A v180
    000500301001200A v241
    0005001B10068000 v8
    000500301001A10A v66
    000500101000400A v15702
    
    5.4.0 -> 5.5.1 JPN
    (5.5.2 version number)
    0005001B10051000 v116
    0005001B10052000 v64
    0005001B10053000 v48
    0005001010041000 v560
    0005001010040000 v212
    0005001B10059000 v162
    000500301001200A v241
    0005001B10068000 v8
    000500301001A10A v49
    000500101000400A v15702
    
    5.4.0 -> 5.5.2 JPN
    (5.5.1 browser)
    0005001B10051000 v128
    0005001B10052000 v64
    0005001B10053000 v48
    0005001010041000 v560
    0005001010040000 v226
    0005001B10059000 v162
    000500301001200A v241
    0005001B10068000 v8
    000500301001A10A v66
    000500101000400A v15702
    
    5.5.0 -> 5.5.1 JPN
    (5.5.2 version number)
    0005001010041000 v560
    000500301001200A v241
    
    5.5.0 or 5.5.1 -> 5.5.2 JPN
    (5.5.1 browser)
    0005001B10051000 v128
    0005001010041000 v560
    0005001010040000 v226
    000500301001200A v241
    000500301001A10A v66
     
    Last edited by Ryccardo, Jul 27, 2017
    Deleted User and iAqua like this.
  5. antiNT

    antiNT a.k.a Johnny El Pollo Loco
    Member

    Joined:
    Sep 14, 2015
    Messages:
    499
    Country:
    Qatar
    What is the "OS Title" that Can freeze the Wii U ?
     
  6. Ryccardo

    Ryccardo watching Thames TV from London
    Member

    Joined:
    Feb 13, 2015
    Messages:
    7,097
    Country:
    Italy
    OSv10 000500101000400A popularly known as WiiU mode kernel
     
    Deleted User and antiNT like this.
  7. PROtone

    PROtone Newbie
    Newcomer

    Joined:
    Jul 28, 2017
    Messages:
    7
    Country:
    Russia
    How you copy new title to SD without power off?
    Just reject card? Its safe?
    Or maybe FTPU_everywhere?
     
  8. Deleted User

    OP Deleted User Newbie

    This looks rather confusing.
     
  9. Ryccardo

    Ryccardo watching Thames TV from London
    Member

    Joined:
    Feb 13, 2015
    Messages:
    7,097
    Country:
    Italy
    Why? You're downloading [system] titles in installable format then using wupinstaller to install them, not any differently from using SysUpdater or clones on 3DS
    (although on 3DS you typically had to pirate a cia pack since Nintendo removes old kernels/Home/browsers from their server, here we're getting everything from the original source)
     
    Deleted User likes this.
  10. PROtone

    PROtone Newbie
    Newcomer

    Joined:
    Jul 28, 2017
    Messages:
    7
    Country:
    Russia
    Great!!! With this guide i turn my 5.4.0 to 5.5.2!!! REAL 5.5.2 not spoofed!
    Thx...

    Region EUR.
    I use nusgrabber and wupinstaller_unsafe from 1st post.
    Download like this: nusgrabber.exe 0005001010041200 v560
    Install all titles from spoiler "5.4.0E -> 5.5.1E (spoofed to 5.5.2)"
    OS title install last (and have freeze after "Instalation successful")

    Now loadiine.ovh tell me "your firmware is 5.5.2"

    Official updates blocked with DNS.

    Be careful!
     
  11. BIFFTAZ

    BIFFTAZ GBAtemp Advanced Fan
    Member

    Joined:
    Jul 26, 2010
    Messages:
    596
    Country:
    Can you still launch browserhax via Loadiine.ovh or selfhost?
     
  12. lusisto

    lusisto Newbie
    Newcomer

    Joined:
    Jul 19, 2017
    Messages:
    9
    Country:
    Argentina
    I am on 5.5.0 EUR. I do not understand the difference between this two options. Also, It is not clear to me why it is recomended to install 4 titles in the EUR version and only 2 titles in the USA version. thanks!

    5.5.0 -> 5.5.1 EUR
    (5.5.2 version number)
    (Why are you even bothering)
    0005001010041200 v560
    000500301001220A v241

    5.5.0 -> 5.5.2 EUR
    (5.5.1 browser)
    0005001010041200 v560
    000500301001220A v241
    0005001B10051000 v128
    000500301001A10A v66
     
  13. Ryccardo

    Ryccardo watching Thames TV from London
    Member

    Joined:
    Feb 13, 2015
    Messages:
    7,097
    Country:
    Italy
    The browser version number is the one for 5.5.1

    The Loadiine.ovh URL will end with "552", tried changing it to "550"?

    Maybe NUSGrabber downloading is broken and actually got the last version? (When I tried it yesterday, it didn't save anything at all)

    — Posts automatically merged - Please don't double post! —

    "version number" gives you a 5.5.1 system but spoofed to 5.5.2
    "browser" gives you a 5.5.2 system but with the last exploitable 5.5.1 browser

    There's little practical difference, SSB4 with the newest game update may be the only game which cares if any do at all

    — Posts automatically merged - Please don't double post! —

    There's an error in the OP, the American ones use the "version number" method as claimed, but the European one incorrectly shows the "browser" list while calling it the "version number" one
     
    Last edited by Ryccardo, Jul 28, 2017
    Deleted User likes this.
  14. lusisto

    lusisto Newbie
    Newcomer

    Joined:
    Jul 19, 2017
    Messages:
    9
    Country:
    Argentina
    Thanks, I understand now. Is it possible to install a clean 5.5.1 (not spoofed to 5.5.2)?
     
  15. PROtone

    PROtone Newbie
    Newcomer

    Joined:
    Jul 28, 2017
    Messages:
    7
    Country:
    Russia
    No.

    Yes. And i try launch exploit from other sites and selfhost. No results...
     
  16. Deleted User

    OP Deleted User Newbie

    "You may now take your SD card out if you want to" says it in the copy of the app you need to use

    It's just annoyingly repetitive.

    The version lists I give update your Wii U to 5.5.2 but give you 5.5.1's browser (5.5.2 VersionData means it can't actually update the browser)
    The only updates in 5.5.2 were AOC overlay, VersionData, and Browser - I do not update the browser, you can check the Internet Browser title yourself


    I was using the browser versions as it was to ensure users were going to get 5.5.2 with 5.5.1 browser to try to make things like SSB4 not get pissy, but I'll update the lists and put them on GH later with a full explanation for both - I also had the American title list off @trololo thus why it's version number

    That's... strange. I most definitely put v241 (5.5.1)'s browser in all titlelists...
    Maybe you accidentally downloaded the wrong version?
     
    Last edited Jul 28, 2017
  17. PROtone

    PROtone Newbie
    Newcomer

    Joined:
    Jul 28, 2017
    Messages:
    7
    Country:
    Russia
    Maybe. But i download all titles by copypaste from the spoiler.
     
    Deleted User likes this.
  18. Deleted User

    OP Deleted User Newbie

    Internet Browser's title is certainly 241; just incase, try http://185.82.21.64/wiiu/ and go to 5.5.1
    EDIT: Just to confirm, you're using PAL, correct?
     
  19. PROtone

    PROtone Newbie
    Newcomer

    Joined:
    Jul 28, 2017
    Messages:
    7
    Country:
    Russia
    Yes, using PAL.

    Error 112-2903
    Can't load video
     
  20. Deleted User

    OP Deleted User Newbie

    Well, I sincerely apologise for not clarifying certain points in the guide; I am currently working on this, and I hope a Wii U exploit comes out very soon so that you can gain homebrew again.
     
    KiiWii and antiNT like this.
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Updating, versions, lower