updating firmware for wiiware?

Discussion in 'Wii - Hacking' started by dodge123, Feb 3, 2011.

  1. dodge123
    OP

    dodge123 Newbie

    Newcomer
    6
    0
    Feb 3, 2011
    United States
    hi,

    got my wii out today for first time in a couple years so im a bit out of touch

    from when i used to use it, its already softmodded with homebrew channel etc, running 3.2E

    problem is i installed a new wiiware game WAD today - the channel shows up fine but when i try and run it it just blinks a bit then goes back to the main screen, im assuming this may be down to an old firmware?

    anyway, just wondering what the safe way to update firmware is, and if theres a 'custom' one i should install etc?

    thanks in advance
     
  2. XFlak

    XFlak Wiitired but still kicking

    Member
    9,127
    533
    Sep 12, 2009
    Canada
    Ontario
    download ModMii, and use it's wizard function to update all your softmods, its really easy, if u have problems u can ask them in my ModMii thread

    cheers
     
  3. dodge123
    OP

    dodge123 Newbie

    Newcomer
    6
    0
    Feb 3, 2011
    United States
    thanks, doing that now - one question though it wants me to install homebrew channel but vie already got that, will it harm to just install it over the top?
     
  4. dodge123
    OP

    dodge123 Newbie

    Newcomer
    6
    0
    Feb 3, 2011
    United States
    ah............


    1) INSTALLING THE HOMEBREW CHANNEL (HBC) AND BOOTMII
    =================================================



    Run BannerBomb v1 by going to Settings, Data Management, Channels, SD Card and choosing yes to load boot.dol/elf
    Note: If it doesn't work for you, visit http://bannerbomb.qoid.us/ for more variations of either version of bannerbomb.



    At this point my console says "The device inserted in the SD Card Slot cant be used"


    any ideas/workarounds? its a 4gb standard sd card....
     
  5. FIX94

    FIX94 Global Moderator

    Global Moderator
    7,075
    8,861
    Dec 3, 2009
    Germany
    ???
    As far as I know SDHC support (4GB or more) is only possible with 4.0 or higher, try to move the sd card in the slot, maybe it's not detected correctly. If it still doesn't work you should try a smaller SD card.
     
  6. dodge123
    OP

    dodge123 Newbie

    Newcomer
    6
    0
    Feb 3, 2011
    United States
    weird, it let me install the new wiiware WAD from the card which subsequently prompted me to try and update firmware to get it to run
     
  7. tj_cool

    tj_cool Site dev

    Supervisor
    9,989
    -1
    Jan 7, 2009
    Belgium
    This planet
    If you already have the HBC, you don't need to install it again.

    You can run the Hackmii installer through the HBC if you want to update the HBC/BootMii though.


    As for the WiiWare, installing the IOS the game needs should be enough I think.
     
  8. dodge123
    OP

    dodge123 Newbie

    Newcomer
    6
    0
    Feb 3, 2011
    United States
    it says in the hackmii guide i need HBC 1.0.7 for the IOS installer to work? i have beta 9 should i try it anyway?
     
  9. XFlak

    XFlak Wiitired but still kicking

    Member
    9,127
    533
    Sep 12, 2009
    Canada
    Ontario
    update your HBC first, the IOS236 Installer will not work with HBC's older than 1.07
     
  10. FIX94

    FIX94 Global Moderator

    Global Moderator
    7,075
    8,861
    Dec 3, 2009
    Germany
    ???
    Simply launch the latest hackmii installer from your old homebrew channel and install the latest homebrew channel 1.0.8.
    edit: too slow [​IMG]