Updating Acekard 2i for DSi 1.4.4

Discussion in 'Acekard' started by cupcakedreams, Oct 1, 2013.

  1. cupcakedreams
    OP

    cupcakedreams Newbie

    Newcomer
    7
    0
    Oct 1, 2013
    So, I've been around the internet reading and reading and reading, since I'm considering getting a new flash card (I accidentally updated my DSi a while ago, and my old counterfeit flashcard wasn't supported anymore...). :wacko:

    The thing is that I have a Nintendo DSi, with the 1.4.4 firmware. I did some reading on the GBATemp wiki and forums, and saw that the Acekard 2i can be updated to work with version 1.4.4 of the firmware.

    However, there was something I didn't understand. It said somewhere that it is possible to update it with a DS/DS Lite or a DSi/3DS, but you have to update the card before you update the DSi. Does that mean that even if I chose to update the card on my DS Lite, it won't work since my DSi is already updated? Or is this only the case if you only have a DSi and logically you'd have to update the card first or else it won't run so it can update?
    (What confuses me is the way it's phrased. Unfortunately I've lost the link to this statement..)
     
  2. how_do_i_do_that

    how_do_i_do_that Blue Wizard is about to die.

    Member
    4,928
    263
    May 16, 2008
    Antarctica
    You have insufficient posts to view user location.
  3. Lacius

    Lacius GBAtemp Guru

    Member
    6,269
    2,558
    May 11, 2008
    United States
    In order to update the Acekard, you need a DS/DSi/3DS that the Acekard presently runs on so it can run and update itself. If your DSi is already on 1.4.4, you can still update the Acekard using a DS that the Acekard still runs on, like your DS Lite. After running the update, the Acekard will work on the DSi on 1.4.4.
     
  4. cupcakedreams
    OP

    cupcakedreams Newbie

    Newcomer
    7
    0
    Oct 1, 2013
    Thank you, that's what I wanted to know :)
    Now I'm seriously thinking of getting the AK2i.
     
  5. Lacius

    Lacius GBAtemp Guru

    Member
    6,269
    2,558
    May 11, 2008
    United States
    If you don't already have an Acekard, I recommend you get something that is still supported. The DSTWO and the R4i Gold 3DS are your two best options. There is no reason to get an Acekard if you haven't already bought a flashcart. I'm sorry I missed that detail in your original post.
     
  6. cupcakedreams
    OP

    cupcakedreams Newbie

    Newcomer
    7
    0
    Oct 1, 2013
    Well, I was thinking of buying the DSTWO, but I decided on the AK2i since it's a much cheaper choice.
    I've never really been so interested in the R4i Gold, but I guess I can't completely rule it out. With all the low quality clones going around, I'm really scared to buy one (my old flashcart is one of those...).
    Is the R4i Gold 3DS that you're talking about this one: http://nds-card.com/ProShow.asp?ProID=149?
     
  7. Lacius

    Lacius GBAtemp Guru

    Member
    6,269
    2,558
    May 11, 2008
    United States
    The R4i Gold 3DS is just as cheap as the Acekard 2i. The only real difference between the Acekard 2i and the R4i Gold 3DS is that the R4i Gold 3DS still receives support for newer DSi/3DS firmwares; the Acekard 2i will never work on anything beyond DSi 1.4.4. and 3DS 4.3. If you were to accidentally update your DSi past 1.4.4, you would have to buy a new flashcart, so it would be better if you just bought something still receiving support anyway.

    The flashcart you linked to is the RTS, which is basically the R4i Gold 3DS. That is a good one to get. You can see the following thread for more details on which flashcart to get. Note: The Acekard 2i is not on the list because there is no reason to get it since it lacks support and the others have all the features it has while being potentially just as cheap. The Acekard 2.1 is on the list but only works on DS systems before the DSi.
    http://gbatemp.net/threads/which-flash-cart-should-i-get.290097/
     
  8. cupcakedreams
    OP

    cupcakedreams Newbie

    Newcomer
    7
    0
    Oct 1, 2013
    Ok, I guess I'll be getting the R4i Gold 3DS then. Thank you for your help :)
     
  9. Another World

    Another World Emulate the Planet!

    Former Staff
    10,502
    1,695
    Jan 3, 2008
    Colombia
    From Where???
  10. cupcakedreams
    OP

    cupcakedreams Newbie

    Newcomer
    7
    0
    Oct 1, 2013
    You shouldn't just assume that I didn't read that, because I did. In the first post I stated (though I now notice that it's awkwardly phrased) that I read the wiki, but something there confused me and I lost the link so I didn't post it.

    The thing that confused me was the phrasing here:
    I planned to buy one and use it on my DSi, which was version 1.4.4, but it is stated that you must upgrade the card before the DSi. I wasn't exactly sure what that meant (if this was only if you didn't have another stystem to update the card on, or if the card simply wouldn't work on the DSi 1.4.4 that was already updated, even if I updated the card on another console.)
    Now I know, thanks to you guys, that it can be updated on another older generation console, but I should probably buy a flashcard that's still supported (even though it doesn't matter to me as I don't plan to update either my DSi nor 3DS XL).

    I'm sorry for crashing in on your forum and being a noob and stuff. :unsure:
     
  11. Another World

    Another World Emulate the Planet!

    Former Staff
    10,502
    1,695
    Jan 3, 2008
    Colombia
    From Where???
    you are right, i shouldn't assume. you might be the 1st person to have conducted some research before posting. i wrote that wiki article. what exactly was confusing to you. was it the wording? or was it that you didn't know exactly what you were reading (ie: firmware vs exploit)?

    -another world
     
  12. cupcakedreams
    OP

    cupcakedreams Newbie

    Newcomer
    7
    0
    Oct 1, 2013
    Seriously? I always try to research myself before asking seemingly pointless questions. I don't want to be an annoying burden. :mellow:

    I knew what the article was about. It was just that tiny little part in the 'Before you begin' part, where it doesn't make it very clear that even if you can't update the cart on a DSi firmware version 1.4.4, you can update it on an older console or a DSi with an older firmware version, and it will be playable on said DSi 1.4.4 after you've updated the cart on another device.

    It does say that '...however, DS and DS Lite systems do not have upgradable firmware', but that only hints that you can freely upgrade the cart on those systems, and not whether it'll still work on the DSi afterwards (since it clearly states that '...the AK2i must first be updated, then the system itself', which is logical since it wouldn't run on the console to update, if the DSi was already 1.4.4, but it doesn't explain exactly why that is and it doesn't explain that you can bypass that if you have another system to use to upgrade it, and then it'll work on the DSi).
    Or maybe that's just the noob in me over thinking...
     
  13. Another World

    Another World Emulate the Planet!

    Former Staff
    10,502
    1,695
    Jan 3, 2008
    Colombia
    From Where???
    the introduction of the article explains what the bootloaders are for and the cat and mouse game nintendo plays with flash kits. this sets up the entire background allowing users to understand that their flash kit can and will get blocked. at the end of this introduction it says "Updating, blocking, and re-flashing are inevitable processes of this hobby, thankfully the Acekard 2i continues to function on the DSi v1.4.4 and lower and on the 3DS v4.3 and lower." this makes it perfectly clear that if you apply the update outlined in the article, that the AK2i will function on the DSi v1.4.4 and lower and on the 3DS v4.3 and lower. this information directly addresses your concern relating to if the card will work on the dsi after you update it on an old system. i think you were confused that the system is just the delivery method and that the exploit itself works independently of the system.

    the delivery method is unimportant, the only issue that needs to be pointed out is that you can not flash the bootloader on an already updated system because the bootloader itself is an .nds file. logic explains that if you can't run the file you can't install the update. to help clear up your concerns, i've added a few things to the article. it now more clearly differentiates "firmware" from "bootloader exploit". i've also done a quick rewrite to better explain why you need to update the card first and then the system.

    i also expanded upon the two sentences that described backwards compatibility. it is now much more clear what this means.

    -another world
     
  14. cupcakedreams
    OP

    cupcakedreams Newbie

    Newcomer
    7
    0
    Oct 1, 2013
    You're right, it was basically this that concerned me. However, I'm not a that tech savy, so to me there could've possibly been some weird reason why it wouldn't work. I only have a basic understanding of the technology. Logic told me that I, of course wouldn't be able to update the chart on the DSi 1.4.4 simply becausethe console would reject the cart, but my brain told me to be careful and assume that there might be something more to consider.
    I now understand everything better, thank you for clarifying the subject to me :)
     
  15. Another World

    Another World Emulate the Planet!

    Former Staff
    10,502
    1,695
    Jan 3, 2008
    Colombia
    From Where???
    thank you, for your input. we are always trying to make various aspects of this community better. few find the need to comment on the wiki articles. most of the ones i'm involved with make sense to me, because i tend to write 98% of them. it is easy to forget to write in a way that someone new to this hobby will fully comprehend.

    make sure you put some great ds homebrew on your flash kit!! check filetrip.net for an awesome selection of apps, games, and emulation.

    -another world