Updating 5.1.0 to 6.0 - Homebrew Compatibility

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by leosel, Sep 20, 2018.

  1. leosel
    OP

    leosel Member

    Newcomer
    3
    Oct 1, 2010
    While checking and doing some of my research of people who successfully updated their switch to 6.0 without burning fuses and run cfw on it, I decided to do it on my own.

    After a successful update from 5.1.0 to 6.0 I tried to run my SX OS ver 1.9, and works flawlessly without errors encountered, since the cfw is fine, I've check some of the homebrew applications that is compatible for version 6.0:
    • Homebrew menu - Works flawlessly
    • Checkpoint - Works fine
    • Tinfoil -Works fine
    • BOW Save file Editor - Works well
    • NXShell - Works good also
    • HBApstore - Still works
    • FTPD - Works fine
    • Edizon - Works good
    • NES Emulator - Works Well
    • Retronx - crash issue - not working
    • zerotwoxci - Works fine
    • DevMenu - not working

    I'll try to test more homebrew apps soon, so everyone could be informed that even on version 6.0 most of the apps works. Anyway if you ask me how did I updated my firmware to 6.0, from 5.1.0 I used a homebrew app called choidojourNX, is a wonderful app that makes your switch update to the latest version without burning fuses, so you could always go back to your previous version in case you will encounter some problems or you feel like the previous one is much better.
     
    Last edited by leosel, Sep 20, 2018
  2. sj33

    sj33 GBAtemp Psycho!

    Member
    12
    Oct 22, 2013
    Japan
  3. leosel
    OP

    leosel Member

    Newcomer
    3
    Oct 1, 2010
    It works on me, make sure to used all the latest versions of homebrew apps and hombrew launcher
     
  4. sj33

    sj33 GBAtemp Psycho!

    Member
    12
    Oct 22, 2013
    Japan
    I'm asking about the .nsp version specifically, however. Not .nro files.
     
  5. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    17
    Aug 6, 2017
    United States
    New York City
    I was already working on a list of confirmed changes that includes more than firmware 6.0 here but I'll credit your thread for the additional findings.
    No, custom/homebrew NSP files currently work on SX OS or RajNX with firmware 6.0. They do not work with ReiNX but I am awaiting additional confirmation that they work using tomGER's SD files.
     
    Pluupy likes this.
  6. nero99

    nero99 GBAtemp Addict

    Member
    10
    Sep 18, 2014
    United States
    VBA-NEXT custom NSP works on 6.0 on the latest hekate 4.1 with the latest SDFILES 9.1
     
    sj33 likes this.
  7. _BlueEyes_

    _BlueEyes_ Newbie

    Newcomer
    1
    Jul 25, 2018
    Germany
    Hey leosel, thank you for doing all the work. I also did the jump from 5.1 to 6.0 with SX OS 1.9, while playing backups still works fine, I experience crashes with RetroNX, the kinds where I have to reboot the Switch and use the payload to boot again. Any chance to point me to the direction of the RetroNX you tested which works flawless for you?

    Thank you in advance
     
  8. whateverg1012

    whateverg1012 Fringe Weaver

    Member
    6
    Sep 23, 2016
    United States
    VA-11 Hall-A
    for devmenu, did you try the nsp or the layeredfs version?
     
  9. leosel
    OP

    leosel Member

    Newcomer
    3
    Oct 1, 2010
    Thank you, for the information about the RetroNX, I haven't tried it to play for a long time, just tested if games will load, it seems that there is a problem on it, as I tried playing it also, I will update my post for crash issue on RetroNX...Thank you Blueyes.

    — Posts automatically merged - Please don't double post! —

    Thank you whateverg1012, I'll try that one too, just in case it might work

    — Posts automatically merged - Please don't double post! —

    Oh, sorry about that Draxzelex, I didn't mean to steal any credits on your part, i just want to inform everyone on homebrew community regarding on compatibility of the apps, to help them decide if they will need to update to version 6.0 or stay on lower version
     
    Last edited by leosel, Sep 20, 2018
  10. _BlueEyes_

    _BlueEyes_ Newbie

    Newcomer
    1
    Jul 25, 2018
    Germany
    also pSNES (SNES Emulator) works flawless,
    which NES Emulator did you try?
     
  11. leosel
    OP

    leosel Member

    Newcomer
    3
    Oct 1, 2010
    Thanks nero99, I'll add it from the list

    — Posts automatically merged - Please don't double post! —

    Wow that's nice, yup we use the same emu...
     
    nero99 likes this.
  12. xXDungeon_CrawlerXx

    xXDungeon_CrawlerXx GBAtemp Advanced Maniac

    Member
    10
    Jul 29, 2015
    Liverpool
    It works well for me using RajNX and as NSP
     
  13. _BlueEyes_

    _BlueEyes_ Newbie

    Newcomer
    1
    Jul 25, 2018
    Germany
    I tested with SX OS 1.9, and while sometimes i appears that it works, when you click on "Scan Directories" it crashes
     
  14. leosel
    OP

    leosel Member

    Newcomer
    3
    Oct 1, 2010
    sj33 my apologies, as on my thread it only implies on the Homebrew apps on .nro files not on .nsp files, since I'm using SX OS 1.9, I'm using .xci files for my games also, but since you open it up, I think it's a good idea also to inform if custom .nsp files works on version 6.0, thanks sj33
     
    Last edited by leosel, Sep 20, 2018
  15. fixingmytoys

    fixingmytoys GBAtemp Fan

    Member
    5
    Jan 4, 2018
    Australia
    Thank you for your post, I wish to ask what f/w did you use the one that was leaked before it officially was released or official version that was acquired after it was officially released, I am thinking of updating but I don’t wish to use the leaked version of f/w 6 I wish to use the official released version after acquiring it
     
  16. leosel
    OP

    leosel Member

    Newcomer
    3
    Oct 1, 2010
    I spanish guy who has it's own youtube channel help me to acquire the 6.0 firmware, nonetheless, I forgot to ask him if it was the leak or official one, but after installing it, all the features that was mention by official post of Nintendo are all in this firmware I used. So I think technically, the firmware that was on rumor circulating on server that some has already received earlier updates is just the same with the official released, is just that it will just enable the online feature at 9-18-2018.
     
  17. itzska

    itzska Member

    Newcomer
    1
    Feb 26, 2018
    United States
    Not sure if I got lucky or what happened, but I accidentally updated when trying to launch Mario Odyssey because I didn't expect an update prompt as I was starting a game.
    My switch updated fine through official updating and is working on SXOS 1.9.

    Edit:
    Update happened while running SXOS 1.6, rebooted to stock. All I had to do was update SXOS to 1.9 and it worked again. Unfortunately LayeredFS seems to be the one major thing that doesn't work for me.
     
    Last edited by itzska, Sep 20, 2018
    Kri3tian likes this.
  18. xXDungeon_CrawlerXx

    xXDungeon_CrawlerXx GBAtemp Advanced Maniac

    Member
    10
    Jul 29, 2015
    Liverpool
    For full CFW support (LayeredFS + custom NSPs) try RajNX. It it the most compatible one for 6.0 atm
     
    itzska likes this.
  19. itzska

    itzska Member

    Newcomer
    1
    Feb 26, 2018
    United States
    Holy cow, just tested it out and can confirm it working.
    So in other words 6.0 didn't break anything that I cared about. GG Nintendo.
     
    xXDungeon_CrawlerXx likes this.
  20. A H4CK3RS L1F3

    A H4CK3RS L1F3 GBAtemp Regular

    Member
    2
    Jan 7, 2016
    United States
    So is it safe to also update the controllers? I read somewhere that it could allow an RCM Joy-con to not work any more (the right one)
     
    2000Man likes this.
Loading...