Updated to 7.0.1, can no longer access Hekate or boot games

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by AnAlchemistReborn, Apr 18, 2019.

  1. AnAlchemistReborn
    OP

    AnAlchemistReborn Member

    Newcomer
    2
    Nov 27, 2014
    United States
    My problem will be listed below but summarize, i updated to 7.0.1 using ChoidujourNX and then began having problems with running/installing and getting CFW to work properly.

    So I am using:

    Updated to 7.01 using ChoidujourNX - choose the ExFat option when updating
    ReiNX_2.1.1
    Atomosphere from the Kosmos V12 package
    Brand new 64GB Samsung SD
    I am in RCM mode and booting using this link https://webcfw.sdsetup.com/

    The Problems:
    I need to access Hekate, Im running mac and this creates issues with the SD card which can be solved with Hekate.
    All folders on the SD card are normally cleared using the Hekate tools, you run this on the entire SD and the nintendo folder.

    When I boot my switch using the link above I use to go into Hekate first to then load the payload.

    Now it boots directly into CFW, normally it shows both ReinX and atmosphere boot screens. I cannot tell which is even running since if I go to system menu it just says version 7.0.1 and not which CFW im running. Also none of my games boot, they ask for an internet connection which I never had this problem before.

    By switching the files around so that the hekate bin file is moved in the bootloader folder instead of root of SD this causes Hekate to load properly but now when I choose a payload it just continously loads Hekate over and over and never boots CFW. So I am stuck in a loop of not being able to run Hekate and also when getting into the CFW and running Apps they seems to work but the games will not load at all and even older games won't load anymore.
     
  2. JBMario

    JBMario Advanced Member

    Newcomer
    4
    Jan 17, 2019
    France
    Instead of using your browser, try to launch the payload with this: https://github.com/SuperOkazaki/fusee-launcher. Works great on a Mac (I tried multiples times since I had issues with the Web version.)

    Concerning the CFW it seems your Switch is loading ReiNX since Atmosphere says 7.0.1 (AMS 0.8.7).

    Regarding the issue with the games, did you download the sigpatches? I see you're using Kosmos. Don't know if you know, but the sigpatches are no longer included. You have to get them separately from the GitHub page of Kosmos or here: https://gbatemp.net/threads/i-heard-that-you-guys-need-some-sweet-patches-for-atmosphere.521164/
     
  3. Hayato213

    Hayato213 GBAtemp Psycho!

    Member
    10
    Dec 26, 2015
    United States
    Looks like you went online without setting up a DNS, that why when you launch a game it will prompt you to update, but don't update your games through Nintendo server. Alternative solution is to set up 90DNS and use the HBG shop for your update and DLC.
     
  4. Kafluke

    Kafluke GBAtemp Guru

    Member
    13
    May 6, 2006
    United States
    ^ while true I dont believe this to be the issue. I think @JBMario hit the nail on the head. Re-read his post. Seams like a sig-patch issue to me.
     
  5. Hayato213

    Hayato213 GBAtemp Psycho!

    Member
    10
    Dec 26, 2015
    United States
    Maybe , if it is not sig patches issue, then it is probably this.
     
  6. Kafluke

    Kafluke GBAtemp Guru

    Member
    13
    May 6, 2006
    United States
    Could be for sure
     
  7. AnAlchemistReborn
    OP

    AnAlchemistReborn Member

    Newcomer
    2
    Nov 27, 2014
    United States
    This was the problem, the sig patches were the reason the games wouldn't load. So that's solved.. I still have some issues though.

    First and foremost, I still cannot boot Hekate. Unless I move the .ini file from the bootloader into the root of my SD I can't load Hekate, and when I do that it forces Hekate to load everytime and I cannot boot Payloads. This isn't a serious issue but I'd like to have access to Hekate and the tools it has. Right now my CFW is working properly but I still want to use Hekate when needed.

    I've noticed that NSPs won't install through Goldleaf v.5 sometimes, other times they will install and then I'll get an error code after and force to reboot, installed NSP still works though. I installed the Devmenu when I was on 6.1 and running that and installing NSPs through there seems to have no issues.

    I also tried to set up the fusee-launcher and got everything set up except the last step. Step 4. Install Python dependencies: python3 -m pip install -r requirements.txt
    This gives me the error " Could not open requirements file: [Errno 2] No such file or directory: 'requirements.txt' "
    I can see the file is located inside the fusee-launcher directory but it's not finding it and I'm not sure if I need to move it or what to make it work. Other then that loading my payload from the website I listed above seems to be working for me for the time being.
     
  8. AnAlchemistReborn
    OP

    AnAlchemistReborn Member

    Newcomer
    2
    Nov 27, 2014
    United States
    Still trying to figure out how to boot Hekate.. no solution so far
     
  9. stick267

    stick267 GBAtemp Fan

    Member
    4
    Dec 17, 2018
    United States
    Check your Hekate ini to see if it's set to autoboot. If it is, take it off.
     
    nanchan likes this.
  10. AnAlchemistReborn
    OP

    AnAlchemistReborn Member

    Newcomer
    2
    Nov 27, 2014
    United States
    I went into the .ini and autoboot was set to 1. I changed it to 0 and that solved the problem, thanks stick!
     
Loading...