Updated everything. Now SSBB Subspace Emissary won't work.

Discussion in 'Wii - Backup Loaders' started by ocd_spacepirate2, Jul 22, 2011.

  1. ocd_spacepirate2
    OP

    Newcomer ocd_spacepirate2 Newbie

    Joined:
    Jul 22, 2011
    Messages:
    2
    Country:
    United States
    OK, I've searched around and it seems like I'm the only one having this specific problem, so please forgive me if this has been asked before.

    Here's what I have:

    I have two different versions of Super Smash Bros. Brawl: The North American version and the Japanese version. I've had an older version of The Homebrew Channel and USB Loader GX for a long time and just recently decided to upgrade everything after following this guide to hack my brother's and my friend's Wiis for them (both 4.3.) I liked what options the "new" hacks gave (such as being able to boot directly to the USB Loader GX, etc.), so I decided to re-hack my Wii using that guide. I updated my Wii to 4.3 and re-hacked per the guide's instructions.

    Almost everything works perfectly fine.

    Except, I get an error when I try to play Subspace Emissary in the NTSC-J version of Super Smash Bros. Brawl:

    [​IMG]
    (I have a video capture device.)

    For those of you that can't read Japanese, it more or less says what it would say in the English version. "An error has occurred. Please press the eject button, take out the disc, turn the power off... etc."

    I do not get an error if I play in the NTSC-U version. Both versions worked perfectly fine with the older versions of everything.

    I should also note that I get this error after completing All-Star mode (NTSC-J) as well, so it never actually saves my score or that I completed it with a certain character. I haven't tried any other 1-player modes though, other than Subspace Emissary obviously.

    Now, I found this page that says I should use Hermes' IOS222/223. Alright... So I follow the instructions to install it and I select 224-mload as the IOS to load the NTSC-J version of Super Smash Bros. Brawl with, but it still doesn't work.

    Interestingly enough, I can either select 224-mload or the default 248 when loading the NTSC-U version and Subspace Emissary still works fine in that version. It's so weird that everything works perfectly except for the "second layer" data of NTSC-J Super Smash Bros. Brawl.

    Soooo... Does anybody have any idea what is going on and/or what I can do to remedy the situation?

    Here's some more info:

    System Menu: 4.3U
    Homebrew Channel: 1.0.8 IOS58 v24.32
    Storage Medium: 120GB Western Digital hard drive, plugged into port 0. Formatted into FAT32 with the command prompt in Windows 7 followed by WBFS in WBFS Manager.
    Configurable USB Loader GX: (it was just easier to take a screenshot - info on bottom.)

    [​IMG]

    You may be asking: "Why do you need both versions? What's wrong with the English version?"

    Well, I make documentary-like movies about the origins of many things in Super Smash Bros. Brawl and post them on YouTube. (I have 11,000+ subscribers.) I often need to consult the original Japanese version of Brawl to see what has been changed in the game when it was localized in America as part of my movies. I would really like access to the Subspace Emissary so I can do what I need to do with it. [​IMG]

    That, and the voice actors are just awful in the English version compared to the Japanese version. But that's irrelevant here. [​IMG]

    At any rate, if anybody can help me out or give me some suggestions about what is wrong here, I would REALLY appreciate it! Thank you!

    Edit: By the way, if anybody needs anymore information, I'll do my best to answer your question so I can get this problem resolved. Thanks again.
     
  2. PPSainity

    Member PPSainity Blinded by Science

    Joined:
    Jun 6, 2009
    Messages:
    646
    Country:
    Canada
    This may are may not be your issue, but I had to re-rip my SSBB (NTSC/U) game image after updating the cIOS I had been using. This was a while back, so the details are blurry, but the issue was due to the fact that the game was initially ripped using an older version of Waninkoko's cIOS (rev14?), that had a dual layer bug in it, so when I updated the cIOS to rev21 I had to re-rip the image. The problem was the same, I was not able to play Subspace Emissary, but I have NTSC/U versions of the Wii and game.

    So if you own the game (which you should as it is worth the $) try re-ripping the game and don't use an older (below rev21) version of Waninkoko's cIOS.

    -[]D
     
  3. ocd_spacepirate2
    OP

    Newcomer ocd_spacepirate2 Newbie

    Joined:
    Jul 22, 2011
    Messages:
    2
    Country:
    United States
    OK, I figured out the problem. And, the problem has to do with information I omitted because I assumed it was irrelevant.

    Anyway, in the NTSC-J version, I replaced 167 .brstm files (in the /files/sound/strm directory) with ones I had generated with the Brawl Custom Song Maker GUI, a tool for generating .brstm files from .wav or .mp3 files. To be more specific, I decompiled the .iso with Wit, a program that runs off of command lines. I replaced the .brstm files then recompiled the .iso (again with Wit) and added it to the external drive with WBFS Manager. (I gotta say, Wit kicks WiiScrubber's ass over the moon when it comes to replacing large amounts of files like this.)

    I assumed this was irrelevant for two reasons:

    1) Before I updated everything, I was able to play beyond the Mario/Kirby battle in Subspace Emissary with the modified Japanese version. (It was interesting playing Subspace Emissary with my custom music.) HOWEVER! I replaced two more original .brstm files with my own the same time I updated.***

    2) The only things that was changed was the .brstm files. These should simply be played/streamed like a .wav, so I don't see why they would affect the loading or the programming or anything like that.

    Anyway, what I did to test this was replace the .brstm files in the NTSC-U version, recompile and add to the drive, while adding a fresh, untouched NTSC-J .iso to the drive. Result? I get a read error in the NTSC-U version in Subspace Emissary but I can play the NTSC-J Subspace Emissary just fine.

    ***This is what I think is causing the problem. There must be a limit to how big the .iso can get, either within the game's programming or the loader itself. Since the .brstm files I am putting in the .iso tend to be larger than the originals, the .iso filesize is inflated bit by bit. I must have just barely pushed it beyond the threshold when I replaced those two more .brstm files.

    Or, maybe the .iso filesize was irrelevant in the older version of the loader I was using and the way it was updated introduced this bug?

    It's interesting that this only affects the "second layer" data of the game though. Maybe because the filesize increases, it displaces the location of the data in the "second layer" and that's what's causing the problem? I am pretty sure the .brstm files are in the "first layer" of data.

    At any rate, I apologize for taking up your time when you replied, PPSainity. I'll experiment with this when I can (I'm gonna be pretty busy for the next several days) and post the results. I plan on replacing the 10 or so largest custom .brstm files with their originals to get the filesize down and see what happens in Subspace Emissary to see if my "threshold" theory is correct at least.

    In the meantime, if anybody has any clear idea of what's going on here, feel free to post. I don't HAVE to have custom music in Subspace Emissary. However, my friend and I got tired of Brawl's music, so that's why we decided to add something different. So if I wanted to play Subspace Emissary in the NTSC-J version, I would have to always delete the .iso and re-add an unaltered version. But then when I want to play Brawl with my friend, I would have to add the compiled .iso... [​IMG] And I prefer playing the NTSC-J version over the NTSC-U version for various reasons. I can read Japanese, so the language barrier isn't a big deal.

    Anyway, if anybody knows what would be causing this specifically, feel free to post. Thank you! [​IMG]
     

Share This Page