Hacking Updated Atmosphere from 0.9.1 to 0.9.2, now all my games have a cloud icon and need to redownloading

Rya102396

Active Member
OP
Newcomer
Joined
Oct 28, 2015
Messages
38
Trophies
0
Age
25
XP
276
Country
United States
So I just updated Atmosphere from 0.9.1 to 0.9.2 on my Switch, been using emummc. Had to edit the .ini file to get emummc to launch again, but nothing other than that changed. Before, all my installed games were working perfectly fine. Now, only the games installed on the "system memory" (emu) will run, and the rest that are installed on the SD card give me the cloud icon, with "This software is not currently on the console" if I try to launch them. Any way to get the games back other than needing to reinstall them? I'd rather not have to reinstall about 200 GB of games if I can fix it another way.
 

Rya102396

Active Member
OP
Newcomer
Joined
Oct 28, 2015
Messages
38
Trophies
0
Age
25
XP
276
Country
United States
Alright, I feel like an idiot now. Checked around all my files, and it seems like the system/hekate edited my config file to point at a completely different folder for my SD content, it seems to be all fine now, didn't think it would have done that.
 
  • Like
Reactions: NoNAND

mindmasterm

New Member
Newbie
Joined
Jul 10, 2019
Messages
3
Trophies
0
Age
41
XP
12
Country
Netherlands
Hi there,
sorry if my english is bad. I have the same problems that my nsp`s dont work and new installed nsp`s have a cloud icon.I have updated the Switch firmware to 8.1.0 and atmosphere to 0.9.2. Before i used an older version of Amtosphere and all worked. Do i need to copy the sigpatches to my SD card or what do i have to do to fix this problems?Rya102396,whats that with the config file, did you copy the sigpatches or how do you solve the problem?
 

Hayato213

( -_・) ︻デ═一' * (/❛o❛)/
Member
Joined
Dec 26, 2015
Messages
10,911
Trophies
1
Location
Vector Industry
XP
5,975
Country
United States
Hi there,
sorry if my english is bad. I have the same problems that my nsp`s dont work and new installed nsp`s have a cloud icon.I have updated the Switch firmware to 8.1.0 and atmosphere to 0.9.2. Before i used an older version of Amtosphere and all worked. Do i need to copy the sigpatches to my SD card or what do i have to do to fix this problems?Rya102396,whats that with the config file, did you copy the sigpatches or how do you solve the problem?

Update your sig patches that chrisrlink linked.
 

Hayato213

( -_・) ︻デ═一' * (/❛o❛)/
Member
Joined
Dec 26, 2015
Messages
10,911
Trophies
1
Location
Vector Industry
XP
5,975
Country
United States
before i had no sig patches for atmosphere. Did i just have to copy them into the root?

You need the sig patches to run unsigned code stuffs, every firmware update require new sig patches, copy the exefs_patches inside the atmosphere folder, and copy the fs_patches into the kip_patches folder into the atmosphere folder, there should be a nogc folder there already.
 

mindmasterm

New Member
Newbie
Joined
Jul 10, 2019
Messages
3
Trophies
0
Age
41
XP
12
Country
Netherlands
i copy the files like you say. Some of my games work, but if i install a new nsp with goldleaf i get the cloud icon once again and the new installed game doesnt work
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    Psionic Roshambo @ Psionic Roshambo: https://cooking.nytimes.com/recipes/1017619-blue-butter