Update to 1.3.0, now Mario Odyssey cannot be played

Discussion in 'Switch - Games & Content' started by bloodfalco, May 18, 2019.

  1. ZachyCatGames

    ZachyCatGames GBAtemp Advanced Maniac

    Member
    8
    Jun 19, 2018
    United States
    Hell
    firmware 1.3.0 doesn’t exist lol. 1.3.0 is the game version
     
  2. azoreseuropa

    azoreseuropa GBAtemp Guru

    Member
    11
    Nov 6, 2002
    United States
    Azores/Portugal
    Stupid of me. LOL!
     
  3. bloodfalco
    OP

    bloodfalco Advanced Member

    Newcomer
    3
    Nov 29, 2015
    Indonesia
    So, any solutions?
     
  4. MrWhosHacking

    MrWhosHacking GBAtemp Regular

    Member
    2
    May 3, 2018
    United States
    Mines works
     
  5. Jonosborne87

    Jonosborne87 Newbie

    Newcomer
    1
    May 23, 2019
    United States
    Are you using hekate or fusee for your payload injection? It sounds to me like you need to update to 8.0.1 because as far as I know the Mario update was mainly for the VR Labo features plus some new shop costumes. You may need to get new titlekeys when updating, but maybe not. Updating will potentially break all of your games, but using Fusee and Lockpick RCM should remedy that.
     
  6. bloodfalco
    OP

    bloodfalco Advanced Member

    Newcomer
    3
    Nov 29, 2015
    Indonesia
    May I know what you did, sir?
     
  7. WhoIAm

    WhoIAm Member

    Newcomer
    4
    Mar 17, 2018
    United States
    I'm surprised so many are commenting to upgrade to 8.0.1; I know for a fact that both Zelda 1.6.0 and Mario 1.3.0 do not require Switch firmware 8.x. I have been playing them just fine on 7.0.1 for weeks now.

    When I got a similar error, it was because I had mods installed for Mario. Uninstall any mods you're using for both games and try again.
     
    MrWhosHacking likes this.
  8. isoboy

    isoboy GBAtemp Advanced Fan

    Member
    6
    Dec 23, 2016
    United States
    Update to 8.0.1.
     
  9. bloodfalco
    OP

    bloodfalco Advanced Member

    Newcomer
    3
    Nov 29, 2015
    Indonesia
     
  10. WhoIAm

    WhoIAm Member

    Newcomer
    4
    Mar 17, 2018
    United States
    Hm, I don't think the location of the game should matter...I have Odyssey base installed to SD, update installed to NAND. I have Zelda's updates/DLC on SD but run the base game off the cart.

    If it's still crashing, unfortunately I don't know what could be the cause of your problem. Perhaps your sigpatches are out of date?
     
  11. bloodfalco
    OP

    bloodfalco Advanced Member

    Newcomer
    3
    Nov 29, 2015
    Indonesia
    How to update sigpatches bro? Sorry for keep asking. I am a total noob here
     
  12. WhoIAm

    WhoIAm Member

    Newcomer
    4
    Mar 17, 2018
    United States
    MrWhosHacking likes this.
  13. emuman100

    emuman100 GBAtemp Regular

    Member
    3
    May 12, 2006
    United States
    I'm on 6.2.0 using ReiNX and I get the very same error. I don't have any mods installed. I assumed it needed a later firmware version, but it installed fine on 6.2.0 without reencryption. Some say 7 is needed, some say 8. I'm curious as to why exactly it does not work. I reencrypted the Turok 2.0.3 update for 6.2.0 and got the same error.
     
  14. Swiminaha

    Swiminaha Member

    Newcomer
    1
    Nov 29, 2018
    Austria
    Austria
    hmm.. why you not patch the updates/games itself to match/fit your OfW/CfW -system? xD

    btw, SMO -update 1.3.0 "need sys ver 7.0.1" , to work prob.
     
    Last edited by Swiminaha, Jun 1, 2019
  15. emuman100

    emuman100 GBAtemp Regular

    Member
    3
    May 12, 2006
    United States
    I was able to install the update without patching for 6.2.0, but it wouldn't start. Perhaps my update was already patched when I downloaded it. Anyone else get it running on 6.2.0?
     
  16. ZachyCatGames

    ZachyCatGames GBAtemp Advanced Maniac

    Member
    8
    Jun 19, 2018
    United States
    Hell
    Getting it to run on anything below 7.0.0 is impossible, it uses a 7.x SDK and requires features added in 7.0.0
     
  17. emuman100

    emuman100 GBAtemp Regular

    Member
    3
    May 12, 2006
    United States
    We don't really know they used the 7 SDK or that it even uses features of 7 for sure. I was able to reencrypt a lot of games for 6.2.0 that install and play without issue.
     
  18. 8BitWonder

    8BitWonder Small Homebrew Dev

    Member
    10
    Jan 23, 2016
    United States
    47 4F 54 20 45 45 4D
    Pretty sure VR mode wasn't in 6.2.0, which SMO 1.3.0 definitely uses.
     
  19. emuman100

    emuman100 GBAtemp Regular

    Member
    3
    May 12, 2006
    United States
    We don't know that "VR Mode" was in any specific system firmware.
     
  20. LapCheong

    LapCheong GBAtemp Regular

    Member
    2
    Mar 6, 2019
    Australia
    Does it matter if you finally know? You still need 7.0.1 because it uses 7.0.x SDK be it if its used in the game or not. Come on....
     
Loading...