Update old A9LH install to work with new Luma 6.5??

Discussion in '3DS - Flashcards & Custom Firmwares' started by smallmedicap, Nov 6, 2016.

  1. smallmedicap
    OP

    smallmedicap Member

    Newcomer
    45
    10
    Nov 1, 2015
    United States
    The new Luma 6.5 says this:


    It works great on the last few A9LH installs. But on ones from more than a month or so ago it does not. I'm assuming that is what it means by "a compatible A9LH install".

    So how in the world do I do a new A9LH (re)install if I am on an older 11.2 A9LH?

    I tried loading various SafeA9LHInstallers from HBC. They do not load. I tried going all the way back to 2.1 with ctrtransfer, that worked fine, but when I do the A9LH install like originally it says OTP not found and cannot be dumped. Which I am assuming is because the 3DS is already hacked. I feel like I have the OTP for this 3DS on a backup disc somewhere but I cannot find it.

    I am probably missing something easy?
     


  2. el_gonz87

    el_gonz87 GBAtemp Advanced Maniac

    Member
    1,559
    929
    Aug 24, 2016
    United States
    If you have A9LH then you can load SafeA9LHinstaller as a payload from /Luma/payloads just like you would hourglass9

    Name the bin "down_safea9lhinstaller.bin" and place in sd:/luma/payloads, then boot holding down on dpad

    Follow this guide: https://plailect.github.io/Guide/updating-a9lh
     
    Last edited by el_gonz87, Nov 6, 2016
  3. smallmedicap
    OP

    smallmedicap Member

    Newcomer
    45
    10
    Nov 1, 2015
    United States
    I knew I was forgetting something easy! I feel dumb. Can't believe I forgot about start payloads (all I ever use those for is hourglass9).

    Thank you el_gonz87.

    My SafeA9LHInstaller_v2.0.3 archive does not contain a safea9lhinstaller.bin. It just has arm11.bin, arm9.bin, and arm9loaderhax.bin.


    EDIT: Ignore the below. arm9loaderhax.bin is the one I had to rename to down_SafeA9LHInstaller.bin

    And now booting without an SD card works fine.

    Thanks again el_gonz87.

    [IGNORE]I am assuming that arm11.bin is the one I rename to down_safea9lhinstaller.bin since arm11.bin is the one that is ran in the original install step in the guide? And arm9loaderhax.bin I should replace with a current one?[/IGNORE]
     
    Last edited by smallmedicap, Nov 6, 2016
  4. el_gonz87

    el_gonz87 GBAtemp Advanced Maniac

    Member
    1,559
    929
    Aug 24, 2016
    United States
    I believe you should use the one in the guide, once you have a9lh installed you shouldn't need the OTP to update, so you can use the one referenced in the guide which should be the latest release
     
  5. Windylacine

    Windylacine GBAtemp Regular

    Member
    258
    62
    Apr 15, 2016
    -snip-
     
    Last edited by Windylacine, Nov 6, 2016
  6. smallmedicap
    OP

    smallmedicap Member

    Newcomer
    45
    10
    Nov 1, 2015
    United States
    Thank you windylacine!

    (Though I figured that out via trial and error about 30 seconds before you posted.) :~)


    Again, thank you both. It is now working fine (booting without SD card works).
     
    Last edited by smallmedicap, Nov 6, 2016
    Windylacine and el_gonz87 like this.
  7. kalkito

    kalkito Member

    Newcomer
    13
    2
    Sep 29, 2016
    Hi. I'm still using A9LH v2 with 11.2.0.35 (I followed the popular guide)
    What are the advantages of updating to v3 and Luma 6.5 besides boot without sdcard? (Using N3DS only to play installed games via freeshop).
     
  8. Windylacine

    Windylacine GBAtemp Regular

    Member
    258
    62
    Apr 15, 2016
    I think it might be able to prevent official system updates from overwriting NATIVE FIRM1 and 0 without SD card inserted, I could be wrong if @Aurora Wright say otherwise.
     
  9. Bryon15

    Bryon15 GBAtemp Maniac

    Member
    1,158
    106
    Aug 9, 2010
    United States
    united states
    Hi. I followed the guide and got this error when trying to update

    http://i.imgur.com/YwRkKHq.jpg
     
  10. Windylacine

    Windylacine GBAtemp Regular

    Member
    258
    62
    Apr 15, 2016
    Did you check a9lh folder to make sure there is payload_stage1.bin in there, if not then check release.7z again and copy both payload_stage1.bin and payload_stage1.bin.sha to a9lh folder.
     
  11. Bryon15

    Bryon15 GBAtemp Maniac

    Member
    1,158
    106
    Aug 9, 2010
    United States
    united states
    I did it. It worked. That part wasn't specified in the guide.
     
  12. Windylacine

    Windylacine GBAtemp Regular

    Member
    258
    62
    Apr 15, 2016
    that's good then!
     
  13. Redferne

    Redferne GBAtemp Advanced Fan

    Member
    707
    234
    Oct 28, 2015
    Yes it is...
     
    Quantumcat and KunoichiZ like this.
  14. Bryon15

    Bryon15 GBAtemp Maniac

    Member
    1,158
    106
    Aug 9, 2010
    United States
    united states
    Oops! You're right. I don't know how I missed it.
     
    Last edited by Bryon15, Nov 7, 2016
  15. Altairseven

    Altairseven GBAtemp Regular

    Member
    124
    29
    Jan 21, 2016
    Argentina
    it would be nice if the guide said "copy the content of arm9loaderhax's release.7z inside the a9lh folder of the sd"

    because the actual name of the zip file may cause confusion, specialy because every other file in the guide is named exactly as the guide describes.
     
    Quantumcat and KunoichiZ like this.
  16. LoDeus

    LoDeus Advanced Member

    Newcomer
    89
    25
    Feb 2, 2016
    Belgium
    I can't boot with luma 6.5, any fix for that? :/
     
  17. Redferne

    Redferne GBAtemp Advanced Fan

    Member
    707
    234
    Oct 28, 2015
    I don't know, turn on your console?
    Or give us some information because so far we are not very good with cristal balls...
    I can boot so you did something wrong.
     
  18. Ryccardo

    Ryccardo WiiUaboo

    Member
    3,057
    1,468
    Feb 13, 2015
    Italy
    Imola
    The other advantage (compared to the old official a9lh from late may) is not having to choose screeninit or not: naming the boot file arm9loaderhax.bin means noscreeninit, naming it arm9loaderhax_si.bin means yes

    If you only use Luma as the arm9loaderhax.bin and don't care for booting from internal memory, you don't really need to update a9lh
     
    Last edited by Ryccardo, Nov 10, 2016
    kalkito likes this.
  19. LoDeus

    LoDeus Advanced Member

    Newcomer
    89
    25
    Feb 2, 2016
    Belgium
    Well, I first used luma updater and it updated and backed up the arm9loaderhax.bin file then I rebooted, the config panel was there, I put on the ones needed and then pressed start to save and reboot and then, after the splashing screen, it always stay at black screen, it just doesn't boot, so I use GodMode9 to restore the backup, but it is pretty annoying to be unable to update. About my console, it is n3ds, a9lh (since not so long after its release but updated a few days ago from v2 to v3 if I'm not mistakin) and sys 11.2
     
  20. Redferne

    Redferne GBAtemp Advanced Fan

    Member
    707
    234
    Oct 28, 2015