Update Luma3ds from 5.2 to 6.6

Discussion in '3DS - Flashcards & Custom Firmwares' started by PerfectZygarde, Jan 5, 2017.

  1. PerfectZygarde
    OP

    PerfectZygarde Newbie

    Newcomer
    3
    0
    Jan 5, 2017
    New Zealand
    First of all I would like to say that I am very new at this so I am sorry if any of the questions I ask seem stupid

    I bought a second hand 3ds with luma3ds on it via Homebrew launcher (NOT AL9H). Everything works well but when I try to access the internet in a game I get

    Error Code: 002-0119
    In order to use this service, a system update it required.
    To perform a system update, select System Update from Other Settings in System Settings

    The firmware came fully updated (11.2.2-35U) and the previous owner said they cant help me since they have never had to update it themselves.

    After some research of my own I found out that I need to update to the latest 6.6 release of luma3ds. I found the files (https://github.com/AuroraWright/Luma3DS/) releases but I don't know what to do with them. My current version of luma3ds is 5.2.

    Thanks
     
  2. x65943

    x65943 Resident Greekaboo, Amateur Dog Father

    Member
    2,452
    1,952
    Jun 23, 2014
    United States
    Indiana
    Take the arm9loaderhax.bin and place it on the root of your sd card (replacing the file that is already there)
     
  3. henrytlh

    henrytlh Advanced Member

    Newcomer
    56
    2
    Nov 15, 2009
    Malaysia
    Look for the application "Luma Updater" in your 3DS home menu, if you see it, run it and download the latest stable build. it should be updated. Else, just download Luma3dsv6.6.7z from this link https://github.com/AuroraWright/Luma3DS/releases then replace the arm9loaderhax at your root SD card.
     
  4. PerfectZygarde
    OP

    PerfectZygarde Newbie

    Newcomer
    3
    0
    Jan 5, 2017
    New Zealand
    Thanks but that doesn't work since like I said it isn't AL9H so there is no arm9loaderhax.bin file and if I just put the new file it doesn't do anything.

    — Posts automatically merged - Please don't double post! —

    Thanks but there is no Luma Updater on my 3ds and like I said before the arm9loaderhax.bin file doesn't work.
    The only extra apps on my 3ds are FBI, The Homebrew Launcher, Dev Men, and SDK Devkit Tools.

    Also I can download apps from the E Shop but the internet only doesn't work in games.
     
  5. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,396
    4,730
    Mar 17, 2010
    Norway
    Alola
    Put the "3ds" folder, launcher.dat and arm9loaderhax.bin on the SD card (arm9loaderhax.bin is apparently still needed by the latest Luma even if you don't have A9LH)
     
  6. PerfectZygarde
    OP

    PerfectZygarde Newbie

    Newcomer
    3
    0
    Jan 5, 2017
    New Zealand
    Where is the launcher.dat file? I can't find it in the 6.6 files. Do you mean luma3ds.dat? If so I have put the 3ds folder, luma3ds.DAT file and armloaderhax.bin file on the root of the SD but it doesn't work. All I get is a blank screen.
     
  7. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,396
    4,730
    Mar 17, 2010
    Norway
    Alola
    Sorry, yes, I meant Luma3DS.dat.
    Edit: You should follow the instructions under "I get a black screen on boot" here: https://github.com/AuroraWright/Luma3DS/wiki/FAQ-and-troubleshooting
    You should make sure to do these steps on emuNAND.
    I would also recommend installing A9LH: http://3ds.guide/
     
    Last edited by The Real Jdbye, Jan 5, 2017
  8. Lilith Valentine

    Lilith Valentine GBATemp's Wolfdog™ I drool on my knife

    Member
    19,326
    19,606
    Sep 13, 2009
    Antarctica
    Between insane and insecure