Thread Status:
Not open for further replies.
  1. Ashikoki

    Ashikoki Member
    Newcomer

    Joined:
    Jan 15, 2016
    Messages:
    12
    Country:
    United States
    Signing on to NNIND doesn't work on HANS 10.3 eshop. Still can't download updates.
     
  2. Deleted User

    Deleted User Newbie

    I can confirm for you that APT:IsTitleAllowed does not have any sort of list to update. The titles and versions it blocks are hardcoded into the NS system module, requiring a system update to change.
     
    democracy and lanman14444 like this.
  3. TheCyberQuake

    OP TheCyberQuake Certified Geek
    Member

    Joined:
    Dec 2, 2014
    Messages:
    5,012
    Country:
    United States
    If you are cooldbooting, my guess is you did something invovling you modifying your boot.3dsx file so that menuhax boots into emuNAND instead of HBL. Updating wouldn't affect that (if the NANDs are unlinked). I'd say if you are using menuhax to coldboot (which is the most common method) that's the most likely cause, which means you would have to replace the boot.3dsx with the standard one, and then modify the payload of menuhax to instead launch your modified boot.3dsx, which you would have to rename to something else that is four letters. So all other exploits could still access the proper boot.3dsx, but menuhax would load the modified payload and load the emuNAND.

    And yes, if you create a backup you can simply inject to old 10.3 backup back into emuNAND if you don't like 10.4
     
  4. bunny_gg

    bunny_gg Advanced Member
    Newcomer

    Joined:
    Jan 20, 2016
    Messages:
    64
    Country:
    Switzerland
    "Memchunkhax2, the kernel exploit used mostly for downgrading and to install legit CIAs, has been patched"
    Does that mean I cannot install legit CIA via FBA or NASA on 10.4.0 by now?
     
  5. Exploithunter_69

    Newcomer

    Joined:
    Jan 20, 2016
    Messages:
    5
    Country:
    United States
    OK I'm fairly new to the 3ds scene and I was wondering what exploits can I do on system version 9.2? Thanks in advance.
     
  6. kratoz29

    kratoz29 GBAtemp Regular
    Member

    Joined:
    May 23, 2014
    Messages:
    147
    Country:
    Mexico
    Can you explain me this? Where do I get the standard boot.3dsx.

    I also got confused cause at first you've said that I wouldn't need anything if I've been using MenuHax, which I do.

    That's the most satisfying thing I've could ever read this week, that's a godsend that I definitely hadn't a clue.
     
  7. TheCyberQuake

    OP TheCyberQuake Certified Geek
    Member

    Joined:
    Dec 2, 2014
    Messages:
    5,012
    Country:
    United States
    You basically have free range to do anything you want if you have 9.2. Although this thread isn't really the place to post it. I highly recommend looking into emuNAND and Custom Firmware (CFW). Have and emuNAND and CFW will allow you to install and run any cia file, meaning you can install homebrew straight to your home menu (or pirated games, hey I won't judge I did my fair share of piracy when I was younger)
    https://gbatemp.net/threads/tutorial-installing-rxtools-custom-firmware-3ds-and-2ds.390867/
    That's if you are on o3ds


    You can get the original boot.3dsx from the starter kit, found on http://smealum.github.io/3ds/
    You can take your old boot.3dsx and call it something else, like emun.3dsx. Then open your menuhax payload (ropbingpayload_menuhax_x.bin, where x is region and other stuff) by right clicking, open with, and open with notepad. Ctrl + f to search, and search for boot.3dsx. Replace that with emun.3dsx, there should be two of them in there so replace both. Save the file, the place boot.3dsx, emun.3dsx (which is just a renamed version of your old boot.3dsx) and the ropbinpayload_menuhax_x.bin back onto the root of your sd card. That should cause menuhax to load whatever it did before, but still allow all other entry points to properly access HBL
     
    Last edited by TheCyberQuake, Jan 20, 2016
  8. 128bit_benny

    128bit_benny Member
    Newcomer

    Joined:
    Aug 16, 2014
    Messages:
    43
    Country:
    Gambia, The
    For buying a New 3ds console, is the Browser a dummy , like in card uodates, so i need to update to 10.4, or fully functional?
     
  9. TrashyClassy

    TrashyClassy Professional Shitposter
    Member

    Joined:
    Sep 26, 2015
    Messages:
    207
    Country:
    Malaysia
    Nooo

    — Posts automatically merged - Please don't double post! —

    Sadly, yes.
     
  10. 128bit_benny

    128bit_benny Member
    Newcomer

    Joined:
    Aug 16, 2014
    Messages:
    43
    Country:
    Gambia, The
    Yes dummy or yes fully functional pre installed? :)
     
  11. TrashyClassy

    TrashyClassy Professional Shitposter
    Member

    Joined:
    Sep 26, 2015
    Messages:
    207
    Country:
    Malaysia
    Actually i wasnt talking to you, i dont know anything about the new 3ds browser since im using old3ds instead
     
    128bit_benny likes this.
  12. TheCyberQuake

    OP TheCyberQuake Certified Geek
    Member

    Joined:
    Dec 2, 2014
    Messages:
    5,012
    Country:
    United States
    Well I need some sleep. Once I wake up and finish a little homework for sociology, I'll sign back on and continue searching for info. I also uploaded a video to hopefully warn the youtube community who don't go on GBATemp. Just briefly covered a few known "fixes", and then a link leading to this thread.

    Also you get to hear my fantastic man-child voice. (Seriously I don't sound 19, at least to me)
    I don't know anything about the 3ds and it's default out-of-box browser.
     
  13. rObOu

    rObOu Member
    Newcomer

    Joined:
    Mar 14, 2009
    Messages:
    32
    Country:
    France
    Has anyone successfully upgraded an o3DS emunand from 9.2 to 10.4?
    I get a black screen after the opening home menu loading screen. Using RxTools.
     
  14. Insidious611

    Insidious611 GBAtemp Regular
    Member

    Joined:
    Oct 23, 2010
    Messages:
    166
    Country:
    United States
    Reporting that I updated my EmuNAND to 10.4 and the HBL CIA is still working after replacing the payload. The payload seems to have a slightly lower boot rate now though? I get more yellow screens when launching HBL from the installed CIA.

    O3DS (2DS actually), running rxTools

    Thanks for clearing that stuff up for me, re: the HBL CIA, can't believe I believed that line in bull that the launcher was blocked on 10.4.

    In case anything breaks I have a 10.3 EmuNAND backup. This probably goes without saying but anyone with an EmuNAND *make a backup before running the update*. It's probably going to be fine but you can never be too careful.

    Of course, worst comes to worst you just have to clone your SysNAND and make a new EmuNAND on 9.2 or whatever.
     
    Last edited by Insidious611, Jan 20, 2016
  15. mashers

    mashers Stubborn ape
    Member

    Joined:
    Jun 10, 2015
    Messages:
    3,837
    Country:
    Sky3DS can't run homebrew.
     
  16. Insidious611

    Insidious611 GBAtemp Regular
    Member

    Joined:
    Oct 23, 2010
    Messages:
    166
    Country:
    United States
    It can run Cubic Ninja, which can then be used to run homebrew. But the bit about "If they ever patch cubic ninja" is kind of wrong though.
     
  17. DjoeN

    DjoeN Captain Haddock!
    Member

    Joined:
    Oct 21, 2005
    Messages:
    5,490
    Country:
    Belgium
    @TheCyberQuake

    You should mention that CakesCFW from @mid-kid also works with EmuNAND 10.4 in the OP

    What has been confirmed:
    • Latest CakesCFW build works with 10.4 in emuNAND on Old 3ds and New 3ds (use correct firmware.bin for your system)
     
    Last edited by DjoeN, Jan 20, 2016
  18. mashers

    mashers Stubborn ape
    Member

    Joined:
    Jun 10, 2015
    Messages:
    3,837
    Country:
    Running Cubic Ninja != running homebrew. The post I quoted said that with Sky3DS "you could still use .3ds homebrew, which could probably launch HBL straight from a .3ds rom", which is incorrect. Sky3DS does absolutely nothing to exploit the system itself. It just emulates a cart, and does not work with 3ds homebrew.
     
  19. leonshong

    leonshong Member
    Newcomer

    Joined:
    Jan 2, 2016
    Messages:
    11
    Country:
    Taiwan
    • Gateway 10.4 emuNAND works with updated Launcher.dat (chizco06)
    I confirm that, too.

    Both my N3DSLL JPN with sysNAND 9.1 start from cold-boot through MenuHax into HBL, then boot into emuNAND 10.4 via Gateway Ultra fw 3.71 successfully.

    Even my moded themes-set by CHMM2 works fine at the first boot into emuNAND 10.4 :)
     
  20. DjoeN

    DjoeN Captain Haddock!
    Member

    Joined:
    Oct 21, 2005
    Messages:
    5,490
    Country:
    Belgium
    Just to add a note to it ;)

    You can write Cubic Ninja or Zelda OoT to Sky3DS(+) and launch HBL through this, since it acts like a real gamecart
    but like @mashers said, Sky3DS itself can't launch homebrew cause it doesn't do a thing for this. it doesn't even run eShop games, only retail gamecart dumps.

    So next Nintendo can do: Send out Updates for Cubic Ninja and Zelda OoT, add it to APT and it's game over for those to. pretty smart move from Nintendo and i suppose and not including a gamelist to, cause this can be hacked (i think)
     
    Last edited by DjoeN, Jan 20, 2016
Loading...

Hide similar threads Similar threads with keywords - Homebrew, Update,

Thread Status:
Not open for further replies.