Update 10.4 and Homebrew: What you need to know

Discussion in '3DS - Flashcards & Custom Firmwares' started by TheCyberQuake, Jan 20, 2016.

Thread Status:
Not open for further replies.
  1. TheCyberQuake
    OP

    TheCyberQuake Certified Geek

    Member
    3,117
    1,962
    Dec 2, 2014
    United States
    Las Vegas, Nevada
    Yesterday evening, Nintendo graced our 3ds consoles with update 10.4, leaving everyone in the homebrew community freaking out and in complete chaos. So I decided to create this post to list exactly what has been "fixed" by Nintendo to make the system more "stable".
    This list is being compiled as a single source from the multitude of other posts in order to bring them all into one place (mostly from replies from this thread: http://gbatemp.net/threads/new-update.410953/)

    UPDATE:
    Browserhax and Menuhax were just updated, and both now fully work on 10.4 for old and new 3ds.

    What has been confirmed:
    • Memchunkhax2, the kernel exploit used mostly for downgrading and to install legit CIAs, has been patched
    • Browserhax does not work on New 3ds
    • Ironhax is effectively dead, due to the system requiring you to update it to its latest version before being allowed to launch it: Only affects Ironfall (https://www.3dbrew.org/wiki/APT:IsTitleAllowed)
    • oot3dhax, and ninjhax still work once you update payloads
    • Browserhax still works on Old 3ds
    • rxTools emuNAND and reiNAND are safe to upgrade to 10.4 on old 3ds
    • reiNAND 3.1 works with 10.4 in emuNAND on New 3ds (Cornholio309)
    • eShop is still accessible on 10.3 through Hans on Old 3ds (Captain_N)
    • Gateway 10.4 emuNAND works with updated Launcher.dat (chizco06)
    • APT:IsTitleAllowed has titles and versions hardcoded into NS system module, meaning they won't be able to block any more game save entry points without another system update (Steveice10)

    Currently unconfirmed:
    • Status of Menuhax for Old 3ds
    • Status of Smashhax
    Please let me know if you are either able to confirm/deny any info, or have new info to add to the list.

    At this point it seems the best course of action is to stay on 10.3, downgrade to 9.2 and install CFW with emuNAND, which you can safely update to 10.4 on Old 3ds, and some emuNANDs on New 3ds

    If you are using oot3dhax, update your payload BEFORE upgrading
    This can be done by running HBL and using the oot3dhax installer, and choosing the firmware you will upgrade to. Do this before you upgrade firmware, as not doing so may leave you with no way to upgrade your payload (or at least no easy way to do so)





    So basically Ninty is now trying to fix the exploitability of the system. So far it doesn't affect a whole lot, but that doesn't mean they will never add more "stability" to the system. For now stay away from 10.4 if you can. (Thanks Joesphvb10 for notifying me about the tweets)

    F.A.Q.
    Q:
    How can I update my oot3dhax payload?
    A: If you still have access to HBL, simply run the oot3d sploit installer and select the appropriate firmware. If you don't have access, you'll have to build a save file and use a USB Save Dongle to put it onto the cartridge. Typically, if you previously had the exploit running on oot3d, you want to update the payload BEFORE upgrading your firmware.

    Q: How do I build the save file for oot3d?
    A: Can't help you there. Either try to follow the instructions on this page, or try to find someone who already built it and posted it online. You can also try to find a friend who hasn't updated, and go from there.

    Q: How can I downgrade from 10.4?
    A: You can't. The kernel exploit used from 9.3-10.3 to downgrade firmware (memchunkhax2) was patched as of 10.4. So for now it is impossible. This also makes it impossible to install legit cia files.
     
    Last edited by TheCyberQuake, Jan 25, 2016
    RockSplinter, ant888, klear and 22 others like this.


  2. LarBob

    LarBob GBAtemp Fan

    Member
    344
    158
    Dec 29, 2013
    United States
    How do I update the payloads for oot3dhax?
    btw, thanks for the thread
     
  3. Ar7ific1al

    Ar7ific1al GBAtemp Regular

    Member
    131
    42
    Jul 12, 2009
    United States
    Great to find all of this in one place instead of browsing dozens of pages and finding a lot of misinformation. Thank you.
     
  4. TheCyberQuake
    OP

    TheCyberQuake Certified Geek

    Member
    3,117
    1,962
    Dec 2, 2014
    United States
    Las Vegas, Nevada
    If you can access HBL through another method, you can use the oot3dhax installer to update the payload. Simply select the firmware you are trying to use it on, and install it again.
     
  5. LarBob

    LarBob GBAtemp Fan

    Member
    344
    158
    Dec 29, 2013
    United States
    So if I have a 2DS on, say, 9.2, I could use HBL to install the 10.4 payload on to the cart and then use it on my N3DS?
     
  6. TheCyberQuake
    OP

    TheCyberQuake Certified Geek

    Member
    3,117
    1,962
    Dec 2, 2014
    United States
    Las Vegas, Nevada
    I was getting tired of the complete pandemonium, so I read through pretty much all of the pages in the original forum post, trying pull things that were actually confirmed by someone.

    Yes
     
    Ar7ific1al likes this.
  7. PandaMayFire

    PandaMayFire GBAtemp Regular

    Member
    287
    86
    Jan 24, 2015
    United States
    This saved me a lot of time, looks like I'm still good to go for the time being :D
     
  8. LarBob

    LarBob GBAtemp Fan

    Member
    344
    158
    Dec 29, 2013
    United States
    Alright, thanks. Looks like it's time to buy oot3d ;)
     
  9. Angelikita

    Angelikita Advanced Member

    Newcomer
    68
    9
    Aug 17, 2015
    Mexico
    Soooo.... Ironfall is the only game with a necesary update?
     
  10. sweis12

    sweis12 GBAtemp Maniac

    Member
    1,242
    513
    Oct 20, 2013
    Saint Kitts and Nevis
    If you are on 10.4, sell the piece of shit ( it may as well be a brick ) and buy something on a lower firmware.
     
  11. TheCyberQuake
    OP

    TheCyberQuake Certified Geek

    Member
    3,117
    1,962
    Dec 2, 2014
    United States
    Las Vegas, Nevada
    Yes. In simple terms Nintendo added a blacklist of games that can't run unless they are updated, and Ironfall is currently the only game in that list.
     
  12. Angelikita

    Angelikita Advanced Member

    Newcomer
    68
    9
    Aug 17, 2015
    Mexico
    Thaks, i dont even have that game
     
  13. Cornholio309

    Cornholio309 GBAtemp Regular

    Member
    194
    50
    Jun 23, 2013
    United States
    I should add that ReiNAND 3.1 (and only ReiNAND 3.1 at the moment - no rxTools!) works with 10.4 in EmuNAND on a New 3DS. I updated it just to get eShop access easily and it works completely fine.

    rxTools plans to have >9.6 EmuNAND support for New 3DS systems as well in a later update.

    Note that the information about rxTools only applies to a New 3DS. EmuNAND 10.4 on rxTools will work just fine for Original 3DSes.
     
    Last edited by Cornholio309, Jan 20, 2016
  14. LarBob

    LarBob GBAtemp Fan

    Member
    344
    158
    Dec 29, 2013
    United States
    nty it has my nnid and all my games. I have a 2ds on 9.2 so it's not that big deal if I can't use hax on the N3ds, but if I can use hax then it might as well
     
  15. Tapri

    Tapri GBAtemp Regular

    Member
    100
    46
    Oct 15, 2015
    United States
    Pretty much, in 10.4, they've made it where if ironfall is on 1.0 or 1.1, then it forces you to update to the latest, effectively removing ironfall from homebrew access as of 10.4, anything prior shouldn't cause this i don't believe.
     
  16. TheCyberQuake
    OP

    TheCyberQuake Certified Geek

    Member
    3,117
    1,962
    Dec 2, 2014
    United States
    Las Vegas, Nevada
    It's only enforced in 10.4, and it's only for Ironfall.
    So if you are on 10.3, you can still use Ironhax, and if you are on 10.4 it will not affect any other installed item (at least for now)
     
  17. markh78

    markh78 Member

    Newcomer
    12
    3
    Dec 25, 2015
    Just the thread I was looking for.
    Since I have Cubic Ninja and only interested in hbl for emu and save edit, I guess I can just update my n3ds.
     
  18. Chizko

    Chizko GBAtemp Regular

    Member
    113
    28
    Jan 24, 2015
    Chile
    ???? ??? ???
    ReiNand 3.1 works for me in N3DS 10.4 emunand, but the first time the update brick me emunand, backup the emunand before update.
     
    Last edited by Chizko, Jan 20, 2016
  19. TheCyberQuake
    OP

    TheCyberQuake Certified Geek

    Member
    3,117
    1,962
    Dec 2, 2014
    United States
    Las Vegas, Nevada
    Backing up an emuNAND before updating it should be common practice
     
  20. Chizko

    Chizko GBAtemp Regular

    Member
    113
    28
    Jan 24, 2015
    Chile
    ???? ??? ???
    fortunately i have it
     
Thread Status:
Not open for further replies.