up to 4.x exploitable, but lower firmware is better

Discussion in 'Switch - Hacking & Homebrew' started by blinkzane, Jan 13, 2018.

  1. Akuseru06

    Akuseru06 Member

    Newcomer
    30
    5
    Jan 8, 2018
    Romania
    When i got the console i was on 3.0.2 but updated because someone said its the end of exploits but thank you for this thread i will stay on 4.1.0 anyway . :yayswitch:
     
  2. SomeKindOfUsername

    SomeKindOfUsername Advanced Member

    Newcomer
    63
    46
    Aug 10, 2014
    United States
    What do you mean you aren't releasing this right now so I can get my free games?! Tell me, what else am I supposed to do with my Switch?
     
  3. Akuseru06

    Akuseru06 Member

    Newcomer
    30
    5
    Jan 8, 2018
    Romania
    They don't promote piracy.
     
  4. SomeKindOfUsername

    SomeKindOfUsername Advanced Member

    Newcomer
    63
    46
    Aug 10, 2014
    United States
    I guess I'll add in a /s just in case.
    Although to be brutally honest, everybody knows this will inevitably lead to that no matter how hard they try to prevent it.
     
    Last edited by SomeKindOfUsername, Jan 13, 2018
  5. leon315

    leon315 POWERLIFTER

    Member
    1,263
    759
    Nov 27, 2013
    Italy
    why?
     
  6. Meriadoc

    Meriadoc Advanced Member

    Newcomer
    73
    17
    May 14, 2016
    Italy
    Why in firmware with kernelhax (2.0-2.3) there won't be a cfw/emunand?
     
  7. blinkzane
    OP

    blinkzane Panic at your moms house

    Member
    GBAtemp Patron
    blinkzane is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    898
    373
    Jul 24, 2012
    United States
    Florida
    This is purely an informative post BTW, not intended to direct in one direction or another and I am unbiased on who does what because I dont really care.
     
    DayVeeBoi and Akuseru06 like this.
  8. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    24,472
    11,989
    Apr 29, 2011
    United States
    Dr. Wahwee's castle
    Interesting, maybe there is hope for 4.x.x after all. Gonna keep a close watch on this news.
     
    Akuseru06 and blinkzane like this.
  9. thekarter104

    thekarter104 GBAtemp Maniac

    Member
    1,407
    421
    Mar 28, 2013
    United States
    Holy crap, that is nice. I'm currecntly on 4.x because Gamecube controller support, and it appears I need it anyways, otherwise we couldn't have a 4 player MK8 Deluxe with friends.
    Time to stay on 4.x!

    EDIT: Is there any known way to block updates on the Switch?
    Is it also possible that it unfortunately may be autoupdated?

    Thanks.
     
    Last edited by thekarter104, Jan 13, 2018
    the_randomizer and Akuseru06 like this.
  10. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    24,472
    11,989
    Apr 29, 2011
    United States
    Dr. Wahwee's castle
    Short of disconnecting the console from the WiFi network, not much else can be done to block updates right now. I've already disconnected, and I'm on 4.0.2 I believe, so I may be pushing it or already past the point of no return. Do not stay connected if you want to avoid updates.

    If you're on 4.0.0, or 4.1.0, disconnect immediately.
     
    Last edited by the_randomizer, Jan 13, 2018
  11. Akuseru06

    Akuseru06 Member

    Newcomer
    30
    5
    Jan 8, 2018
    Romania
    You say it like Nintendo is ready to make an update today for the switch to patch 4.x.x :gun:
     
  12. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    24,472
    11,989
    Apr 29, 2011
    United States
    Dr. Wahwee's castle
    You can never be too safe. Disconnecting is still better safe than sorry.
     
  13. Akuseru06

    Akuseru06 Member

    Newcomer
    30
    5
    Jan 8, 2018
    Romania
    I know .
    But i am stupid because i was on 3.0.2 and updated now i learned something
    I need to stay on 4.x
     
  14. Patatas

    Patatas Newbie

    Newcomer
    9
    12
    Jan 8, 2018
    Spain
    Or you can set up a DNS to block updates on your wifi settings:

    I can't post a link because I don't have and old account (even though I've been around for a lot of time without an account), so this should do:

    gbatemp.net/threads/dns-to-block-the-updates-of-the-switch.465952/
     
    DarthDub likes this.
  15. SimonMKWii

    SimonMKWii GBAtemp Regular

    Member
    166
    233
    Nov 18, 2017
    Australia
    Melbourne, Victoria
    NVIDIA, obviously!
    Why would people hacking the US government give two shits about a game console?
     
  16. Kourin

    Kourin Touhou Maniac

    Member
    942
    631
    Jan 24, 2016
    Australia
    Ripple Star
    "Haha, we have a 4.1 exploit but we're not gonna talk about it in any meaningful way for as long as possible"
    Then don't mention it, plain and simple. There's nothing more annoying than hackers stroking their ego about having something that others don't. You'll be the first ones to complain when people hassle you about it too.
     
  17. yardie

    yardie GBAtemp Maniac

    Member
    1,306
    1,334
    Mar 27, 2016
    United States
    Maybe he's just trying to tell people who wants Homebrew to not update

    No need to be a dick man
     
  18. GarnetSunset

    GarnetSunset Advanced Member

    Newcomer
    88
    127
    Apr 27, 2017
    United States
    On the topic of 4.1. I have that FW rn. If you A. don't have the money for a <3.0.1 console B. don't care enough to find one (me) then just hold out.

    Lemme put it this way, them having a private exploit on 4.1 means they can bring it forward to 4.2 etc, it's useful for testing purposes. They can use it to make public exploits for 4.2 aswell! Just be patient my friends. :)
     
    DarthDub, blinkzane and VinsCool like this.
  19. Patatas

    Patatas Newbie

    Newcomer
    9
    12
    Jan 8, 2018
    Spain
    Yep, he explained that perfectly clear. They use that private exploit and don't want it to be patched by revealing it. If it gets patched, they will release it as it will be no longer useful for them. Since they are the ones who found it, I think they have the right to look over their interest rather than yours.

    Plus it might make the exploit available on further firmwares, would you rather lose it so people can start using the really few and early homebrew available? It's not stroking their ego, it's thinking long term.
     
    X2XO, DarthDub, rogerramjet and 2 others like this.
  20. Slartibartfast42

    Slartibartfast42 GBAtemp Advanced Fan

    Member
    880
    247
    Mar 6, 2013
    United States
    And how do you prevent children from updating? And how do you prevent it from updating itself?
     
Loading...