Unlinked SysNAND wont let me install .cia files, yet the emuNAND works great

Discussion in '3DS - Homebrew Development and Emulators' started by duffmmann, Oct 19, 2015.

  1. duffmmann
    OP

    duffmmann GBAtemp Psycho!

    Member
    3,688
    1,511
    Mar 11, 2009
    United States
    So I've unlinked my SysNAND in order to have my 3DS coldboot back into my emuNAND any time I exit something that would otherwise not direct me back to the EmuNAND (such as my DS flashcard, and hopefully DSiware and GBA titles). The problem is, in order to get the GBA and DSiWare titles working again I have to reinstall the patched agb file to both the sysnand and the emunand, along with whichever dsiware and gba titles I want installed. Consequently, I have to re-enter the sysnand and install a few .cias, but I'm unable to install any .cias, every time I get the error Summary_Wrong_argument (0x8)

    My info is that I'm on a N3DS XL U, both the sysNAND and emuNAND are 9.0. I spoofed the eShop on the sysNAND via NTR and downloaded a free titles in order to make sure there was a title.db file in order to allow any .cia files to be installed via the fbi installer from the homebrew launcher after I launch pasta cfw with firmlaunch from cubic ninja 1.1b

    Anyone know what I could possibly be missing to give me the error I'm receiving and inability to install any .cia files to the sysNAND? As I mentioned I'm using the version of themehax that coldboots into the unlinked emuNAND, where you don't even have to hold L or anything like that. I don't know if that's important or not, but I thought it might be worth noting.
     
    Last edited by duffmmann, Oct 19, 2015
  2. rotebrotobias

    rotebrotobias GBAtemp Maniac

    Member
    1,039
    256
    Jan 31, 2015
    Open your SD card and go to Nintendo 3DS folder. There should be 2 folders there since you have sysNAND and emuNAND. Right click on each of them and check which is the biggest.
    The smaller one should be sysNAND, so open that and open the second, then create a folder there called dbs and inside that folder make a blank file called either title.db or import.db.
    On your 3DS, go to System Settings -> Data Management -> 3DS titles and it will say something with corrupted. Click fix or whatever it says.

    Now you should be able to install cia files again in sysNAND.
     
  3. duffmmann
    OP

    duffmmann GBAtemp Psycho!

    Member
    3,688
    1,511
    Mar 11, 2009
    United States
    This does not appear to be the issue, I already had the file.db and import.db files and going into the settings and data management didn't say anything was corrupted or anything like that. Not sure what else it could be though.
     
  4. rotebrotobias

    rotebrotobias GBAtemp Maniac

    Member
    1,039
    256
    Jan 31, 2015
    Check both folders in the Nintendo 3DS folder. The one without dbs folder should be the sysNAND folder.
     
  5. duffmmann
    OP

    duffmmann GBAtemp Psycho!

    Member
    3,688
    1,511
    Mar 11, 2009
    United States
    There are more than 2 folders, but they all have the dbs folder with the title.db and import.db files, so that is not the issue.
     
  6. rotebrotobias

    rotebrotobias GBAtemp Maniac

    Member
    1,039
    256
    Jan 31, 2015
    Then i have no idea what could be wrong.
     
  7. duffmmann
    OP

    duffmmann GBAtemp Psycho!

    Member
    3,688
    1,511
    Mar 11, 2009
    United States
    Thanks anyway
     
  8. duffmmann
    OP

    duffmmann GBAtemp Psycho!

    Member
    3,688
    1,511
    Mar 11, 2009
    United States
    I figured out what my problem was, I should have had firmlaunch off, not on. Now I know. I'll leave this note here in case anyone else ever discovers themself with the same issue.