Uneek DI boots into black screen

Discussion in 'Wii - Hacking' started by Taleweaver, Mar 15, 2011.

Mar 15, 2011
  1. Taleweaver
    OP

    Member Taleweaver Storywriter

    Joined:
    Dec 23, 2009
    Messages:
    5,121
    Location:
    Belgium
    Country:
    Belgium
    Well...like I mentioned in another thread: my uneek nand blackscreens on me now. More specifically: when booting, I get the usual "press A to continue" message (the red wii theme). After I press A, the actual system menu just doesn't load anymore. It worked fine until I did some stuff to it.

    It started some days earlier. I noticed that some of my wads black screened. It was kinda strange as to why, as it wasn't just "out of region". But it wasn't the worst issue. Besides: most of them worked fine. Such as the HBC, and priiloader's installation (although priiloader is kinda buggy when it comes to editting system settings).

    Yesterday evening, I was checking out which homebrew worked on that emulated setup. MMM was one of them. Then I noticed it had an option to edit priiloader. Within it, the option to change (and actually save) the system menu hacks. The first attempt (the automatic "press A on the health screen" hack) worked fine. So I added 3 more: block system updates, block disc updates and the region free everything hack. Since I had uninstalled the non-working wads, I also reinstalled those with showmiiwads.


    ...and that's when the actual system menu refused to come up.

    At first, I didn't worry too much about it. I tried booting into uneek priiloader by holding the reset button. The hacks were enabled, but as before, I couldn't save the setting to disable them. I noticed earlier I couldn't boot into the HBC, which is probably normal: this version of priiloader doesn't look for that 1.0.7 channel name. Earlier, I was able to install and use a forwarder to wiiflow (that actually booted into joyflow, assuming it was in the (for the forwarder) correct folder). This didn't work this time.
    So I decided to go about it the hard way and remove priiloader from the nand.

    This seemed to be successful. At least: it didn't auto-pressed the a-button anymore, and holding the reset button no longer brings up the menu (as such, I assume that's a success). But still, uneek refused to boot. Now I started to worry a bit.

    Thinking it may have been caused by the reinstallation of those wads, I uninstalled those again (even though they worked earlier). Still, it doesn't boot.

    I tried defragmenting the drive, but this didn't work either. So...now I'm out of options. Aside from the "go back to start" option. But that means I have to recompile the whole shebang, reinstall hbc and priiloader, miis and savegames, the whole bunch o wads, system settings...all in all, not the most pleasant of task.

    So hence this question: does anyone have still something to try to get this uneek thing working again? [​IMG]
     
  2. Hielkenator

    Member Hielkenator GBAtemp Psycho!

    Joined:
    Feb 7, 2010
    Messages:
    4,176
    Country:
    Netherlands
    When i Install wads with showmiwads I get the same errors all the time.
    Now I install them via MMM from the HBC in Uneek. NO problems.
    Make sure you have a vulnerable ios installed ( 236 )
    Also I'm using SNORT 48+ for managing the installed channels.

    Just delete and star over.
    Also there is NO need to have your updates blocked in UNEEK.
    You have region change on the fly also, ( I don't even think it's needed for the channels, DVD loading is also disabled by default so there is no need for the hacks )
    Make sure you have a Uneek NAND based on SM 4.3, and you'll be fine.

    You ccould also try to delete the config files of uneek before starting over.
    You will have to reboot several times to Uneek in order to set things up again.
     
  3. cobleman

    Member cobleman GBAtemp Maniac

    Joined:
    Jun 23, 2009
    Messages:
    1,449
    Location:
    Australia
    Country:
    Australia
    Modmii for windows makes a great Uneek + Di or Sneek + Di very simple setup http://filetrip.net/file.php?id=23834
    P.S. Black screen is probly the Di not compileing properly check its 32.5kb not 0kb
     
  4. zizer

    Member zizer GBAtemp Addict

    Joined:
    Aug 23, 2010
    Messages:
    2,035
    Country:
    Modmii for windows makes only r150
     
  5. Taleweaver
    OP

    Member Taleweaver Storywriter

    Joined:
    Dec 23, 2009
    Messages:
    5,121
    Location:
    Belgium
    Country:
    Belgium
    Thanks for the replies thus far. I'll see what I can do to reply. [​IMG]

    @Hielkenator: I'll keep that way to install wads in mind for the future. I take it IOS236 is needed to install those wads with MMM?
    I like snort for doing what it does. But in time, I hope joyflow will fulfill role of launching all my channels.

    I kinda guessed the blocking of updates wasn't needed. I figured it was better to be extra safe. 'Extra safe' was apparently a bit risky. [​IMG]
    The region change on the fly...I noticed it in the menu, but couldn't quite figure out how it worked (the only thing I got was getting a green screen and a loud beep out of 'S.M. All stars+world' instead of a black screen). Another future thingy to check out. [​IMG]

    This could work...but do you know where uneek stores its config? [​IMG]


    @cobleman: don't get me wrong, but isn't that advice you tell someone who is trying to set up uneek? I already had it working for a week, so it was already compiled properly. (I'll still recheck those files, as I ran in that 0kb error before).

    @zizer: I know. But afaik, the latest revision is r151...and the changelog since then is not exactly blowing me away.
     
  6. scooby74029

    Member scooby74029 "fake coder"

    Joined:
    May 7, 2010
    Messages:
    1,174
    Location:
    oklahoma, USA
    Country:
    United States
    if you use mmm13.4 in s/uneek you can use any ios to install anything you want
    all ios in s/uneek have the ahbprot flag set when in mmm13.4
    that is how i install all my wads to s/uneek
     
  7. OverjoY

    Member OverjoY GBAtemp Fan

    Joined:
    Apr 1, 2010
    Messages:
    495
    Location:
    Rotterdam
    Country:
    Netherlands
    Disc Region free hack is already in SMenu.c and why don't you just add the other hacks you want over there?

    I also had some issues with USA wads on my 4.2e nand, but I just installed Eur versions of them.

    Uneek stores it's config in euh... folder Sneek.

    Just remove Priiloader and maybe you'll have to replace your SM app file
     
  8. Hielkenator

    Member Hielkenator GBAtemp Psycho!

    Joined:
    Feb 7, 2010
    Messages:
    4,176
    Country:
    Netherlands

    I remember now you guys mention it.

    The config files are in the Sneek folder on your USB HD.
    You can also delete the channel cache .
    I use Wiixplorer for convenience.
     
  9. Taleweaver
    OP

    Member Taleweaver Storywriter

    Joined:
    Dec 23, 2009
    Messages:
    5,121
    Location:
    Belgium
    Country:
    Belgium
    Thanks for the info, guys. [​IMG]

    Clearing out the cache indeed got things to work again.


    *sigh of relief*
     
  10. Hielkenator

    Member Hielkenator GBAtemp Psycho!

    Joined:
    Feb 7, 2010
    Messages:
    4,176
    Country:
    Netherlands
    Lol, no problem!
     
  11. XFlak

    Member XFlak Wiitired but still kicking

    Joined:
    Sep 12, 2009
    Messages:
    9,122
    Location:
    Ontario
    Country:
    Canada
    Please excuse my ignorance, but how does one go about clearing the cache using WiiXplorer or Windows or w/e. I don't have any problems right now, but I like arming myself with information like this [​IMG]
     
  12. scooby74029

    Member scooby74029 "fake coder"

    Joined:
    May 7, 2010
    Messages:
    1,174
    Location:
    oklahoma, USA
    Country:
    United States
    @xflak

    they mean delete the channel cache and diconfig.bin

    scooby74029
     
  13. OverjoY

    Member OverjoY GBAtemp Fan

    Joined:
    Apr 1, 2010
    Messages:
    495
    Location:
    Rotterdam
    Country:
    Netherlands
    Just delete the config.bin files
     
  14. Taleweaver
    OP

    Member Taleweaver Storywriter

    Joined:
    Dec 23, 2009
    Messages:
    5,121
    Location:
    Belgium
    Country:
    Belgium
    ...that are found on the \sneek subfolder on the USB device if you're using UNEEK (I just moved them to another folder, just in case...I dislike deleting things when I'm not 100% sure it'll work). I deleted both channelcache.bin and diconfig.bin, but it may be that getting rid of just one 'll do the trick (even though they are remade after running uneek again). [​IMG]
     

Share This Page