Unbricked the 3DS, but i want to uninstall ARM9

Discussion in '3DS - Flashcards & Custom Firmwares' started by xHomerOx, Jun 10, 2017.

  1. xHomerOx
    OP

    xHomerOx Member

    Newcomer
    40
    0
    May 28, 2016
    Argentina
    I managed to unbrick the 3DS, but now I want to sell it to one friend, so I would like to uninstall the ARM9, and leave all on factory default but... My N3DSXL 9.2.0-20U only boots when boot.firm (luma 7.1) is in the MicroSD. So I tried to use SafeArm9Installer to uninstall the ARM9, but i cannot start it from boot, because with homebrew i keeps getting Red or Black Screen.

    Could you give some steps to uninstall the ARM9 having Luma 7.1, It's the only way I can do it otherwise the 3DS won't boot, but in one case i renamed the CTRBOOTMANAGER to boot.firm and i booted from there, but i don't remember the versions of the files I need to use for this, so i would need an Step by Step Guide for this specific case. Any suggestion will be welcome... thanks in advance.
     
  2. Lacius

    Lacius GBAtemp Guru

    Member
    6,104
    2,436
    May 11, 2008
    United States
    If you are using the boot.firm for Luma3DS, then that means you have BS9 installed, not A9LH. There is no reason to uninstall BS9, however. Use FBI or GodMode9 to copy the Luma3DS boot.firm to your CTRNAND, and you won't require the microSD card to boot anymore.

    Edit: For a step-by-step guide, follow this link, and go to Section VI - CTRNAND Luma3DS.
    https://3ds.guide/finalizing-setup
     
    Last edited by Lacius, Jun 10, 2017
    Quantumcat likes this.
  3. xHomerOx
    OP

    xHomerOx Member

    Newcomer
    40
    0
    May 28, 2016
    Argentina
    Cannot do it yet, i have to start over again, cause i couldn't init safehax to install B9S. B9S is not installed, i don't know what can i do...
     
  4. SomeGamer

    SomeGamer GBAtemp Guru

    Member
    5,755
    2,712
    Dec 19, 2014
    Hungary
    If your 3DS needs boot.firm to boot, it has B9S.
     
  5. Altairseven

    Altairseven GBAtemp Regular

    Member
    124
    29
    Jan 21, 2016
    Argentina
    as someGamer just said, if you cant boot only with boot.firm in the sd, then you already have boot9strap installed, which is what you want to have, however, if your luma version is 7.1 and not 8.0, then you need to follow this section of the guide https://3ds.guide/updating-b9s, in order to install the latest version of boot9strap and luma 8.0
     
  6. xHomerOx
    OP

    xHomerOx Member

    Newcomer
    40
    0
    May 28, 2016
    Argentina
    Thanks guys, it's done, but i don't recall having B9S installed on my SysNAND, but at least i can sell it to one of my friends, with latest version and hacked. :)))) Thanks!