Unable to update softmod 4.1u HBC or 4.3

Discussion in 'Wii - Hacking' started by pyrocide, Feb 17, 2016.

  1. pyrocide
    OP

    pyrocide Newbie

    Newcomer
    3
    0
    May 30, 2012
    United States
    Hello,

    I've been trying to update my softmodded Wii from 4.1u to 4.3 and ran across two issues.

    I know I am connected to the net because I can watch any streaming services without issue.

    Problem 1: HBC is v1.1.0 and, correct me if I'm wrong, it is supposed to download the latest version automatically and install. It is not.

    Problem 2: I cannot update to 4.3 from Wii official update, which if I'm reading is supposed to be fine if on 1.08 and later HBC and does not pose a brick risk.

    Am I reading the wiki's and various articles wrong or something? Thanks in advance.
     
  2. SickPuppy

    SickPuppy New Member

    Member
    1,791
    451
    Jul 29, 2009
    United States

    Why are you trying to update. If you update you will have to rehack your Wii.

    You can get the latest hackmii installer to update your hbc from here - http://bootmii.org/download/ Wii system menu 4.3 offers no advantages over 4.1, so there is no reason to update.
     
    Last edited by SickPuppy, Feb 17, 2016
  3. pyrocide
    OP

    pyrocide Newbie

    Newcomer
    3
    0
    May 30, 2012
    United States
    From what I understood newer games may not work on 4.1u. Is that not correct?
     
  4. SickPuppy

    SickPuppy New Member

    Member
    1,791
    451
    Jul 29, 2009
    United States
    Are you referring to playing copies or original disc. If you mean copied games then they don't require a certain system menu. If you have games that don't work then look at your backup loader and/or the cIOS as being the problem. Original discs probably do require a certain system menu to run, not to mention having to update the IOS's.
     
    Last edited by SickPuppy, Feb 17, 2016
    GreyWolf likes this.
  5. pyrocide
    OP

    pyrocide Newbie

    Newcomer
    3
    0
    May 30, 2012
    United States
    Original discs. I have a few backup copies but I like to borrow games first and then determine if want to buy and copy it for ease of switching games.
     
  6. tswntk

    tswntk GBAtemp Advanced Fan

    Member
    669
    136
    Aug 6, 2012
    Switzerland
    you might have priiloader installed and told it to block disk/online updates.
    still you don't need a particular system menu to run games. you might need a certain ios to run a game but you can easily update/add that ios with modmii. or you can even use usbloaders to boot the disk with cios.
    Make a syscheck and compare your ios against NUSD to see if you have the latest (but not to confuse with vWii versions)

    updating via official methods will remove your softmod and you have to re-softmod again.