PS1/2 Unable to play new PSX games on my PSP-Street?

Francesca

Well-Known Member
OP
Member
Joined
Mar 17, 2015
Messages
388
Trophies
0
XP
839
Country
Armenia
Years ago I'd do a lot of PS1 emulation on my CWC-hacked PSP Street 1000. I got back into it this year, realising that any and all PSP-converted PS1 games I find online don't work on it any more - I get the error "the game could not be started FFFFFFFF". This error doesn't seem to apply to my old games, already on the system's SD Card or PSP ISOs, and my attempts to go into Recovery Mode have all failed, as holding R while turning the system on doesn't open it any longer.

Would appreciate some help as to what to do.
 

kehkou

does what Nintendon't
Member
Joined
Dec 19, 2009
Messages
785
Trophies
0
Location
The Duke City
XP
915
Country
United States
I haven't been on this scene in well over a decade, so I don't know what has changed since the heyday; I may not be of much help. Is the popsloader still a thing? If so, I would check there first.

do you have pops and popsloader installed? preferable with a collection of different pops versions (since some games run better with some pops versions)
:ninja:
 

Francesca

Well-Known Member
OP
Member
Joined
Mar 17, 2015
Messages
388
Trophies
0
XP
839
Country
Armenia
do you have pops and popsloader installed? preferable with a collection of different pops versions (since some games run better with some pops versions)
Not as far as I can tell looking inside the memory stick. No files or folders with a name like that. It may well be there under a different name? idk.

@Francesca, what version of custom firmware are you running?

6.60 PRO-C2. It won't let me update any more.
 

rantex92

Well-Known Member
Member
Joined
Sep 28, 2021
Messages
553
Trophies
0
Age
30
XP
741
Country
Germany
Not as far as I can tell looking inside the memory stick. No files or folders with a name like that. It may well be there under a different name? idk.



6.60 PRO-C2. It won't let me update any more.
https://www.psx-place.com/resources/popsloader-6-60-pro-ps1-on-psp.622/

and you will need the pops files but those are copyrighted material i cant link to them

and to play psx you will need atleast one version of pops installed and the popsloader will let you switch between pops versions
 

Sonic Angel Knight

Well-Known Member
Member
Joined
May 27, 2016
Messages
14,188
Trophies
1
Location
New York
XP
11,905
Country
United States
6.60 PRO-C2. It won't let me update any more.
First, i think you should update your firmware to 6.61, that's the latest official firmware. Just to be sure you got the latest update. I don't know if you can download the system update from the system or website anymore (Since sony mention cutting psp service) or maybe try the web archive site, LINK HERE.

Second, there is the psp infinity which allows you to have persistent cfw for either PRO CFW or ME CFW. It works on both 6.60 (Which you're currently using) and the latest 6.61 (The one you can update to) Instructions about getting and using it are link here. Since it works on 6.60, you could probably skip updating to 6.61 and just run the infinity installer. But maybe that "Extra stability" can help. This should maybe make things easier and functional. Just my suggestion. :ninja:
 
General chit-chat
Help Users
    Dark_Phoras @ Dark_Phoras: Has Childish Gambino become more mature?