TX releases SX OS v3.0.0 beta, introduces SX Core and Lite support plus bug fixes

SXOS300BETA.png

After a long wait, the official release of SX OS v3.0.0 is here to enjoy! Supporting all Switch consoles, it's great for those waiting for their pre-ordered modchips. For those running unpatched consoles this new update also brings a few long-awaited bug fixes, including the broken cheat finder and the game crashes on Switch firmware 10.

You can find the full update below.
It has come to our attention some people didn't take the Non Disclosure Agreement we (did not ;-)) make them sign too seriously. Thus, we are releasing SX OS v3.0.0 beta to the public today.

We would (again) strongly suggest *not* to use any builds of SX OS that were not distributed by us (This includes private links that do point to our servers, for what it's worth). It could pose a risk to your hardware and data and creates a potential support nightmare for us. Thank you for your understanding.

Let's not waste any more time and have a look at the changelog for SX OS v3.0.0:
  • Full support for Mariko and Switch Lite consoles.
    That's right, SX OS now supports 100% of all consoles manufactured to date.
  • Support for SX Core and SX Lite boot methods.
    With SX Core and SX Lite arriving to the mainstream audience soon, we want to make sure you can actually use your product when it arrives to your doorstep. We would like to remind you every SX Core and SX Lite comes with a *free* license for SX OS. No need to pick up a license key separately. Just activate your product like you normally would. (Through our website or using the SX OS menu)
  • Support for systems with a larger NAND
    Die hard Switch modders who have installed a larger NAND storage in their switches are now actually able to use it with SX OS. (Previously it would hang during boot)
  • Fixed error 2162-0002 game crashes
    We introduced a regression in SX OS 2.9.5 which made some games crash with error code 2162-0002 (when accessing in game manuals and such). This has been addressed and resolved.
  • Fix bug with displaying MAIN memory addresses in cheat finder
    We had a little regression in the cheatfinder a while ago that slipped past our QA somehow. All you cheat hunters can rejoice, this has been fixed!
There's many under the hood changes we won't bore you with, if you encounter any issues do not hesitate to let us know!

That's all we have in store for you today. We are happy to see our new products are being embraced by a wild variety of entities worldwide. We promised a solution for the unliberated Switch consoles, and we are the first to deliver one. Keep this in mind when you vouch for any derivative works, and have a good night!
Are you eagerly waiting for the SX Core and Lite to release? Are there any hot issues you're still waiting for a fix on? Let us know!

:arrow: Source
 

RedHunter

Well-Known Member
Member
Joined
Dec 12, 2014
Messages
440
Trophies
0
XP
1,502
Country
Italy
I am able to get SX3.0 to work with Enunand. However I am not seeing any games. I've tried renaming Emutendo folder to Nintendo, but still no luck. Once I revert back to 2.9.5, then I am able to see the games (in Emutendo). Is this happening to anyone else?
I thought it was my fault because I changed the boot files using the mtp app but I guess not.

Lost all my emunand, saves included. Luckily I lost only Indivisible and some seeds on botw.

Avoid this update, even emunand creation doesn't work and I'm afraid I'm going to be banned because some nsp showed up on my sysnand.

TX fucked up this time, wish someone warned us about this issue here.
 

comput3rus3r

Well-Known Member
Member
Joined
Aug 20, 2016
Messages
3,574
Trophies
1
Age
120
XP
4,760
Country
United States
I thought it was my fault because I changed the boot files using the mtp app but I guess not.

Lost all my emunand, saves included. Luckily I lost only Indivisible and some seeds on botw.

Avoid this update, even emunand creation doesn't work and I'm afraid I'm going to be banned because some nsp showed up on my sysnand.

TX fucked up this time, wish someone warned us about this issue here.
I have no issues with sxos 3.0.
 

sorabora

Well-Known Member
Member
Joined
Dec 8, 2016
Messages
350
Trophies
0
XP
1,027
Country
United States
I think I messed up, didn't want to turn off the console so I connected the console to the pc, started the mtp app and changed the boot file from there.
SX gave me an error and I lost everything on the emunand even the saves :(

No way to get them back?

Do you have tesla overlay files in sxos/titles? If so, you cannot boot on 3.0 as others have stated. Had same problem.
 

Legend Of Kay

Well-Known Member
Member
Joined
Oct 12, 2018
Messages
230
Trophies
0
Age
30
XP
900
Country
Australia
W
I thought it was my fault because I changed the boot files using the mtp app but I guess not.

Lost all my emunand, saves included. Luckily I lost only Indivisible and some seeds on botw.

Avoid this update, even emunand creation doesn't work and I'm afraid I'm going to be banned because some nsp showed up on my sysnand.

TX fucked up this time, wish someone warned us about this issue here.
Everything works perfect on my end. Not a single issue.
 
D

Deleted User

Guest
Overlays and SX loader are indeed broken.

I'll just stay on 2.9.5 till this is fixed.

There's other bugs as well. Had a client ship in 6 switches and some wont boot 3.0 straight up to create emunand and some do. Also, I have to revert back to 2.95 on 1 of the switches for it to boot already created emunand. Hopefully next release irons out some of these issues.
 
  • Like
Reactions: LiveMChief

RebelNerd

Member
Newcomer
Joined
Jul 9, 2018
Messages
5
Trophies
0
Age
48
XP
78
Country
Netherlands
When aim on SXOS 3.0 with custom firmware installed on internal storage you cant boot custom firmware anny more. When i put back SXOS 2.9.5 custom firmware starts without any problem..... So its not working for them who have the custom firmware installed on internal memory....
 

Mikep90

Well-Known Member
Member
Joined
May 29, 2018
Messages
223
Trophies
0
Age
39
XP
1,346
Country
United States
When aim on SXOS 3.0 with custom firmware installed on internal storage you cant boot custom firmware anny more. When i put back SXOS 2.9.5 custom firmware starts without any problem..... So its not working for them who have the custom firmware installed on internal memory....
Take off autoloader that might be the cause of it
 

Legend Of Kay

Well-Known Member
Member
Joined
Oct 12, 2018
Messages
230
Trophies
0
Age
30
XP
900
Country
Australia
When aim on SXOS 3.0 with custom firmware installed on internal storage you cant boot custom firmware anny more. When i put back SXOS 2.9.5 custom firmware starts without any problem..... So its not working for them who have the custom firmware installed on internal memory....
Works for me. Take off auto loader like that other guy said and the other 40 people in this thread.
 

Reecey

Mario 64 (favorite game of all time)
Member
Joined
Mar 7, 2010
Messages
5,866
Trophies
1
Location
At Home :)
XP
3,581
Country
The sxos menu installer doesn't work either it goes to sleep half way through the install you need to install a large nsp for this to fault.
 

Purple_Shyguy

Well-Known Member
Member
Joined
Nov 8, 2008
Messages
1,639
Trophies
1
Age
31
Location
Republic of Ireland
XP
2,729
Country
Is there any way to easily boot back into the TXOS menu? So i can turn emunand on/off?

I know there's a TXOS reboot homebrew but that just resets the system. Doesn't bring up the menu as far as I know
 

Legend Of Kay

Well-Known Member
Member
Joined
Oct 12, 2018
Messages
230
Trophies
0
Age
30
XP
900
Country
Australia
Is there any way to easily boot back into the TXOS menu? So i can turn emunand on/off?

I know there's a TXOS reboot homebrew but that just resets the system. Doesn't bring up the menu as far as I know
If you just reset the system the normal way it reboots automatically into cfw now. So if you just hold the +volume button whilst rebooting it will boot into the TX menu.
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    KennieDaMeanie @ KennieDaMeanie: https://youtube.com/shorts/qNYX_fhdPfI?feature=share