TX Presents SX OS v2.9.2 Beta - With Improved Stealth Mode and More!

Another day, another SX OS update! Today, Team-Xecuter released their SX OS v2.9.2 beta.
SX292.png

Good news, we been informed that TX has finally released v2.9.2 and it contains some new features, and also it looks this will soon be their 'STABLE' release and they report they are hard at work on SX OS v3.0.0 so we have alot to look forward to enjoy soon! Oh'yeah, it also fully supports the latest Nintendo Switch firmware v9.0.1 of course :)
  • Local Multiplayer over the internet (LAN play) is working again.
    Somewhere down the line we introduced a regression in functionality causing local multiplayer emulation to be broken and/or out of sync with the current lan-play implementation. This has been addressed and should work correctly again.
  • Extended scope of Stealth Mode
    Recently it has come to our attention that there was claims floating around about stealth mode being broken on SX OS v2.9+. We investigated these claims and are happy to let you know this is completely wrong. Stealth Mode behaved exactly the same like it always did. Nonetheless, we took this feedback/rumour as an opportunity to further tighten down on the stealthiness. From now you cannot start the eShop application if you have stealth mode enabled. Furthermore all error reporting and telemetry has been neutered. That means errors that are generated while using SX OS that might get you "flagged" won't be queued up for delivery when you boot into OFW anymore either!
  • Improved XCI game compatibility
    In our last update we already addressed some compatibility issues with re-packed XCI images, yet some XCI files were still not playable. We investigated this issue and as it turns out there are certain tools around (older versions of 'NSC Builder' for example) that generate bogus metadata for the (encrypted) 'Gamecard Info' that is part of the XCI header. Our gamecart emulation now detects these bad images and fixes them. If you want your XCI images to be future proof; please be careful with whatever post-processing you apply to XCI files though, we can't clean up after other people's mistakes indefinitely!
  • Rebooting SX OS
    If you select "restart" now from the power options menu you will actually reboot into SX OS. There is no need to replug your SX Pro dongle or send a payload from your computer when doing so. Additionally, if an error occurs you can also reboot into SX OS by simply pressing the power button. Neat!
SX292-1.png

They report this will be their final v2.x release as they are moving forward to a big v3.0 release with it having many suggestions they have received over the last few months from their valued SX OS users, so in the meantime grab their v2.9.2 release from their website.

—< Team-Xecuter - Rocking the Switch in 2019 and beyond! >—

:arrow: Source: MaxConsole
 

sorabora

Well-Known Member
Member
Joined
Dec 8, 2016
Messages
354
Trophies
0
XP
1,089
Country
United States
If you made a backup od a clean nand and haven't connected to Nintendo servers you can restore the backup, create an emunand and connect officially to Nintendo servers while on OFW

In other words, the answer is "no," given that the Switch was used since SX OS launched and did use online features (e.g., updating cores on Retroarch though no online gameplay), though was not banned at the time it went into permanent airplane/stealth mode?

Sorry, not trying to be dense. Just want to be 100% clear.
 
Last edited by sorabora,

xabier

Well-Known Member
Member
Joined
Dec 10, 2006
Messages
577
Trophies
0
XP
1,181
Country
United States
In other words, the answer is "no," given that the Switch was used since SX OS launched and did use online features (e.g., updating cores on Retroarch though no online gameplay), though was not banned at the time it went into permanent airplane/stealth mode?

Sorry, not trying to be dense. Just want to be 100% clear.
I myself used homebrew before sx os(pfba an some other apps) and loaded some legit xci files. Used the console normally with a very active eshop account.

Then I was in a "clean" backup&restore cycle until emunans was released. My switch has been on "legit" ofw online and "tainted" emunand with Nintendo servers blocked.

I haven't been banned despite using xcis without clean backup, I used to clean the error logs before it was deemed unsafe.

If you haven't used nsp files I think that you might be still good to go. Anyway if you don't try to go online you are already self banned, you could take the risk and check if you are safe, worst thing could happen is going back offline again.
 
  • Like
Reactions: sorabora

wurstpistole

GBAtemp MVP
Member
Joined
Nov 19, 2015
Messages
4,542
Trophies
1
XP
4,716
Country
United Kingdom
the splatoon xci is broken for me as well.. i can get through the opening intro onto to get hit with an error when trying to go into a lobby,, and no im not banned.. and i dumped the splatoon cart on my system, so i know it cant be a bad dump when it was working fine pre 9.0
There is probably next to no one caring about a working xci of an online only game, which you can't play anyway if you want to be somewhat safe from banning
 
  • Like
Reactions: Tumbleweed

sorabora

Well-Known Member
Member
Joined
Dec 8, 2016
Messages
354
Trophies
0
XP
1,089
Country
United States
If you haven't used nsp files I think that you might be still good to go. Anyway if you don't try to go online you are already self banned, you could take the risk and check if you are safe, worst thing could happen is going back offline again.

Appreciate your detailed experience. My experience was mostly along your lines with one (prob major) caveat: I did install and extensively use the hbmenu as an NSP.

But - as you said - I'm basically self-banned as is, so maybe I'll just throw caution to the wind and see if I was hit in a ban wave in the past year or so that I've been offline. If not, we'll see!

Thanks again.
 

jackieleex3

Active Member
Newcomer
Joined
Apr 16, 2018
Messages
29
Trophies
0
Age
32
XP
299
Country
United States
TX say there was nothing wrong with stealth mode from beginning. and I was worry when I was using HBG shop during that time. looks like I'm not ban after all
 

stoffer666

Well-Known Member
Newcomer
Joined
May 21, 2018
Messages
62
Trophies
0
Age
40
XP
849
Country
Denmark
Another day, another SX OS update! Today, Team-Xecuter released their SX OS v2.9.2 beta.
View attachment 181765

Good news, we been informed that TX has finally released v2.9.2 and it contains some new features, and also it looks this will soon be their 'STABLE' release and they report they are hard at work on SX OS v3.0.0 so we have alot to look forward to enjoy soon! Oh'yeah, it also fully supports the latest Nintendo Switch firmware v9.0.1 of course :)


They report this will be their final v2.x release as they are moving forward to a big v3.0 release with it having many suggestions they have received over the last few months from their valued SX OS users, so in the meantime grab their v2.9.2 release from their website.

—< Team-Xecuter - Rocking the Switch in 2019 and beyond! >—

:arrow: Source: MaxConsole

The only problem i can find is that i can not use the homebrew menu with full ram support any more. It goes into the menu but can not navigate and press any button. Using the R button with a nsp game.
i am on emunand 9.0.1 (files) and sys nand 9.0.1 are anyone having the same problems with this.
 

Reecey

Mario 64 (favorite game of all time)
Member
Joined
Mar 7, 2010
Messages
5,866
Trophies
1
Location
At Home :)
XP
3,754
Country
I just tested on a hidden 9.0.1 emunand smash bros and it works fine with stealth mode off, well the xci that I had that is the first rip of the scene
Have you connected your switch to the wifi? you have to have the switch connected in settings, then turn off stealth mode and run Mario Maker 2 xci, it should freeze so does Smash xci, if your wifi is not connected to the switch in settings then it runs fine with stealth mode off, it only seems to happen when you are connected to your wifi and turn off stealth mode then run the game, not sure why? If you are banned it should not matter if you try.

Edit: sorry to test this out you will need to turn off stealth mode first, then go into settings connect to your wifi then go back and boot up Mario Maker 2 xci or Smash.

--------------------- MERGED ---------------------------

If you went online with SX OS prior to emunand being a feature (though not banned), is it pointless to use emunand as a method to lessen (not eliminate) the odds of being banned? Or is it still an option?
No my unit was brand new on firmware 4.1.0 untouched I went straight ahead and set up emunand hidden partition up turned of telemetry on account and I have always used online titles I own in xci format in emunand since and never had an issue I sometimes play for hours especially Mario Kart 8 there are a few members here that already know this about me. There was a thread about injecting certs into xci back ups along time ago I have been doing it for a while now.
 
Last edited by Reecey,

kamesenin888

Well-Known Member
Member
Joined
Oct 20, 2007
Messages
1,432
Trophies
0
XP
2,007
Country
Have you connected your switch to the wifi? you have to have the switch connected in settings, then turn off stealth mode and run Mario Maker 2 xci, it should freeze so does Smash xci, if your wifi is not connected to the switch in settings then it runs fine with stealth mode off, it only seems to happen when you are connected to your wifi and turn off stealth mode then run the game, not sure why? If you are banned it should not matter if you try.

Edit: sorry to test this out you will need to turn off stealth mode first, then go into settings connect to your wifi then go back and boot up Mario Maker 2 xci or Smash.

--------------------- MERGED ---------------------------


No my unit was brand new on firmware 4.1.0 untouched I went straight ahead and set up emunand hidden partition up turned of telemetry on account and I have always used online titles I own in xci format in emunand since and never had an issue I sometimes play for hours especially Mario Kart 8 there are a few members here that already know this about me. There was a thread about injecting certs into xci back ups along time ago I have been doing it for a while now.

I already tried but here goes again with pics,
Green Joy-Con D-Pad Shells for Nintendo Switch
 

Reecey

Mario 64 (favorite game of all time)
Member
Joined
Mar 7, 2010
Messages
5,866
Trophies
1
Location
At Home :)
XP
3,754
Country
I already tried but here goes again with pics,
Green Joy-Con D-Pad Shells for Nintendo Switch
You say you are banned I can only think it’s that why it’s working for you. I don’t understand that, it’s certainly doing it for me I will upload a video have you tried Mario Maker 2 as well? I’m wandering now if it’s a UK thing because of the banned xecuter urls maybe it’s causing an issue with stealth mode when you turn it off and I’m certainly not lying would not be worth my time & effort, someone from the uk could test this as well please.

Here’s a video it’s not great and that’s not a bad thing I don’t want everyone seeing everything but you can see stealth mode is turned off, WiFi is connected and the firmware is 9.0.1 and you will see Mario Maker 2 freeze.
 
Last edited by Reecey,

Reecey

Mario 64 (favorite game of all time)
Member
Joined
Mar 7, 2010
Messages
5,866
Trophies
1
Location
At Home :)
XP
3,754
Country
the splatoon xci is broken for me as well.. i can get through the opening intro onto to get hit with an error when trying to go into a lobby,, and no im not banned.. and i dumped the splatoon cart on my system, so i know it cant be a bad dump when it was working fine pre 9.0
Did you get Splatoon 2 working? What exactly is it doing I have Splatoon 2 dumped in xci format I can test it myself my end to see what happens, it sounds similar whats happening to my dumped retail games they were all working fine pre 9.0 firmware also are you using it in the uk? online with stealth mode off? what firmware and beta sxos are you using? also emunand or not? thanks
 
Last edited by Reecey,
D

Deleted User

Guest
@Reecey I just wanted to let you know myself and a few testers have all tried to replicate your situation on our switches and so far we have not been able to reproduce this.
 

frostii

Well-Known Member
Member
Joined
Jun 24, 2009
Messages
178
Trophies
0
Location
Brisbane, Australia
XP
1,006
Country
United States
Hi,
Can I please confirm the following steps are working now with this BETA (in this order)?

1. Boot up Switch with new 2.9.2 SX OS.
2. Update Firmware to 9.0.1 using ChoidujourNX 1.01.
3. Reboot.
4. Enjoy.

I know v2.9 BETA was running into problems with updating firmware. Just want to confirm that issue is no longer a problem.

Thanks.
 
  • Like
Reactions: lapras2494

Reecey

Mario 64 (favorite game of all time)
Member
Joined
Mar 7, 2010
Messages
5,866
Trophies
1
Location
At Home :)
XP
3,754
Country
@Reecey I just wanted to let you know myself and a few testers have all tried to replicate your situation on our switches and so far we have not been able to reproduce this.
Someone else has reported exactly the same issue on your forums under beta thread/2.9.2 discussion I have just read it and joined up and posted myself so its not just me. @Game_Over_Tom did you watch the video I posted earlier to give you an idea whats actually happening? I'm not saying the team is not trying, I'm sure they are thank you for the support! but it doesn't make any sense at all too me they were all working fine pre 9.0 firmware on 2.8Beta, so why is it happening now. Tom I am also trying my end to make sure it’s not me I have dumped Mario Maker 2 several times again last night but still the same I also installed 9.0.1 firmware again to check that but still exactly the same issue occurs. It only happens when you have stealth mode off and your WiFi connected in settings soon as you boot the game up in the intro or loading example it will freeze the console and you have to hard power down, it’s not just happening with one game it happens with a few online titles and you cannot go online gaming with any of them.

As far as hacking/homebrew is concerned I would say I am advanced and know what I am doing so I cannot see anything I am doing wrong but the only things I have done since recently pre 9.0 firmware was update my switch to 9.0 ChoiDujournx 1.0.2 with 2.8Beta but changed to 2.9.0Beta on boot up, then 9.0.1 was released so I flashed firmware 9.0.1 with sxos 2.9.1Beta with ChoiDujournx 1.0.2 then I changed to sxos 2.9.2Beta when they came out and that’s it, the bugs been present since pre 9.0 I did register my Nintendo account to the Mario Kart Iphone I’m not sure if that’s relevant.
 
Last edited by Reecey,

kornjaca200

Well-Known Member
Newcomer
Joined
Mar 2, 2017
Messages
57
Trophies
0
Age
35
XP
962
Country
Netherlands
Someone else has reported exactly the same issue on your forums under beta thread/2.9.2 discussion I have just read it and joined up and posted myself so its not just me. @Game_Over_Tom did you watch the video I posted earlier to give you an idea whats actually happening? I'm not saying the team is not trying, I'm sure they are thank you for the support! but it doesn't make any sense at all too me they were all working fine pre 9.0 firmware on 2.8Beta, so why is it happening now. Tom I am also trying my end to make sure it’s not me I have dumped Mario Maker 2 several times again last night but still the same I also installed 9.0.1 firmware again to check that but still exactly the same issue occurs. It only happens when you have stealth mode off and your WiFi connected in settings soon as you boot the game up in the intro or loading example it will freeze the console and you have to hard power down, it’s not just happening with one game it happens with a few online titles and you cannot go online gaming with any of them.

As far as hacking/homebrew is concerned I would say I am advanced and know what I am doing so I cannot see anything I am doing wrong but the only things I have done since recently pre 9.0 firmware was update my switch to 9.0 ChoiDujournx 1.0.2 with 2.8Beta but changed to 2.9.0Beta on boot up, then 9.0.1 was released so I flashed firmware 9.0.1 with sxos 2.9.1Beta with ChoiDujournx 1.0.2 then I changed to sxos 2.9.2Beta when they came out and that’s it, the bugs been present since pre 9.0 I did register my Nintendo account to the Mario Kart Iphone I’m not sure if that’s relevant.
Have you tried playing without your dump but with your own original mario maker cartridge in your system, maybe that works?
 
  • Like
Reactions: Deleted User

DEMONDICE

K-K-Kureiji
Member
Joined
Dec 7, 2013
Messages
975
Trophies
0
Age
31
XP
1,717
Country
United States
So does this release update properly with 9.0? I remember the last release was messing up people's Switches when they updates to 9.0 and tried to boot SXOS. I've avoided it since then.
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    KenniesNewName @ KenniesNewName: Apple is the new Disney