TX Presents SX OS v2.8 Beta - Now Compatible with v8.1.0 FW

Discussion in 'Switch - Backup Loaders & Modchips' started by garyopa, Jun 19, 2019.

  1. Solid924

    Solid924 Member

    Newcomer
    4
    Dec 6, 2017
    Albania
    Do you use exfat? If yes, this might corrupt your data as it did mine in the past. So I switched to fat32 and it works like a charm since then.
     
  2. lobogrr

    lobogrr Newbie

    Newcomer
    1
    Jun 22, 2019
    Poland
    Yes, exFAT. But I've update firmware few times before using same method and everything was ok.. Also, friend of mine yesterday done excactly same thing and had excactly same error.
     
  3. guitarheroknight

    guitarheroknight 1.6180339887

    Member
    12
    Nov 9, 2014
    Norway
    Grand Line
    Use Goldleaf instead of the SX OS installer.
     
    lobogrr likes this.
  4. lobogrr

    lobogrr Newbie

    Newcomer
    1
    Jun 22, 2019
    Poland
    Well.. it worked. Thanks:) Now I only have to reinstall 20+ titles :/
    Could it be some kind of bug in SXOS 2.8 beta?
     
  5. TheGreaKhali

    TheGreaKhali Advanced Member

    Newcomer
    2
    Jul 29, 2018
    United Kingdom
    Has team xecutor commented on this, wondering if it's a bug and can be fixed with a hotfix on a new SX Pro update instead of having to reinstall all my games
     
  6. cagerhager

    cagerhager Advanced Member

    Newcomer
    4
    Feb 17, 2018
    United States
    I get a crash after the switch splash screen. Anyone else having this issue? Also updated from 7.1 to 8.1 using choi. Updated SXOS to 2.8

    update: I ran into an issue with the themes. Had to delete the folder in sxos/titles that corresponded to themes and it booted up. Just in case anyone else experiences this.
     
    Last edited by cagerhager, Jun 22, 2019
  7. budtoka420

    budtoka420 GBAtemp Fan

    Member
    5
    Jun 6, 2012
    United States
    I'm having none of these issues with my sx os
     
  8. Josshy0125

    Josshy0125 GBAtemp Regular

    Member
    4
    Jun 16, 2019
    United Kingdom
    Neither am I. Im wondering if it's something aside from SX causing these things.
     
  9. lobogrr

    lobogrr Newbie

    Newcomer
    1
    Jun 22, 2019
    Poland
    @budtoka420 @Josshy0125
    Guys, did you update also from 7.1 to 8.1.0 with ChoiDujourNX v1.02?
    Had you use SXOS installer with your old games or Goldleaf?
     
  10. Josshy0125

    Josshy0125 GBAtemp Regular

    Member
    4
    Jun 16, 2019
    United Kingdom
    Naw, I say "fuck it" and update using the normal means. But it's just because I'm lazy, and don't care if I'm banned or for emunand, etc. I personally use goldleaf.
     
  11. cots

    cots GBAtemp Maniac

    Member
    9
    Dec 29, 2014
    United States
    That would require skills beyond what the common CFW troll has equipped.
     
    mrdude likes this.
  12. Mohammed2935

    Mohammed2935 GBAtemp Regular

    Member
    5
    Jul 4, 2018
    Kuwait
    I just updated my switch to 8.1.0 via the homebrew app and every eshop/update and xci games are working fine on my Evo 512gb micro SD card. No problems at all.
     
  13. Itsuki235

    Itsuki235 GBAtemp Regular

    Member
    1
    Jun 13, 2019
    United States
  14. rickwj324

    rickwj324 GBAtemp Regular

    Member
    3
    Oct 5, 2013
    United States
    I did the update this weekend to Beta v2.8 and also updated my OFW to 8.1.0 (via choidujournx). It worked fine, I managed to install an nsp game and run it without issue. Shortly after I was going to install 2 more nsp games but when I try to go into the ALBUMS folder it immediately crashes with error: 2162-0002. Nothing I try (shutdown, reboot, remove card, etc) seems to help. Any suggestions? I can still launch my installed games without issue, I just can't get to the ALBUMS menu so that I can install something else.

    **Sorry, I created a thread for this issue but no one has commented. Thought it might be more appropriate to post it in this thread.
     
  15. Itsuki235

    Itsuki235 GBAtemp Regular

    Member
    1
    Jun 13, 2019
    United States
    Are you using ExFat? Corruption issues are common. Reformat the SD card to Fat32.
     
    rickwj324 likes this.
  16. rickwj324

    rickwj324 GBAtemp Regular

    Member
    3
    Oct 5, 2013
    United States
    Yes...it's a 256gb exfat formatted card. I'll try that to see if it helps. Thanks!! --Rick
     
  17. SpiderPig2810

    SpiderPig2810 Member

    Newcomer
    1
    Dec 4, 2018
    Germany
    After updating to 8.1 and the newest SXOS Beta i also getting error messages. If i want to start a game i always get a message that i have to link a Nintendo Account to the game, but that does not work. Also some games (newly installed Breath of the Wild) asked me for an system update but i am already on 8.1
    So how can i fix this and what does that mean?
     
  18. Josshy0125

    Josshy0125 GBAtemp Regular

    Member
    4
    Jun 16, 2019
    United Kingdom
    I don't see how it's going downhill...?
     
  19. Dust2dust

    Dust2dust GBAtemp Maniac

    Member
    8
    Jun 17, 2010
    Canada
    :huh:I'm sure you meant to write something that makes sense, but this darn Google translate still needs to improve a lot.
     
  20. Tomas-Romski

    Tomas-Romski Newbie

    Newcomer
    1
    Jun 27, 2019
    Poland
    Hi,

    I wish to ask about update procedure of quite old Switch wish SXOS and emunand. I haven't been using it for a while and there's some 6.x firmware both on OFW and SXOS emunand.
    Could you please tell me:
    1. What is the best procedure to update both OFW and emunand to 8.x? Which one should be first to update?
    2. If I stay with 6.x on OFW can I update only emunand to 8.x? (of course with new boot.dat)

    Thanks!
     
Quick Reply
Draft saved Draft deleted
Loading...