TX Presents SX OS v2.7.1 - Minor Bugfixes

Discussion in 'Switch - Backup Loaders & Modchips' started by garyopa, May 3, 2019.

  1. hippy dave

    hippy dave BBMB

    Member
    15
    Apr 30, 2012
    United Kingdom
    The boost will only work on 7.x and above. Wouldn't surprise me if the update won't run on 6.2 at all for that reason.
     
  2. IpponDatara

    IpponDatara Member

    Newcomer
    4
    Jul 12, 2018
    Germany
    OC works only on 8.0 and upwards.
     
  3. isoboy

    isoboy GBAtemp Advanced Fan

    Member
    7
    Dec 23, 2016
    United States
    Sooooo....the game won't run at all if you update it on a lower firmware? Or it just won't take advantage of the OC? Do we know for sure? Did anyone try? I can't be bothered to!
     
  4. Kurems

    Kurems Member

    Newcomer
    3
    Nov 23, 2008
    Japan
    After some tests, I can confirm that the OC boost is only effective on at least FW 8.0.0.
    Mesured some loading times on Super Mario Odyssey (v1.3.0) and The Legend of Zelda - Breath of the Wild (v1.6.0) [Original game cards launched on two emuNANDs and updates/DLCs installed inside the emuNAND (files - FAT32)].

    Mario
    FW 7.0.1 - 23 seconds (initial loading time) & 9 seconds (loading a saved game)
    FW 8.0.1 - 14 seconds (initial loading time once more) & 5 seconds (loading the same saved game).

    Zelda
    FW 7.0.1 - 19 seconds (loading a saved game)
    FW 8.0.1 - 11 seconds (loading the same saved game)

    EDIT : For the tests, I've bypassed the FW requirement on the updates with reNXPack and installed them with SX Installer (Album) when the emuNANDs were on FW 7.0.1 and SX OS 2.6.1.
    Updated the emuNANDs FW to 8.0.1 with ChoiDuJourNX 1.0.2 + updating SX OS to 2.7.1 BETA after the tests on FW 7.0.1.
     
    Last edited by Kurems, May 5, 2019
    Chizko, isoboy, Garou and 2 others like this.
  5. AceVader0

    AceVader0 Member

    Newcomer
    4
    Jul 30, 2013
    United States
    Just tried a couple really old games: MK8 Deluxe and Mario Tennis, none of them worked. I guess the NSP updates are at fault here, so I'm gonna delete them, install them again and see if it works....
    However I won't do that to every single game. They better fix this, and quick.
     
  6. lukands

    lukands I took the little bus here

    Member
    5
    Mar 27, 2009
    Estonia
    Your mamas house
    Did you report the post???
     
  7. Zygizz

    Zygizz Member

    Newcomer
    3
    May 9, 2018
    Lithuania
    2.7 and 2.71 sx os firmware version i getting error then trying to boot into cfw . Anyone having the same issues ?
     
    HellaJvke likes this.
  8. Hielkenator2

    Hielkenator2 GBAtemp Regular

    Member
    2
    Jul 18, 2017
    Albania
    ALSO CONFIRMING ALL INSTALLED GAMES, SD CARD AND INTERNAL MEMORY CORRUPTED ON 2.7.1.

    I came from 7.1 and updated to 8.1, using 2.7.0 > 2.7.1

    How do we get this info to TX?
     
  9. HellaJvke

    HellaJvke GBAtemp Regular

    Member
    3
    Oct 25, 2016
    United States
    In your mind
    noooo
    can someone please help me

    im not able to boot into the sxos menu at all
    i see the green light after the blue light and then a black screen
    is it my filesystem??
    nothing really changed i just updated to 8.0.1 vio horizon
    ive got
    /nintendo
    /switch
    /sxox (this folder is empty it was not on my card after i updated do i need anything in here?)
    /tinfoil
    boot.dat (latest beta from sx ((though i couldnt find just 2.7)))
    hbmenu.nro
    hekate_ctcer_2.3bin
    info.json
    licence.dat
    license request.dat
    manifest.install
    sxos.upd

    anyone have advice for me?
    ive never used autorcm, im running exfat have the update
    i tried both methods of turning off my console like someon ementioned

    if anyone has the 2.7 .dat lmk i could try that one if the 2.7.1 isnt working...
     
  10. viper3344

    viper3344 GBAtemp Regular

    Member
    4
    Aug 18, 2011
    United States
    Never used emunand and am about to update my 100% working 7.0.1 to 8.0.1

    Even with this hot fix SX patch, there are still reports of games not working? I don’t want to reinstall anything. I have always just installed NSPs via SXos album since release of the first sxos
     
    MarkDarkness likes this.
  11. brollikk

    brollikk GBAtemp Fan

    Member
    5
    Mar 8, 2018
    United States
    Yes there are reports of nsp games being broken, specifically those that have update patches
     
    MarkDarkness likes this.
  12. dsrules

    dsrules GBAtemp Guru

    Member
    10
    Sep 20, 2005
    also confirmng all installed games in my microsd are working fine on 2.7.1 8.0.1
     
  13. Safaraffo

    Safaraffo Newbie

    Newcomer
    1
    May 5, 2019
    United States
    I have the same problem as you. Everything was working fine until I updated to 8.0.1 and sx os version 2.7.1. Only reason I updated is because apparently 8.0.1 was patched but now it doesn't even load into the cfw menu.
     
  14. kamesenin888

    kamesenin888 GBAtemp Maniac

    Member
    8
    Oct 20, 2007
    You are so salty that is funny, what is forbidden is to link to sx directly not to a post on another forum that may have the link to sx
     
    KhenemetHeru likes this.
  15. WiiuGold

    WiiuGold GBAtemp Advanced Fan

    Member
    8
    Jan 5, 2015
    United States
    Reinstall your games :)
     
  16. KhenemetHeru

    KhenemetHeru Advanced Member

    Newcomer
    3
    Apr 22, 2015
    United States
    New Britain, CT
    Use XCIs, don't install anything, stitch all dlc and updates into them with NSCB.
     
    Redferne and XTRIPLEX like this.
  17. SexiestManAlive

    SexiestManAlive GBAtemp Expert

    Member
    5
    Apr 18, 2016
    United States
    anyway to play the games without updating? as i have no idea how to make custom xcis, and want to play mario odyssey
     
Loading...