Two identical USBs. 1 works, 1 doesn't on USB Loader GX

Discussion in 'Wii U - Hacking & Backup Loaders' started by John Brown, Aug 25, 2015.

  1. John Brown
    OP

    John Brown Member

    Newcomer
    13
    1
    Apr 25, 2015
    Canada
    Tech Stuff (versions, hardware configurations, etc...)
    Hi, I have two Lexar JumpDrive 32GB USB 3.0 Flash Drives, both of which are formatted to FAT32 with an allocation unit size of 16 kilobytes. I have homebrew channel 1.1.1 installed on my Wii U. I have this d2x-v10-beta53-alt-vWii installed. Nintendont is at version 3.371 and USB loader GX is on version 3.0 R1256-1257. I also have CFG usb loader (70) and Wii Flow (1054).

    The Problem
    So of the two lexar usbs I mentioned only one of them works with USB loader gx and it works flawlessly. The other one, which is exactly the same doesn't. A message pops up saying "USB device not initialized". Both usbs were plugged in port 0. I have the same gamecube game with the same directory on both usbs. Both USBS work with Cfg usb loader, wii flow and nintendont but due to various reasons USB Loader GX is the best option for my setup. After long hours of trial and error a different message pops up. It say "No WBFS or FAT/NTFS/EXT partition found. You can select or format a partition or use the channel loader mode." Anyone have any idea why one of my usbs isn't working and how to fix it?
     
  2. pedro702

    pedro702 GBAtemp Guru

    Member
    6,599
    2,114
    Mar 3, 2014
    Portugal
    maybe one is more fragmented than the other im guessing, but you shouldnt even considering using flashdrives on wiiu, the power output is so wierd that it isnt reliable thats why nintendo asks people to use y cables that damn power output is crap.
     
  3. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,274
    8,748
    Oct 27, 2002
    France
    Engine room, learning
    Like he said, flashcard are not recommended as you need additional power suply with most drives and flashdrives can't use them.
    also, I'm pretty sure 90% of flash drives can't "install game" (dump disc to ISO). they can be read, but writing is unstable or even not supported.

    About your issue, did you bought the two drives at the same time?
    Sometime, manufacturers are not shipping the same hardware or the same firmware version inside the hardware PCI/USB adapter integrated in your product.

    Your issue looks like the one that a lot of users are having lately, the drive just can't be mounted.
    a user tried to update his hard drive firmware (possible because Western digital HDD had that option) and suddenly that drive worked fine !
    so, maybe your issue is the same.

    I still haven't investigated or figured out why USBLoaderGX has that issue while other homebrew are compatible.
     
  4. FaTaL_ErRoR

    FaTaL_ErRoR AKA ŦƕƎ ƠṀƐƝ

    Member
    491
    346
    Mar 9, 2014
    United States
    I too really don't understand what the problem is. I have probably around 30-40 different usb flash drives ranging from 1gb to 120 gb. And mostly different brands. I haven't had any problems using usbloader gx with any of them. In fact I have dumped games from the u to them without issue.
    I really only had a problem getting a darn passport working on the wii u and it was because of an outdated firmware issue. (I am gonna guess that's a wii-u side issue)
    Honestly if it's not a power issue more than likely it's a user issue or defect in the drive.
    @ OP do a complete full format on that drive and try again. Make sure it's the long format. And maybe try using your pc's port 0 as well. (pc port 0 probably will help in no way but personally I've had trouble formatting in my port 4 of my pc so it's worth a shot)
    I am not saying you are stupid or anything like that. But from time to time we all screw up and either remove the usb prior to it fully formatting or try to cut corners and don't do a full format. It happens. Just try these things and let us know the outcome. Also, Ive never heard of lexar but I have google so time to check that brand out.
    Edit: lol don't know the brand but apparently I own one....what an idiot I am. I have a 32gb one. Just argued with the MRS about not having one and she threw it at my head...
    Big tip, don't argue with your wife....It hurts like a bitch.
     
  5. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    18,274
    8,748
    Oct 27, 2002
    France
    Engine room, learning
    Oh, so you have a lot of flashdrive with zero issues?
    I always thought flashdrives were not working correctly, I guess users only comes here to report issues with it and never when it works fine, so I thought the majority of drives were faulty.
    I don't know why some flash drives can't dump games (it freezes at random %, often at 0%).

    john: I know you want to use two drives, one for wii and one for gc, but is it only because of the limited space?
    I recommend using a bigger drive, and put both Wii and Gamecube (and Wiiware/VC/other homebrew) on the same drive. Even on the same partition it's fine.
    It's a lot easier to setup and less hassle than configuring homebrew to use dual USB Ports.