Homebrew Emulator TwilightMenu++ Gbarunner2 issue, dsp-audio and hicode builds don't work

Alexboy2334

Member
OP
Newcomer
Joined
Apr 4, 2021
Messages
13
Trophies
0
Age
39
XP
49
Country
United States
I have a DSiXL with TwilightMenu ++ v20.1.0 launched with the Memory Pit (Without HiyaCFW) and I tried to use the latest dsp-audio and hicode builds for DSi but they don't work properly. The dsp-audio build crashes with a black screen with only Gbarunner2 written. The hicode build seems to work, but the game crashes when I open a save file. The version of Gbarunner2 integrated with TwilightMenu ++ works perfectly, but I wanted to use these builds to solve the audio problem with Mario and Luigi Superstar Saga (https://wiki.gbatemp.net/wiki/GBARunner2/DSi_3DS_Compatibility_List). This is an image of the "_gba" folder and the "_nds" folder. I have attached the "settings.ini" file below.

upload_2021-5-13_15-21-37.png


upload_2021-5-13_15-21-26.png


I don't see anywhere a folder named "nds-bootstrap", is that a problem?
 

Attachments

  • upload_2021-5-13_15-8-11.png
    upload_2021-5-13_15-8-11.png
    19.2 KB · Views: 31
  • upload_2021-5-13_15-10-31.png
    upload_2021-5-13_15-10-31.png
    5 KB · Views: 28
  • settings.zip
    1,005 bytes · Views: 34

RocketRobz

Stylish TWiLight Hero
Developer
Joined
Oct 1, 2010
Messages
14,893
Trophies
2
Age
22
XP
17,150
Country
United States
I have a DSiXL with TwilightMenu ++ v20.1.0 launched with the Memory Pit (Without HiyaCFW) and I tried to use the latest dsp-audio and hicode builds for DSi but they don't work properly. The dsp-audio build crashes with a black screen with only Gbarunner2 written. The hicode build seems to work, but the game crashes when I open a save file. The version of Gbarunner2 integrated with TwilightMenu ++ works perfectly, but I wanted to use these builds to solve the audio problem with Mario and Luigi Superstar Saga (https://wiki.gbatemp.net/wiki/GBARunner2/DSi_3DS_Compatibility_List). This is an image of the "_gba" folder and the "_nds" folder. I have attached the "settings.ini" file below.

View attachment 262803

View attachment 262802

I don't see anywhere a folder named "nds-bootstrap", is that a problem?
No, it isn't.
The problem is that Unlaunch isn't installed. You need to install Unlaunch to use those builds, the first of which should already be included.
 

Alexboy2334

Member
OP
Newcomer
Joined
Apr 4, 2021
Messages
13
Trophies
0
Age
39
XP
49
Country
United States
No, it isn't.
The problem is that Unlaunch isn't installed. You need to install Unlaunch to use those builds, the first of which should already be included.

Thank you very much for your reply. Sorry but I'm not very expert with DSi hacking.
 
  • Like
Reactions: banjo2
General chit-chat
Help Users
    Psionic Roshambo @ Psionic Roshambo: https://imgur.com/gallery/kUTOYMV