Twilight Hack says I'm having too old IOS's

Discussion in 'Wii - Hacking' started by Eplez, May 16, 2009.

  1. Eplez
    OP

    Eplez Newbie

    Newcomer
    4
    0
    May 12, 2009
    Norway
    Hi there,

    I have a bit of a problem going on here. I have blown the dust of my old Wii (FW 2.1E) and was going to use the twilight hack on it.

    After loading up the save and when I'm going to install the Homebrew Channel, i get the following message:
    "...Homebrew channel requires any ios newer than or equal to ios21...".

    I got a hold of a file called "IOS21-64-v514.wad.out.wad" (from the Trauma Center game).

    How do I advance from here? Will updating IOS 21 be enough, or will there be other IOS and Channels that haven't been updated that can crash if my Wii is semi updated?

    If updating ISO 21 is enough, should i just
    * Put WadImport (http://wiibrew.org/wiki/WadImport) and the IOS in question on a SD card
    * Import the IOS
    * Put HBC on the SD card and install?

    In advance, thanks! [​IMG]
     
  2. WiiPower

    WiiPower GBAtemp Guru

    Member
    8,165
    72
    Oct 17, 2008
    Gambia, The
    Updating to 3.2 is recommend anyways, but just installing IOS21 should do it. If WadImport fails, try WAD Manager. And i would install IOS36v1042 too if you are able to get that wad.
     
  3. Eplez
    OP

    Eplez Newbie

    Newcomer
    4
    0
    May 12, 2009
    Norway
    Thanks for the quick reply!

    I extracted IOS36-64-v1042.wad.out.wad as well.

    But how could I upgrade specifically to 3.2? I assume if I use the online updater, I'll go straight to 4.0.
     
  4. dark42

    dark42 GBAtemp Regular

    Member
    193
    1
    Nov 13, 2007
    United States
    You could update to 4.0 through Nintendo, and use bannerbomb and Bootmii installer to install HBC. Why do you want to go to 3.2?
     
  5. WiiPower

    WiiPower GBAtemp Guru

    Member
    8,165
    72
    Oct 17, 2008
    Gambia, The
    Yes the online updater goes straight to 3.2.

    Just try to install IOS21 and IOS36 first. Then install the HBC. And then take a closer look at AnyRegionChanger.

    Because on 4.0 every IOS is trucha fixed. Why 2.1.>4.0->3.2/4.0 hybrid* if 2.1->3.2/4.0 hybrid is directly possible?

    *That's how i would call the firmware most people here use. That's all 3.2 IOS + all IOS from 4.0 that are not included in 3.2 + patched IOS60 and 4.0 system menu(optional, the alternative is of course the 3.2 system menu).
     
  6. Slowking

    Slowking GBAtemp Maniac

    Member
    1,396
    25
    Dec 31, 2006
    Gambia, The
    Use one of the 4.0 upgrade guides that are around here somewhere. If you are going to use Waninkokos Updater also use IOS Downgrader to upgrade your IOSs.
     
  7. stiansoftcore

    stiansoftcore Member

    Newcomer
    14
    0
    Aug 4, 2008
    United States
    Not if you want lots of GC homebrew [​IMG]
     
  8. FenrirWolf

    FenrirWolf GBAtemp Psycho!

    Member
    4,346
    326
    Nov 19, 2008
    United States
    Sandy, UT
    Mario Kart and Barlw both have the 3.1 update, so you could always use those discs to get you to that point and then install the HBC
     
  9. steve-p

    steve-p GBAtemp Advanced Fan

    Member
    503
    0
    Apr 13, 2009
    update from "samba de amigo",
    it has the latest 3.1 v4 on it.

    then search the torrent sites for 3.2 offline-upgrade
    it's the wads for ios30 & 3.2 sysmenu.
    bung them in with wad-manager after you install hbc & cios10.

    make sure both the game & wads are for your region first!!!
     
  10. Eplez
    OP

    Eplez Newbie

    Newcomer
    4
    0
    May 12, 2009
    Norway
    Just wanted to thank everyone once more for your quick replies =D

    I've installed IOS21 and IOS36 and added the homebrew channel.

    I tried to update to 3.2E via Any Region Changer, but it didn't seem to like my network (although HBC says the network is initialized and shows me the correct IP)

    @steve-p

    I assume i would need to install "WiiGators Gamma 0.3 loader" if I were to run a Samba De Amigo backup to update to 3.1 v4? Is there anything else I need to take into consideration before doing that? Don't want to brick my wii at the finish line [​IMG]
     
  11. steve-p

    steve-p GBAtemp Advanced Fan

    Member
    503
    0
    Apr 13, 2009
    assumed you had a chip!
    my bad [​IMG]

    is your network encrypted?
    try disabling the encryption to do an upgrade.
     
  12. Eplez
    OP

    Eplez Newbie

    Newcomer
    4
    0
    May 12, 2009
    Norway
    Oh, lol.

    Disabled encryption and it's installing and going through stuff now although the first line after network initialization was:

    Error! isfs_open (ret = -106)

    Will edit this post and keep you posted (no pun intended [​IMG])

    Edit:
    Update went well.. Rebooted after installation and it now says 3.2 in the options. Also installed cIOS v9

    Just need to read up more on the starfall / gamma thing if I need both to run backups (going to order USB HDD, but will use my DVD's for a couple of weeks)
    Installed preloader 0.29 and set it to use IOS36, but it won't load games from the disc channel. Only says "Unable to read disc".

    Also the HBC apps looks a little wank. Doesn't show descriptions, version numbers etc etc like i've seen on the youtube videos. Found out I either a) Had to get the Homebrew Browser, or b) Manually add the meta.xml files to the folders

    I guess all in all, it was a success. Thanks once again [​IMG]
     
  13. WiiPower

    WiiPower GBAtemp Guru

    Member
    8,165
    72
    Oct 17, 2008
    Gambia, The
    Seriously, where did you get the information that preloader loads backups? You are not the first one thinking that? (it's totally wrong)

    preloader,BootMii, the twilight hack, starfall, HBC, DVDx,Gecko OS, team twizzers, bushing, marcan, sven peter,Nuke, brkirch .. these are all things or persons that have absolutely nothing to do with backups. The persons are in fact strictly against backups because they know backup mostly means pirated copy.
     
  14. Alexrose

    Alexrose Untitled

    Member
    783
    150
    Jan 20, 2009
    England
    Speaking of which, install bootmii as boot2 now for more brick protection.