[Tutorial] Restore Patched Home Menu/NS/AGB/TWL (AuReiNand does this for us now)

Discussion in '3DS - Tutorials' started by KhaderWelaye, Apr 16, 2016.

  1. KhaderWelaye
    OP

    KhaderWelaye GBAtemp Regular

    Member
    253
    92
    Mar 31, 2012
    United States
    Background: Prior to AuReiNand supporting Region Free, TWL and AGB patching, all of these things had to be patched using CIA files. Now that these are features officially supported by AuReiNAND, I wanted to clean up my system firmware so I didn't have multiple patches coming from multiple places before updating AuReiNand from v3.14.

    What we're doing: We are going to use 3DNUS Mod to download the appropriate titles that we have likely modified, use FBI to uninstall the patched CIAs and then re-install the clean untouched firmware files.

    Please Note: This tutorial partially assumes that you are already familiar with running CFW and using FBI. If you are having trouble with these, this tutorial is not the place to start.

    What you will need:
    Steps:
    1. Download 3DNUS Mod and extract it to its own folder.
    2. Use the Title IDs below to download CIAs for anything you have modified. Make sure in 3DNUS that "Pack as .CIA" is selected and that you've chosen New 3DS or Old 3DS based on what you have.
      Home Menu (10.6U-10.7U) - Usually modified for Region Free CIAs
      NS system-module (10.4U-10.7U) - Usually modified for Region Free Cartridges
      AGB (6.0U-10.7U) - Usually modified for GBA Firmware Patch
      TWL (6.2U-10.7U) - Usually modified for DSi Firmware Patch
      Different Region or Lower Firmware
    3. Copy the downloaded CIA files to your 3DS' SD Card. You will find then in the 3DNUS directory.
    4. Before we do anything with these CIA files, as we are making changes to core system modules, make sure you've made a NAND backup just in case.
    5. Launch FBI, and use the L-Button to Switch the Destination from SD to NAND. Next, use the R-Button to Switch the Mode to Delete Title.
    6. Before we can install the CIAs we downloaded, we need to delete the patched titles. To do this, go through the list and look for Title IDs that match the ones you downloaded. The Title ID for each title shows at the top of the top screen in FBI. This can be a little tedious, so be patient and make sure you are deleting the correct title. If you downloaded 4 CIA files, there will be 4 matching Title IDs in this list.
    7. After deleting the appropriate titles, use the R-Button to switch back to Install CIA
    8. Install the CIA files that you copied to your SD card earlier, one by one.
    After this, your titles will be back to their clean selves with no patches. At this point, go ahead and take advantage of AuReiNand's ability to do all this without custom patched firmware files!

    (don't remember if AuReiNand supports region free cartridges yet so some of you might end up leaving the NS system-module patch in place)
     
    Last edited by KhaderWelaye, Apr 16, 2016
  2. mgrev

    mgrev Legit Gladiator

    Member
    1,814
    2,194
    Apr 13, 2015
    Norway
    Under Tomato Hentai's stairs
    you should add title id's for all the regions
     
    anonymoose likes this.
  3. KhaderWelaye
    OP

    KhaderWelaye GBAtemp Regular

    Member
    253
    92
    Mar 31, 2012
    United States
    I'll get around to it at some point for convenience sake, for now the link in the section on if you have a different region or lower firmware should be sufficient.
     
  4. ChoiB

    ChoiB Newbie

    Newcomer
    3
    0
    May 25, 2016
    I does not work for me. I'm on latest Luma3ds+A9LH with updated firmware. I have patched my twl before, so tried restoring doing this. It installed just fine, but still it does not detect my R4i Gold Pro and R4i Revolution. I don't know if my r4 is working anyway, I will have to try on other 3ds.
     
  5. brkun

    brkun GBAtemp Fan

    Member
    415
    69
    Mar 9, 2015
    United States
    Guys, i know this is old, but i need to do this BUT for 11.1 :(

    Cant get 3dnus to work
     
  6. laharl22

    laharl22 GBAtemp Maniac

    Member
    1,386
    138
    Dec 19, 2014
    France
    how to fix invalid argument when i try to install the untouched ns cia ?
     
  7. Alter Ratione

    Alter Ratione Advanced Member

    Newcomer
    86
    16
    May 29, 2015
    Brazil
    I have got to the same error but since I did not found an answer, I tried a clean install with saves backed up.