Tutorial [TUTORIAL] More-or-less Catch-All Tutorial

Switch CFW tutorial to focus on ReiNAND?

  • Switch to ReiNAND (Lighter footprint, seems to work better in most systems, native regionfree TBD)

    Votes: 6 85.7%
  • Keep using rxTools (Unstable, build Dropbox host goes down every other day, generally troublesome)

    Votes: 1 14.3%

  • Total voters
    7
  • Poll closed .

iamhelltothee

Member
Newcomer
Joined
Jan 8, 2016
Messages
19
Trophies
0
Age
27
XP
57
Country
Venezuela
I am trying to get step 11 done. So far everything has gone right but when CTRBootManagers purple screen shows, it reads:

Configuration file not found: /boot.cfg
Creating default configuration...
Press any key to continue...

Now, of course I have the boot.cfg in there, and I tried overwritting it and double checked the code written inside the file. Also gave it multiple tries but still nothing. And the screen just freezes, pressing "any key" does nothing and I have to turn off.

What am I doing wrong?

I overwritted boot.3dsx and boot.cfg from CTRs original .zip and then manually edited my boot.cfg from within the SD card. Maybe I messed up somewhere before.
 

iamhelltothee

Member
Newcomer
Joined
Jan 8, 2016
Messages
19
Trophies
0
Age
27
XP
57
Country
Venezuela
Might've been improperly closed brackets.
Oh well, at least it's fixed now.
Probably, Im not overly familiar with coding. I know how brackets work, but I probably wouldnt notice if they are not right lol.

Im getting a new error thou. When I try to check TMD, after going to Inject FBI, emuNAND and press B for check TMD only, I get this:

Opening S....
Failed!
Opening S....
Failed!
 

thegameksk

Well-Known Member
Member
Joined
Jan 5, 2016
Messages
207
Trophies
0
Age
38
XP
471
Country
United States
I am on new3ds. After step 10 I am having trouble. When I boot it boots to rx tools but it says err:couldnt load arm 9 payload. If I try to go to anything else the screen just turns red and nothing happens.
 

Sgt. Lulz

Beef up
OP
Member
Joined
Oct 16, 2010
Messages
404
Trophies
0
XP
1,207
Country
United Kingdom
Probably, Im not overly familiar with coding. I know how brackets work, but I probably wouldnt notice if they are not right lol.

Im getting a new error thou. When I try to check TMD, after going to Inject FBI, emuNAND and press B for check TMD only, I get this:

Opening S....
Failed!
Opening S....
Failed!
I've heard thousands of reports of this error pretty much everywhere.
Try one of the following:
1. Redownload firmware.bin.
2. Use the alternate rxTools version.
3. Inject it manually through d0k3's injection tool.
 

iamhelltothee

Member
Newcomer
Joined
Jan 8, 2016
Messages
19
Trophies
0
Age
27
XP
57
Country
Venezuela
I've heard thousands of reports of this error pretty much everywhere.
Try one of the following:
1. Redownload firmware.bin.
2. Use the alternate rxTools version.
3. Inject it manually through d0k3's injection tool.

Third option is the n3ds method from your guide, correct?
Ill try this asap. Thanks.
 

Sgt. Lulz

Beef up
OP
Member
Joined
Oct 16, 2010
Messages
404
Trophies
0
XP
1,207
Country
United Kingdom
Third option is the n3ds method from your guide, correct?
Ill try this asap. Thanks.
Yeah, but it works on O3DS too, of course.

I am on new3ds. After step 10 I am having trouble. When I boot it boots to rx tools but it says err:couldnt load arm 9 payload. If I try to go to anything else the screen just turns red and nothing happens.
ERR:Couldn't load ARM9 payload happens when a file is missing or otherwise corrupted and unusable.
Try reinstalling rxTools and everything else.
 
  • Like
Reactions: thegameksk

thegameksk

Well-Known Member
Member
Joined
Jan 5, 2016
Messages
207
Trophies
0
Age
38
XP
471
Country
United States
Yeah, but it works on O3DS too, of course.


ERR:Couldn't load ARM9 payload happens when a file is missing or otherwise corrupted and unusable.
Try reinstalling rxTools and everything else.


Not sure whats going on. I re-downloaded everything and I still get this issue.
 

thegameksk

Well-Known Member
Member
Joined
Jan 5, 2016
Messages
207
Trophies
0
Age
38
XP
471
Country
United States
Well, I'm stumped.
Your SD card might be kicking the bucket, I'm not too sure.
Does anything else work?
the Homebrew Launcher .3dsx should at LEAST work.

The boot entry works and it has different options to pick from. Rx tools gives me that error with purple screens, pasta and homebrew menus top screen is black and bottom is red but the system just hangs. Have to restart by holding power button.

edit: file browser, settings, reboot, and power off work. Netload too.
 
Last edited by thegameksk,

iamhelltothee

Member
Newcomer
Joined
Jan 8, 2016
Messages
19
Trophies
0
Age
27
XP
57
Country
Venezuela
DONE! after days of trying before stumbling upon your guide I have emuNAND runing through rxTools. I injected FBI manually and then installed the CIA using de Health and Safety one btw. Thank you very much.

I have a question regarding the unlinking process. Given the fact that I actually ran TinyFormat before I even downgraded, so right now I have nothing installed nor any NNID associated with my sysNAND, would it be better to install and run TinyFormat in sysNAND instead? Would that keep my emuNAND intact, while still achieving unlinking and allowing me to later update emuNAND to 10.3 (Im on an o3ds btw) and signing in to my NNID?

EDIT: Solved. Thanks again for the patience and the great guide mate.
 
Last edited by iamhelltothee,

lowe23

Member
Newcomer
Joined
Jan 11, 2016
Messages
19
Trophies
0
Age
34
XP
39
Country
Canada
I've followed your guide with mostly smooth sailing, but I've gotten to the rxTools part. In CTRBootManager, I hold L and press A to open the rxTools menu. When i get there, it gives me "failed to load native_firm". Was I suppose to do anything else? I've made sure firmware.bin is in /rxTools/sys/

I'm on O3DS btw.

EDIT: Used the alternative version and things worked out.
 
Last edited by lowe23,

Kylezo

Active Member
Newcomer
Joined
Jan 7, 2016
Messages
40
Trophies
0
Age
37
XP
94
Country
United States
This is beyond a joke now.
Let me put it this way: There's a certain limit to how much something can be idiot-proofed before it just becomes plain unfit for consumption.

My bad, I think the guide formatting made it kind of unclear to me, didn't intend to be such a huge burden with my one issue, lol. I fixed that anyways before I even finished posting, so not sure why you even replied to it, but thanks for the clarification, it may help someone else.

Started over using confirmed nightly, saw your 16a update, tyvm for addressing that. All appears to have gone smoothly but I have one final question, can anyone point me to a guide for restoring my mii/streetpass data from before the downgrade (is that even possible)? I have all these requisite backups, would love to get my old guys back.

/e: alternately/additionally, info on preserving this data for when I downgrade my main console would be very helpful.
 
Last edited by Kylezo,

lowe23

Member
Newcomer
Joined
Jan 11, 2016
Messages
19
Trophies
0
Age
34
XP
39
Country
Canada
I have EmuNAND running. Everything seems to be OK, except that FBI isn't working when I start Health & Safety. Any ideas?

EDIT: fixed this too
 
Last edited by lowe23,

SuperNintendo64

Well-Known Member
Member
Joined
Dec 21, 2015
Messages
140
Trophies
0
Age
42
XP
172
Country
Bulgaria
Ive just installed HBL cia on emunand, but it dosent work.

It reads

"failed to download the payload with http"

I know there´s something i need to do with it, but the guide only says "you have to edit the payload hold Y"

No, holding Y didnt got me anything
 

Boreas3

New Member
Newbie
Joined
Jun 17, 2015
Messages
4
Trophies
0
Age
24
XP
518
Country
Belgium
Hello,
I've a little stupid question:
Can I use oothax to go into rxtool with CtrBootManager?

Thanks you for your future answer :-)
 
General chit-chat
Help Users
    Dark_Phoras @ Dark_Phoras: Nevermind, better quality in a week, and the current version brings permanent korean subtitles