Trying to update my 4.1U Wii to 4.3U safely

Discussion in 'Wii - Hacking' started by Cyber Akuma, Aug 19, 2010.

Aug 19, 2010
  1. Cyber Akuma
    OP

    Member Cyber Akuma GBAtemp Regular

    Joined:
    Mar 12, 2009
    Messages:
    126
    Country:
    United States
    I am still on 4.1U, mainly because 4.2U offered basically nothing and ricked bricking my Wii, though 4.3U has some useful things. So I have a few questions to ask.

    1. The latest version of HackMii installer supports USB2.0 through the IOS58 that 4.3U added, so then should I install the latest version of HackMii first then 4.3, or 4.3 first?

    2. Does 4.3 still attempt to reflash your boot2?

    3. Is there any sort of "safe" updater that only installs the channel, ios files, etc that are missing from 4.2 and 4.3 without actually stubbing my 200+ CIOS files, deleting my homebrew, undoing any of my hacks, patching security holes, etc?

    Basicallly, what would be the safest and least messy way to go from 4.1U to 4.3U while keeping all my hacks and not risking a brick that replaces my boot2 installed bootmii?
     
  2. elimist

    Member elimist GBAtemp Regular

    Joined:
    Mar 31, 2009
    Messages:
    282
    Country:
    United States
     
  3. mauifrog

    Member mauifrog DA KINE WiiHacker

    Joined:
    Jan 21, 2010
    Messages:
    1,585
    Country:
    United States
    You can use dop-mii v13 to update all your outdated ios, mios, bc and boot2 and stay on 4.1- which is just great.
     
  4. s3phir0th115

    Member s3phir0th115 GBAtemp Advanced Fan

    Joined:
    Dec 31, 2008
    Messages:
    700
    Country:
    United States
    1. You could, but you don't have too. You can intall IOS58 without updating if you wish.

    2. Depending on when your wii was last updated, it does try. I forget which 4.x update tries updating the boot2, I just know that one of them does.

    3. Well, Waninkoko made one. But I find the best approach is to do it yourself with Wad manager and NUSD.

    As for the best and safest way, I'd advise wad manager with NUSD. Though there are alternatives, like Dop-Mii.
     
  5. VashTS

    Member VashTS Beat it, son

    Joined:
    Mar 14, 2009
    Messages:
    3,653
    Location:
    Upstate NY
    Country:
    United States
    if you don't want to rick bricking you're wii, then leave it at 4.1 (or 4.2) its the best at this point.

    1st rule of wii hacking, never update your system menu (until its verified as meaningful, if it is).
     
  6. Cyber Akuma
    OP

    Member Cyber Akuma GBAtemp Regular

    Joined:
    Mar 12, 2009
    Messages:
    126
    Country:
    United States
    Well, the reason I am asking is because I once had a disk game that would not start because there were some IOS files I needed installed before it would play, another time some Pokemon Wiiware title would not run until I updated an already existing IOS file to a newer version. I really care more about just making sure all games will run with all their features than my Wii being "updated".

    Does the 4.3U System Menu do ANYTHING over 4.1U other than just attempt to remove homebrew? If not, then I have no reason to update anything other than my IOS files (unless 4.1U is incompatible with the newer files, but from what I understand of how IOS files work, that shouldn't be a possibility).

    And I know I can install IOS58, but I am sure there were other new IOS files added as well as older IOS files updated right? Is there a list anywhere of what files were added/updated since 4.1U so I can manually add them to my Wii?

    Finally, is there any way I can scan my Wii for what IOS/CIOS files are installed, which ones are not installed, and what version they are? I am always running outdated version of my CIOS files because I constantly forget to update them, I am sure my IOS files are very out of date.

    This is why I wanted to "update" my Wii to 4.3U.

    Will dop-mii be able to do this? Are there any other risks or problems it can cause? Especially with my cios files? Will it be able to check my CIOS files too? Do any hacks rely on older IOS files anymore to work or are they pretty much all official IOS or CIOS200+ now?
     
  7. trumpet-205

    Member trumpet-205 Embrace the darkness within

    Joined:
    Jan 14, 2009
    Messages:
    4,363
    Country:
    United States
    4.3U does nothing other than removing homebrew. Don't let Nintendo fool you.

    I do recommend you update to 4.2U, since it did fix a bug for a game in multiplayer (forgot what game it is).

    To install IOS58, just use DOP-Mii or IOS58 installer.

    To scan IOS, use DOP-Mii (syscheck).
     

Share This Page