Trying to understand why SNES wont load on Luma

Discussion in '3DS - Flashcards & Custom Firmwares' started by player0, Jan 14, 2017.

  1. player0
    OP

    player0 GBAtemp Regular

    Member
    193
    10
    Sep 2, 2006
    Was trying to load MegaManX (Region:all) from Freeshop on two New3DS
    Machine 1: luma6.6 on sysnand 11.2.0-35E
    Result: Can see both TV and SNES icons, game loads in English

    Machine 2: luma6.6 on sysnand 11.2.0-35J
    Result: Can't see SNES but only TV icon, game jumps out and asks to do system reboot

    Same SD card so not a hardware issue. Same source (freeshop) same CFW version on same 11.2.0 just different region machine.

    Can someone try to point out why the difference?
     
  2. Columbo2811

    Columbo2811 GBAtemp Maniac

    Member
    1,271
    750
    Jul 19, 2015
    Usa and Europe snes games are the same. Games can run on both. Japan ones have issues I think. If I remember rightly if you start a euro/Usa game through hans first on Japan console they'll play fine after.
     
  3. player0
    OP

    player0 GBAtemp Regular

    Member
    193
    10
    Sep 2, 2006
    More testing on the machines show a pattern:
    EU machine can always see both the SNES and TV icons for all different regions games and games load fine, EU games load in English and JP games load in Japanese.

    JP machine can always see both the SNES and TV icons ONLY for JP games. EU/US, even region free games all only show a TV icon without SNES. But still the games load fine, EU games load in English and JP games load in Japanese. However, region free games are the games that I said earlier (MegamanX) that will jump out and reboot.

    Is Luma not supporting JP machines as good as EU ones?
     
  4. squall14716

    squall14716 GBAtemp Maniac

    Member
    1,162
    662
    May 16, 2011
    United States
    Despite being flagged as region free, Mega Man X has a separate dedicated Japanese release - the one with the title in English is not actually meant to be used on Japanese systems. The issue isn't Luma AFAIK, it's just that SNES VC doesn't play well on out-of-region systems, most likely due to the pop-up on first launch that asks whether you want to allow information to be shared with Nintendo.
     
    Last edited by squall14716, Jan 15, 2017
  5. player0
    OP

    player0 GBAtemp Regular

    Member
    193
    10
    Sep 2, 2006
    Yes you are right, the JP release RockmanX shows the icons (both) fine and runs fine on JP machine.
    But IDK, that does not explain why everything seems so prefect on EU machine but not JP machine if its not Luma in play?
     
  6. Columbo2811

    Columbo2811 GBAtemp Maniac

    Member
    1,271
    750
    Jul 19, 2015
    Have you tried
    Enable region/language emulation and external .code: Enables the following two features:
    From here
    https://github.com/AuroraWright/Luma3DS/wiki/Options-and-usage
     
  7. player0
    OP

    player0 GBAtemp Regular

    Member
    193
    10
    Sep 2, 2006
    Yea, that didnt help at all. Tried all combinations like EU+EN EU+JP US+EN US+JP JP+JP JP+EN. All ended up the same (jump out and reboot)