Trying to revive a GBA SP: what's wrong?

Discussion in 'GBA - Hardware, Devices and Utilities' started by xenon, Sep 4, 2006.

  1. xenon
    OP

    xenon GBAtemp Regular

    Member
    153
    0
    May 19, 2006
    Italy
    Hi. A friend of mine found a GBA SP in a park a couple of years ago. Not being much of a gamer, he gave it to me, and I finally tried to revive it. I bought an USB cable charger, plugged it in and here's what happens:
    if the GBA is turned off, the red LED turns on for about 1/2 second, then it goes off. If the GBA is on, the green and the red LEDs turn on, the screen gets white, again for about 1/2 second, then it's all off. Needless to say, the GBA doesn't get charged and isn't usable when plugged. What could it be? A dead battery?
    Thanks for your attention.
     
  2. KirbyPink

    KirbyPink GBAtemp Fan

    Member
    391
    0
    Jun 30, 2006
    Gbatemp
    Sounds like mine. Sort of. Mine as it if you turn the battery button on all the way up it turns off.

    I say get a new battery.
     
  3. TanookiSuit

    TanookiSuit GBAtemp Addict

    Member
    2,596
    39
    Nov 11, 2004
    United States
    Louisville, KY
    If it doesn't work when it's plugged in I'm not so sure it's the battery as much as a circuitry problem.
     
  4. ridgecity

    ridgecity GBAtemp Advanced Fan

    Member
    759
    0
    Nov 6, 2002
    Mexico
    just get a new one. $40 in k-mart.
     
  5. xenon
    OP

    xenon GBAtemp Regular

    Member
    153
    0
    May 19, 2006
    Italy
    I know they're cheap now, but having a DS Lite I'm not too inclined to spend that money on a GBA. But thanks for your replies.