Trying to get old DSi Flashcard working on 3DS with Luma/al9h

Discussion in '3DS - Flashcards & Custom Firmwares' started by ketchupz92, Dec 9, 2016.

  1. ketchupz92
    OP

    ketchupz92 Newbie

    Newcomer
    4
    0
    Dec 9, 2016
    Gambia, The
    Hello Folks, hope someone can help me cause im kinda lost now.
    At first some intel:
    3DS Al9h and Luma all running updated and on latest 3ds firmware 11.2
    The Flashcard is this one: http://imgur.com/xTUy3G8
    It's still working with my Dsi running firmware 1.4.1
    Whats the error? When trying to start it via twloader it just prompts an error message telling me to push the power button (Does not appear in Home Menu)
    And what i tried:
    Plailects Troubleshooting for broken TWL Firm, but it somehow does not really install the cias via fbi, dunno why
    Various firmware patches for the r4i including a apparent 1.4.4 patch that allows 3ds support
    Googled for hours for different solutions and could not really find an answer that helped me.
     
  2. SirHaxALot

    SirHaxALot Yum Cookies! :3

    Member
    132
    41
    Nov 22, 2016
    Gambia, The
    Is there an error message? If yes what does it say?
     
  3. crazy_p

    crazy_p Advanced Member

    Newcomer
    68
    23
    Sep 3, 2016
    Switzerland
  4. ketchupz92
    OP

    ketchupz92 Newbie

    Newcomer
    4
    0
    Dec 9, 2016
    Gambia, The
    First of all thank you guys for the quick help, but sadly i already tried you link @crazy_p, and fbi does not really give an error when installing those cias but when i pick install and delete cias it never deletes those 5 cias, every other cia works.
    so far im pretty sure the problem is a broken twl/ ds functionality at all, since none of my ds retail games seem to be recognized at all
     
  5. Majickhat55

    Majickhat55 The Red Woman

    Member
    3,949
    1,838
    Mar 28, 2016
    United States
    Asshai
    You don't need TWL Loader with that flashcard. It works on Luma by itself with WOOD, (I have one myself). "if your DS Flashcart already works thanks to that patch, then you don't need this" Luma patches the whitelist so basically any DS flashcard that has worked in the past should work on Luma alone.
     
    Last edited by Majickhat55, Dec 9, 2016
  6. Lilith Valentine

    Lilith Valentine GBATemp's Wolfdog™ Cuddle lesbian derp

    Member
    20,069
    21,175
    Sep 13, 2009
    Antarctica
    Between insane and insecure
    What is the error FBI is giving you?
     
  7. ketchupz92
    OP

    ketchupz92 Newbie

    Newcomer
    4
    0
    Dec 9, 2016
    Gambia, The
    It's not giving any error, it simply does not delete the cias which makes me believe it didn't install them. Btw i don't really know exactly what those cias do when installed, so i can not check if they are installed correctly. Its just super weird for them to not get deleted when all other ones are. The goal of the cias after all is to get the cartridge slot for ds games working after all, which it does not.
    @Majickhat55 , you really have the exact same? I just wonder why it does work for you and not for me then :/

    EDIT: So far i got the normal NDS Games working again, but the flashcard is still not working. How do you start it?
     
    Last edited by ketchupz92, Dec 9, 2016
  8. ketchupz92
    OP

    ketchupz92 Newbie

    Newcomer
    4
    0
    Dec 9, 2016
    Gambia, The
    Nevermind, i just somehow figured it out myself. But for those wondering or running into the same problem, these are the steps i did in order to get it running:
    1. Install a clean TWLFirm from Nintendo, there are threads out there with links, google it if you need it, alternatively you just use your own twl backup. Problem here is, almost no one has one, since plailects guide does not really talk about that since it is a very rare error to happen.
    2. Check if the Card is working correctly at all, i inserted it in a Dsi before and it booted up, but i didn't start a game with the newest firmware wood r4igold 1.64, and thought it worked. Wow i was wrong, turns out the card simply did work up to wood r4igold 1.54, newer ones always freezed when loading an actual game or homebrew off of it.
    3. Check for a certain patch, that essentially turns your older Flashcard into a newer one that's 3ds compatible, there are lot of different revisions out there and mine did not support it natively, so i needed the patch, its somewhere deep hidden inside the card's website labeled on the frontcover.
    4. Update Luma, i had the newest luma but for some reason it was faulty and did never even recognize that a game was in slot 1
    (4.5 Try Plailect's Troubleshooting for a broken twl or dsi/dsi functionality, although it did not work for me, it could work for you, after all you know its the "official thing")
    5. If it still does not show your flashcard in your homemenu, start by reinserting the card over and over until it pops up. I did that before the above steps, and it did not work, but the second after the luma update, it showed up, and in combination with the updated firmware for the flashcard etc. it finally started working. On top of that: There's no need for the other special launchers that i've used so far, it just works like it does on the old Dsi

    I just wrote it in a hurry as im still quite happy that i somehow figured it out after 2 days of tryharding
    so please excuse errors or inconsistencies, if you have the same problem and don't understand a certain step, you can just pm me.