TouhouDS v0.9 on acekard 2i help

Discussion in 'NDS - Emulation and Homebrew' started by Drew8898, Apr 16, 2010.

Apr 16, 2010
  1. Drew8898
    OP

    Newcomer Drew8898 Newbie

    Joined:
    Apr 16, 2010
    Messages:
    4
    Country:
    United States
    Trying to run touhou 0.9 on acekard 2i, but I keep getting an error screen when trying to start up.

    The error screen says libfat failure. Says I need to make sure to properly apply a DLDI patch, but to my knowledge acekard 2i should do that automatically.

    I properly put the touhouDS folder in the rood directory, but I still get the error.

    I'm running AKAIO 1.6 RC2 if that makes a difference.

    Any help would be great.
     
  2. Fishaman P

    Member Fishaman P Speedrunner

    Joined:
    Jan 2, 2010
    Messages:
    3,176
    Location:
    Wisconsin
    Country:
    United States
    Launch it with DSOrganize. NesDS has a problem with it not responding when launched my the AK2i directly. This may be a similar case.
     
  3. Drew8898
    OP

    Newcomer Drew8898 Newbie

    Joined:
    Apr 16, 2010
    Messages:
    4
    Country:
    United States
    Getting a similar error when trying to use DS Organize now. Says I need to properly DLDI patch it. Double checked to see if acekard 2i auto patched, and it should.

    Perhaps the problem is with AKAIO.
     
  4. jurassicplayer

    Member jurassicplayer Completionist Themer

    Joined:
    Mar 7, 2009
    Messages:
    4,280
    Location:
    Pantsuland
    Country:
    United States
    Well did you try checking if the nds file is patched (its great checking that the acekard should autopatch, but its best to check the actual nds file to make sure that it is patched).
    Another idea is to try a couple of homebrew loaders like DSKiosk, DSChannels, Homebrew Menu, Flashcart OS, etc.
     
  5. Drew8898
    OP

    Newcomer Drew8898 Newbie

    Joined:
    Apr 16, 2010
    Messages:
    4
    Country:
    United States
    How do I manually check to see if the nds file is patched?
     
  6. jurassicplayer

    Member jurassicplayer Completionist Themer

    Joined:
    Mar 7, 2009
    Messages:
    4,280
    Location:
    Pantsuland
    Country:
    United States
    Well, you could use a PC GUI patcher and patch it with the acekard dldi. It should say the last dldi it had on and the newest one you put on. Apart from that, try the various homebrew loaders.
     
  7. Drew8898
    OP

    Newcomer Drew8898 Newbie

    Joined:
    Apr 16, 2010
    Messages:
    4
    Country:
    United States
    Found the problem. The DLDI file that came with the AKAIO software is for Acekard+. After downloading the official Acekard2i software and using the DLDI file that came with it and a manual patcher, Touhou 0.9 works fine on AKAIO 1.6 RC2.

    Thank you for the assistance. I probably would have given up if you hadn't put me on the right track of trying to patch it manually.

    I suppose the moral of this incident is to never rely on something to do things manually even if they say they should, and that official software is [occasionally] more reliable than third party software.
     
  8. jurassicplayer

    Member jurassicplayer Completionist Themer

    Joined:
    Mar 7, 2009
    Messages:
    4,280
    Location:
    Pantsuland
    Country:
    United States
    Lol, glad to be of help. Most people just place too much trust in their auto-dldi patcher. I guess I'm just a wary person because I've always had to manually dldi patch the homebrew I download (woot for the no auto-dldi patching R4...).
     

Share This Page