Tinfoil Error: "Failed to commit to content records" on 14.1.1 OFW / 1.3.1 ATMOS / 1.3.0 SIGS

FirM

Well-Known Member
OP
Newcomer
Joined
Jun 20, 2019
Messages
69
Trophies
0
XP
250
Country
United States
Hey there! Experiencing a huge issue with Tinfoil since updating to OFW 14.1.1.

Everything worked fine before. On a fresh boot into atmos, games will work just fine on my SD card. I'll launch Tinfoil, no problems.

I'll go to install an NSP, and no matter which one, it'll get to 100% and then throw an error saying "Failed to commit to content records".

This will create a spinning black icon for the "installed" game. I can remove this by going into the Switch data management settings, and then try twice to delete the software (the first try will throw an error).

However, all the games on the SD card are now unplayable, and will throw the generic "unable to start software" error message when trying to launch anything.

I've tried removing my "atmosphere", "bootloader" and "sept" folders and then adding the new atmos package for 1.3.1, followed by the sigpatches for 1.3.1/HOS14.1.0 (I was told they'd be exactly the same for 14.1.1). I'm launching using the newest fusee file.

So, what's the deal? Did Tinfoil get an update I don't know about? That's essentially the only link in the chain that I didn't update.
 

Draxzelex

Well-Known Member
Member
Joined
Aug 6, 2017
Messages
17,946
Trophies
1
Age
27
Location
New York City
XP
11,875
Country
United States
Hey there! Experiencing a huge issue with Tinfoil since updating to OFW 14.1.1.

Everything worked fine before. On a fresh boot into atmos, games will work just fine on my SD card. I'll launch Tinfoil, no problems.

I'll go to install an NSP, and no matter which one, it'll get to 100% and then throw an error saying "Failed to commit to content records".

This will create a spinning black icon for the "installed" game. I can remove this by going into the Switch data management settings, and then try twice to delete the software (the first try will throw an error).

However, all the games on the SD card are now unplayable, and will throw the generic "unable to start software" error message when trying to launch anything.

I've tried removing my "atmosphere", "bootloader" and "sept" folders and then adding the new atmos package for 1.3.1, followed by the sigpatches for 1.3.1/HOS14.1.0 (I was told they'd be exactly the same for 14.1.1). I'm launching using the newest fusee file.

So, what's the deal? Did Tinfoil get an update I don't know about? That's essentially the only link in the chain that I didn't update.
I recommend asking in the Switch Noobs Paradise.
 
  • Like
Reactions: impeeza

FirM

Well-Known Member
OP
Newcomer
Joined
Jun 20, 2019
Messages
69
Trophies
0
XP
250
Country
United States
by the way you are missing the correct sigpatches, download the latest ones.
Funny thing, I am using the most recent sigpatches (got them from ITotalJustice), they're just made for 14.1.0, not 14.1.1. But I've seen it said on here that the sigpatches didn't change for 14.1.1, so I assumed I could just use them now. Will this be resolved if I just wait for 1.3.2 atmos/sigs? Because I am on 14.1.1 OFW.
 

fluggy2003

Well-Known Member
Newcomer
Joined
Apr 17, 2015
Messages
48
Trophies
0
Age
43
XP
1,041
Country
I had same issue. Was tearing my hair out. Formatted and refilled my full 1TB micro sd 3 times as thought it was corrupted. As a last resort I switched back to previous Atmosphere and used Daybreak to revert my firmware to 14.0 and everything works perfectly again.
 

FirM

Well-Known Member
OP
Newcomer
Joined
Jun 20, 2019
Messages
69
Trophies
0
XP
250
Country
United States
Okay, strange... Where downloading TinWoo, I tried GoldLeaf after a fresh reboot, and that worked just fine. Game installed and loads, other games still work. I didn't step my OFW back, and I hadn't seen impeeza's link yet, so I'm still using ITotalJustice's sigs. Gonna try TinWoo now and see if that works also. But yeah, mayyyyybe just avoid Tinfoil for now (or forever?)
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    suslu22 @ suslu22: i opened