Thinking about updating to 4.0 from 3.2

Discussion in 'Wii - Hacking' started by Dark_anth, Jun 9, 2009.

Jun 9, 2009
  1. Dark_anth
    OP

    Banned Dark_anth Banned

    Joined:
    Aug 1, 2008
    Messages:
    243
    Country:
    United States
    ok, I have been a "fan" of 3.2 for like a year. now 4.0 looks very cool but i want no homebrew restristrictions. I allready have HBC so I dont care about twilight.
    I want to:
    -Play "backups" from disk channel
    -play backups from HDD/SD/SDHC
    -Play Wads (pirates) VC from SD
    -Keep all Homebrew functunality
    (I have softmii and cioscorp and everything from softmii)
    Would I have to uninstall all that?
    Thanks,
    Dark_anth
     


  2. tj_cool

    Supervisor tj_cool Stuff

    Joined:
    Jan 7, 2009
    Messages:
    9,942
    Location:
    This planet
    Country:
    Belgium
  3. sl33p

    Member sl33p GBAtemp Regular

    Joined:
    Dec 7, 2008
    Messages:
    191
    Country:
    United States
    I held out on upgrading for a long time but finally decided to do so last week. What got me to do it was BootMii as I backed up my Wii memory in 3.2 so if IO didn't like 4.0 I could revert back easily without having to start over.

    Long story short: I'm still on 4.0 after using the exact guide that tj_cool posted.


    If you're using preloader here's the hacks I'm currently using (USA 4.0). I got them off a thread on the board and they were not made by me. I just wish I rememebr where I got them so I could properly credit the author for his work

    [Replace Healthwarning with Backmenu]
    version=417
    offset=0x81655F04
    value=0x814092D4
    [Region free channels]
    version=417
    offset=0x8152D580,0x813B5FF4
    value=0x38000001,0x48000028
    [Skip disc update check]
    version=417
    offset=0x8137ED54,0x8137ED58
    value=0x60000000,0x60000000
    [Remove diag disc check]
    version=417
    offset=0x813793A4
    value=0x60000000
    [Disc auto start when right pressed]
    version=417
    offset=0x8137A770
    value=0x2C000002
    [Disc autostart]
    version=417
    offset=0x8137A758
    value=0x48000020
    [Remove NoCopy Protection]
    version=417
    offset=0x8134E1E0
    value=0x7C000000
    offset=0x8134E1F0,0x8134E1F4,0x8134E1F8,0x8134E1FC
    value=0x801C0024,0x5400003C,0x901C0024,0x48000018
    offset=0x81353DF8
    value=0x3BE00000
    offset=0x813C4C88,0x813C4C8C
    value=0x7C000000,0x4182001C
    offset=0x815C1B48
    value=0x38600001
    [Region free channels from SD]
    version=417
    offset=0x81530544
    value=0x4E800020
    [Region free Wii games]
    version=417
    offset=0x8137D378
    value=0x38000001
    offset=0x8137D63C
    value=0x38000001
    offset=0x8137F40C
    value=0x38600001
    [Force Disc Region]
    version=417
    offset=0x8137D65C
    value=0x4800001C
    offset=0x8137D680
    value=0x60000000
    [Move Disc Channel]
    version=417
    offset=0x813AF388
    value=0x60000000
    [No menu BGM]
    version=417
    offset=0x8136Acc8
    value=0x4E800020
     
  4. olliepop2000

    Member olliepop2000 GBAtemp Fan

    Joined:
    Apr 4, 2009
    Messages:
    457
    Location:
    North West UK
    Country:
    United Kingdom
    If I were you, I would install a patched IOS60 whilst still on 3.2 as it is not required by Systemmenu 3.2 so at least you know the required Systemmenu 4.0 IOS is already there, use Waninkoko Firmware Upgrader get to 4.0, it will skip IOS 60 as it is already done. If possible get a Bootmii NAND dump before doing anything though. If you then decide to install Preloader 0.29 you shouldn't get the 'System files are corrupt' message. Good luck.

    Edit: Preloader hacks
     
  5. Dark_anth
    OP

    Banned Dark_anth Banned

    Joined:
    Aug 1, 2008
    Messages:
    243
    Country:
    United States
    Another question, if I have softmii and want Bootmii, how do I get it? do i have to delete it? if so, how?
     
  6. Dark_anth
    OP

    Banned Dark_anth Banned

    Joined:
    Aug 1, 2008
    Messages:
    243
    Country:
    United States
  7. tj_cool

    Supervisor tj_cool Stuff

    Joined:
    Jan 7, 2009
    Messages:
    9,942
    Location:
    This planet
    Country:
    Belgium
  8. skawo96

    Member skawo96 GBAtemp Advanced Maniac

    Joined:
    May 22, 2008
    Messages:
    1,925
    Country:
    United Kingdom
    I also have a question regarding 4.0 and since there's a topic like this I'll use it [​IMG]

    So, anyway, is there a way to get Trucha Signed Discs working on 4.0? I tried the IOS Downgrader 1.0, but nope.
     
  9. s3phir0th115

    Member s3phir0th115 GBAtemp Advanced Fan

    Joined:
    Dec 31, 2008
    Messages:
    700
    Country:
    United States
    I believe that without a modchip, you require cIOScorp for this.
     
  10. skawo96

    Member skawo96 GBAtemp Advanced Maniac

    Joined:
    May 22, 2008
    Messages:
    1,925
    Country:
    United Kingdom
    I do have a modchip.

    Oh, and I mean, enable Trucha Discs through Disc Channel, I know that I can boot them thru GeckoOS
     
  11. s3phir0th115

    Member s3phir0th115 GBAtemp Advanced Fan

    Joined:
    Dec 31, 2008
    Messages:
    700
    Country:
    United States
    Oh. I believe all that requires is that you trucha patch all of your IOS's. IOS downgrader wouldn't do that for you because newer IOS's like IOS60 which system menu 4.0 runs on never had an official trucha vulnerable version. The solution is to patch the trucha vulnerability in yourself.

    I would like to say you can get the IOS60 wad with NUSD and then use wwpatcher with freethebug and patch it in, but when I do that with IOS61 the shop channel, which uses IOS61, does not work.

    I do believe there is a program on wiibrew that will download and patch IOS60 for you, and also the shop channel. I forget what it's called though.
     
  12. skawo96

    Member skawo96 GBAtemp Advanced Maniac

    Joined:
    May 22, 2008
    Messages:
    1,925
    Country:
    United Kingdom
    I believe icefire's updater does that. Same does the Shop and IOS60 installer. I tried both of them.
     
  13. s3phir0th115

    Member s3phir0th115 GBAtemp Advanced Fan

    Joined:
    Dec 31, 2008
    Messages:
    700
    Country:
    United States
    That's probably the ticket for you then. Try one of those out, then install system menu 4.0 and see if that works for you.
     
  14. skawo96

    Member skawo96 GBAtemp Advanced Maniac

    Joined:
    May 22, 2008
    Messages:
    1,925
    Country:
    United Kingdom
    [​IMG] Read it again?
     
  15. mikeyt1998

    Member mikeyt1998 YouTube Glitcher

    Joined:
    Aug 11, 2007
    Messages:
    1,359
    Location:
    Dalton-in-furness, north west
    Country:
    United Kingdom
    my god, if you have IOS249 installed then you should be able to IOS downgrade your wii. mine did it fine, but i didnt even need to coz i installed cIOSCORP anyways lol

    and since all of the IOS used in cIOSCORP are trucha bugged thats like using IOS Downgrader.

    the issue you have with IOS Downgrader is that it doesnt downgrade IOS60 (the system menu operator), so you just use preloader 0.29 or install cIOS60BF.wad from cIOSCORP lol.


    and in answer to the main question... yes, you should upgrade to 4.0, it's way better and easy lol

    here's what i do on everyones wii that they give me...

    install cIOS_rev7.wad,
    update it to cIOS_rev9,
    update through nintendo,
    install cIOSCORP,
    install preloader 0.29,
    install wiigator MIOS Xi.

    and thats it, full game channel gameplay, HDD loader compatibility, unofficial channels from SD Menu, full homebrew functionallity... simplest way IMO [​IMG]

    of course, my way wont work when update 4.1 or whatever comes out because it'll probably stop things working. but in that case i'd install IOS60 then just do this lot but use cIOS Downgrader 1.11 to upgrade the wii to 4.0 lol [​IMG]
     
  16. skawo96

    Member skawo96 GBAtemp Advanced Maniac

    Joined:
    May 22, 2008
    Messages:
    1,925
    Country:
    United Kingdom
    Dude, but, did you read the things I posted later? I tried installing trucha-bugged IOS versions many times, and it didn't work. Icefire's updater patches every IOS with bug.
     
  17. mikeyt1998

    Member mikeyt1998 YouTube Glitcher

    Joined:
    Aug 11, 2007
    Messages:
    1,359
    Location:
    Dalton-in-furness, north west
    Country:
    United Kingdom
    :S strange, i apologise [​IMG]

    wonder why it never worked for you...

    least you got it sorted now [​IMG]

    how were u tryin to install the trucha bugged IOS'?
     
  18. skawo96

    Member skawo96 GBAtemp Advanced Maniac

    Joined:
    May 22, 2008
    Messages:
    1,925
    Country:
    United Kingdom
    Icefire's updater
    Shop/Mii/IOS60/61 Installer
    http://gbatemp.net/index.php?showtopic=144835 - wads created by this offline option.

    They all claim to patch trucha bug back into IOSes...]



    I'm back on 3.2 with BootMii, so open for suggestions.
     
  19. mikeyt1998

    Member mikeyt1998 YouTube Glitcher

    Joined:
    Aug 11, 2007
    Messages:
    1,359
    Location:
    Dalton-in-furness, north west
    Country:
    United Kingdom
    do you have an internet connection?

    if you do and have cIOS installed then there should be no issue with updating the wii then downgrading the IOS' as far as i know...

    works for me everytime lol

    or again, if you have an internet connection, try waninkoko's 4.0 updater, updates with trucha bug in tact.



    if you DONT have an internet connection, you could try manually installing each trucha bugged IOS using wad manager 1.4 and choosing IOS249 to install them [​IMG]

    but i think other wad managers use 249 as default so you dont need to worry about that lol


    and if i'm completely talking crap about something you never asked just say and i'll just go XD
     
  20. skawo96

    Member skawo96 GBAtemp Advanced Maniac

    Joined:
    May 22, 2008
    Messages:
    1,925
    Country:
    United Kingdom
    I guess I'll just update and forget about trucha...but that makes me feel kinda... [​IMG]
     

Share This Page