System froze, now it won't charge or turn back on

Discussion in 'Switch - Console, Accessories & Hardware' started by Dothackjhe, Aug 19, 2018.

  1. Dothackjhe
    OP

    Dothackjhe GBAtemp Fan

    Member
    3
    Dec 29, 2013
    Philippines
    Philippines
    I just recently got my first Switch last month when I bought it online out of whim. It's from a legitimate local e-Commerce platform and it's brand new. Everything was okay about the device at first after initializing its settings for first-time usage. From the get-go, it's a perfectly working device as far as first impression goes.

    Some weeks later, I decided to jailbreak the system by going for a ReiNX hack. Things were starting off just fine for a while which led me to almost fill a Sandisk Ultra 128Gb micro-SDXC card with backup ROMs. During that time, I was able to boot and reboot the system a number of times as any normally-functioning device would. I was also able to test out a few games on it until my most recent session very early in the morning today (around 1 to 2 AM) when it suddenly froze after trying to boot a third game.

    Intuitively, I forced close the unit so as to reset it, but only to not have it boot again or even charge it.

    I tried a handful of solutions I could find in the internet such as holding the power button down for at least 30 seconds, then pressing the power button again, or accessing the device's "maintenance mode" to make it go live again; but to no avail.

    Despite being an almost a month in my ownership, I barely touched the device as I initially did not have any game in it. It's only when I realized that the console is jailbreakable that I literally started playing it. Worst, this is only my second session of play with it after getting quite hooked with The Legend of Zelda: Breath of the Wild and now it's not working.

    Finding for a means to resolve the problem, I had been scouring the internet for answers related to the issue and came across problems that are inherent to the device. I'm really astounded to realize how faulty the system is inherently at its current state after experiencing this issue. One YouTuber even claimed that the chip that Nintendo used to control the power system of the device is inferior in comparison to Sony hardware.

    If these factors are any relevant, I have the following conditions during the aforementioned play session before the issue arose:
    • The unit was running while being charged using the Switch's stock charger.
    • The device's battery charge is nearing or already full by the time the issue came about.
    • I was using the system in handheld mode.
    • I was, at the time, switching between games just to check them out (in chronological order: The Legend of Zelda: Breath of the Wild, Splatoon 2, and Xenoblade Chronicles 2).
    • The system froze at the splash screen as soon as I ran Xenoblade Chronicles 2
    • I did not use anything third-party-related accessory for the device except for the analog caps which cover the analog sticks and the case which enclosed the back part of the Switch. Neither of the two is electrical by nature so as to cause a brick.
    Anybody else experienced the same thing? How were you able to fix it?
     
    Last edited by Dothackjhe, Aug 19, 2018
  2. Dothackjhe
    OP

    Dothackjhe GBAtemp Fan

    Member
    3
    Dec 29, 2013
    Philippines
    Philippines
    I finally managed to make it work again!!!

    The idea just came off randomly: I simply checked whether or not the system is still in RCM Mode and, apparently, it is!

    I was able to boot the system again after injecting ReiNX payload!
     
  3. Andalitez

    Andalitez GBAtemp Fan

    Member
    4
    Jul 2, 2018
    France
    Final Space
    so instead of typing this long well thought out post,you should have taken a 5 minute break and tried to inject the payload again...xD
     
  4. Dothackjhe
    OP

    Dothackjhe GBAtemp Fan

    Member
    3
    Dec 29, 2013
    Philippines
    Philippines
    Lolz. Yeah, the irony.
     
  5. altorn

    altorn GBAtemp Advanced Fan

    Member
    4
    Jul 15, 2007
    Canada
    Toronto, Ontario
    we need a troubleshooting sticky. way too many repetitive posts about "switch not charging / freezing / not booting".
     
  6. Dothackjhe
    OP

    Dothackjhe GBAtemp Fan

    Member
    3
    Dec 29, 2013
    Philippines
    Philippines
    I agree. I would have realized the solution sooner if there was such a thread.
     
  7. noizap

    noizap Member

    Newcomer
    3
    Oct 29, 2009
    Philippines
    Philippines Manila
    you answer your question so quick Dothackjhe. Im pretty impressed of how long you write it. :) cool
     
  8. Dothackjhe
    OP

    Dothackjhe GBAtemp Fan

    Member
    3
    Dec 29, 2013
    Philippines
    Philippines
    Looking at the time difference between posts, you would know that it took several hours before I figured out myself on how to fix the issue.
     
  9. noizap

    noizap Member

    Newcomer
    3
    Oct 29, 2009
    Philippines
    Philippines Manila
    yeah, atleast you figure it out. :) congrats Kabayan
     
    Dothackjhe likes this.
Loading...