Hacking Discussion SX OS - Error and Solutions Thread

Have you checked that your SD card Isn't Fake

  • Yes

    Votes: 195 76.2%
  • No

    Votes: 48 18.8%
  • Will verify soon

    Votes: 13 5.1%

  • Total voters
    256

Timtacle

Member
Newcomer
Joined
Aug 19, 2019
Messages
16
Trophies
0
Age
34
XP
125
Country
France
Hi!

So I'm having an issue.
I was playing, and then I got that same error message.

So I pushed Power but nothing happened. I can't even boot on OFW and the console doesn't seem to boot at all.

So I tried to inject the payload from TegraRCM on my laptop. TegraRCM recognized my Switch and I can switch between RCM ON/OFF.

But when I inject the payload, nothing happens. I tried everything... Nothing seems to work. I'm quite desperate here. Do anyone knows what's going on?
 

soppok2k

Member
Newcomer
Joined
Apr 24, 2020
Messages
6
Trophies
0
Age
33
XP
30
Country
United States
Hello there,

I am runnung SX OS Emu Nand 2.9.2 and I upgraded with the recommended method by team Xecutor (I followed all steps 1:1) which provided me with the firmware V 9.0.1 - worked like charm. This time I repeated this method to upgrade to V 9.2.0 and got stuck.
All worked well, the firmware updated properly and the switch shuted down after 30 sec, and went into an black screen.

I rebooted the consol, and it loads usualy into the original system. But as soon as I want to boot into SX OS and I activate the payload, I get the SX OS screen and after that a black screen.

Is there any way to fix that?

Cheers
 

Justerino

Well-Known Member
Member
Joined
Nov 19, 2019
Messages
130
Trophies
0
Age
29
XP
270
Country
United States
Hi again,

I had changed my password today for security reasons and on my switch after getting the latest SX OS update, I have to re enter my password but when i do it the system crashed and gives ms a 2162-0002 error code.

Is there any way I can link my nintendo account back onto my console?
 

soppok2k

Member
Newcomer
Joined
Apr 24, 2020
Messages
6
Trophies
0
Age
33
XP
30
Country
United States
Hello there,

I am runnung SX OS Emu Nand 2.9.2 and I upgraded with the recommended method by team Xecutor (I followed all steps 1:1) which provided me with the firmware V 9.0.1 - worked like charm. This time I repeated this method to upgrade to V 9.2.0 and got stuck.
All worked well, the firmware updated properly and the switch shuted down after 30 sec, and went into an black screen.

I rebooted the consol, and it loads usualy into the original system. But as soon as I want to boot into SX OS and I activate the payload, I get the SX OS screen and after that a black screen.

Is there any way to fix that?

Cheers

I had to upgrade to SX OS 2.9.4 sorry, but it might help anyone other get stuck with the same issue.
 

wings516

Member
Newcomer
Joined
Mar 23, 2020
Messages
14
Trophies
0
Age
34
XP
41
Country
United States
Its now been updated

Looks like the 2.9.5 update is working. For those having issues with local play on certain games, you must download the ldm_mitm.nro and

Disable
-Local wireless play
-Stealth mode
-FTP

Once you do this, go back into the ldm nro and confirm it is off (should show error). Local play should work just fine now!
This was tested on a 10.0.1 Legit switch and an SX OS emunand and sysnand 9.1.0 switch running AC:NH 12.0.0
 
Last edited by wings516,
  • Like
Reactions: shanefromoz

victorv75

New Member
Newbie
Joined
May 28, 2020
Messages
1
Trophies
0
Age
47
XP
26
Country
United Kingdom
looking for ideas / help here chaps, anything to try appreciated.

I'm fairly comfortable updating to new versions of SX OS and now and again using homebrew app to update firmware offline - I've updated to 9.2 and 2.9.4 recently no bother - tried 2.95 and black screen when I try to boot, also black screen trying to boot to SX OS menu - switch back to 2.9.4 all works fine. tried various version of 2.9.5 boot.dat using same micros SD card, same result.

Anything obvious I am missing ?

- is beta 2.9.5 buggy enough that it'll just not work at all sometimes (I've no customer themes or any apps other than ChoiDujourNX and only other files on card are games (XCI files).)
 

sorabora

Well-Known Member
Member
Joined
Dec 8, 2016
Messages
356
Trophies
0
XP
1,128
Country
United States
looking for ideas / help here chaps, anything to try appreciated.

I'm fairly comfortable updating to new versions of SX OS and now and again using homebrew app to update firmware offline - I've updated to 9.2 and 2.9.4 recently no bother - tried 2.95 and black screen when I try to boot, also black screen trying to boot to SX OS menu - switch back to 2.9.4 all works fine. tried various version of 2.9.5 boot.dat using same micros SD card, same result.

Anything obvious I am missing ?

- is beta 2.9.5 buggy enough that it'll just not work at all sometimes (I've no customer themes or any apps other than ChoiDujourNX and only other files on card are games (XCI files).)

Any themes or other various homebrews sitting in sxos/titles? On more than one occasion, an sxos update would make my switch fail to boot. Cleaning out the aforementioned folder fixed it, both times, right away.
 

Daimakaimura

Well-Known Member
Member
Joined
Apr 9, 2007
Messages
197
Trophies
0
XP
591
Country
Belgium
I'm running OFW 2.0.0
SD card Samsung Evo 256 (or 128)

-details of error; i get constant black or blue screen when i put my license file on sd card.
when i delete it I can get past the blue screen, on get into the SX options setting.
but never can i get the CFW to boot. i'm on 3.0.0 beta and also tried 2.9.2 , none work.

i have the feeling the dongle is faulty, or correpted license file, time and time again.
tried formatting like 3 times already
 

KrispChicknStrip

New Member
Newbie
Joined
Aug 7, 2020
Messages
1
Trophies
0
Age
22
XP
22
Country
Canada
I'm new to the modded switch life and I'm trying to use hbg shop and other nro files such as Checkpoint and ChoiDujourNX but cant seem to get anything to pop up in the homebrew tab, the files are in the "switch" (all lowercase) folder which is in the root of the SD card where they should be but can't seem to get it to work.

SD card - SanDisk Ultra 128GB
Switch - 9.2.0
SX OX - Latest version according to the updater on it

I haven't tried games or anything else cause I wanted to use Tinfoil directly on the switch to install them but I'm stumped..
 

W0rmy

Member
Newcomer
Joined
Sep 24, 2020
Messages
24
Trophies
0
Age
52
XP
109
Country
Ireland
Assume you have extracted them? (i.e. they are nro files?)

Just wondering if someone can confirm about SX Autoloader - using the latest 1.40 on the latest 3.1.0 Beta and 11.0 firmware crashes it on mine - I've read reports of it working - any one confirm?
 

JoseUg

Member
Newcomer
Joined
Oct 2, 2015
Messages
18
Trophies
0
Age
28
XP
91
Country
Mexico
Hi, im trying to use SXOS with the HDD support, but it does not recognize the games, they are XCI files, and i have tried using with subfolder and into the root of the hdd, the hdd is exfat, i dont know what else to do, can someone help me please?

EDIT:
So i resolve my issue, in case any one is having the same issue as me, what i did is i used another HDD Toshiba 1tb usb 3.0, i delete the partition with windows disk admin, then i give the format of exfat, slow option, after that, the hdd shows as primary partition, so i upload the games and it worked, right now im testing with the other hdd that i had problems and i will post the resolution.
 
Last edited by JoseUg,

mrdude

Well-Known Member
Member
Joined
Dec 11, 2015
Messages
1,550
Trophies
1
Age
54
XP
4,325
Country
Put the folders SXOS/XCI in the root of the sd card - then put the xci in the xci folder. Also your switch firmware/emunand must have the exfat firmware installed to support exfat.
 
  • Like
Reactions: JoseUg

robot_bikram

New Member
Newbie
Joined
Apr 9, 2021
Messages
3
Trophies
0
Age
32
XP
13
Country
India
Is it safe to update after install SX LITE on Nintendo Switch Lite through WIFI??

Coz I've done update through WIFI...actually i brought brand new Nintendo Switch Lite n SX LITE then install SX LITE.
Everything was perfect i put boot.dat on root of my new Memory card then i insert in memory card slot and turn on then SX boot logo shows up after that there is 3 option.
I clicked on CFW option then screen goes black n eject memory card instantly then Nintendo start up , I finished up initial setup like date time ,internet etc. because that was the 1st time I was going turn on my Nintendo..
again inserted memory card without turn off but there was a message pups up "A system update is required to use the microSDXC memory card" then I updated Nintendo after that screen goes black.
I tried to turn off Nintendo it was then press power button again. There was SX Option shows up i clicked on in every option screen goes black so have I done great mistake??
 
General chit-chat
Help Users
    DEMONGreninjaPG @ DEMONGreninjaPG: i feel like shit