SX OS 1.9 Freeze When Turning On FTP Server

Discussion in 'Switch - Backup Loaders & Modchips' started by mranonymous, Sep 8, 2018.

  1. mranonymous
    OP

    mranonymous GBAtemp Regular

    Member
    4
    Jul 22, 2018
    United States
    Hello,

    I have been using the FTP feature with 1.9 a lot lately, and it has been working flawlessly.

    Just a few minutes ago, I went to enable the FTP Server in Options, and the system froze. Not a huge deal, I just needed to do a hard power off and boot it back up. I tried again and it worked fine.

    I just wanted to share this in case anyone else has experienced the same issue. And also - does anyone know what can cause this? Thanks
     
  2. Albytrozz

    Albytrozz GBAtemp Regular

    Member
    4
    Jun 10, 2018
    United States
    To be honest the FTP feature has never worked for me since it was introduced. Someone said it could have been because I was using FileZilla and to try WinSCP but both cause the system to black screen with the 12 second shutdown message. Happens with both apps on every version even after they claimed to have improved FTP on 1.9.

    That said it's not a huge deal to take the card out to add stuff or upgrade SX OS.
     
    mranonymous likes this.
  3. json

    json MUSCLEMAN

    Member
    9
    Aug 9, 2013
    Burkina Faso
    What FW version are you on?

    EDIT: Also should you find out how to reproduce this you should let TX know so they can fix it
     
    Last edited by json, Sep 8, 2018
    mranonymous likes this.
  4. aleexz

    aleexz Member

    Newcomer
    2
    Jul 8, 2018
    Spain
    It worked for me flawlessly yesterday with Filezilla but I read about some people having the same issue as you.
     
    mranonymous likes this.
  5. mranonymous
    OP

    mranonymous GBAtemp Regular

    Member
    4
    Jul 22, 2018
    United States
    Yeah I was a bit skeptical to use it at first because I'd heard similar things. I decided to give it a go once I upgraded to 1.9, because I figured they'd probably improved it some when they made it faster. It worked really well with Filezilla for me until the crash. Overall though it's still relatively solid IMO, as I've probably used it around 20 times and it only crashed the one time. I just hope that the crash issue is addressed in future updates.

    I'm on FW 5.1.0. And yeah good idea. I can't recall doing anything out of the ordinary when it happened, but I may have had Filezilla open from the previous session. So I wonder if it tried to automatically connect or something, causing a freeze. I'll test that out to see if it's the issue.

    Ah, good to hear that it's more than just me experiencing the issue. I'm sure they will get it ironed out if enough people let them know. I'll contact them via their website form to let them know about it.
     
Loading...