Hardware Switch stuck on black screen. Likely due to right joy con?

dkts

New Member
OP
Newbie
Joined
May 26, 2021
Messages
1
Trophies
0
Age
23
XP
9
Country
Netherlands
Hi!

This is a bit of a weird issue (to me) so stick with me while I try to explain it.

Some information
- My console has auto RCM active
- Console has been working fine, until it rather suddenly didn't.
- I did flash android onto my SD card, where I had to do a joy con FW dump. This was around the time these issues started, so maybe it is related? Something wrong happened during the dump?
- I have tried flashing fusee-test and lockpick as well, in case the issue was Hekate related.

The history
Just a few days ago I discovered, while playing, that the right joy con wasn't properly connecting to the switch. They were both attached physically, and both were getting charged, but the right one counted as wireless. Out of nowhere (after 30 minutes or something) the switch suddenly made the iconic snap sound and both joy cons counted as connected.

This worked fine until I had to power off the console.

When I tried to power the console back on and inject hekate: Nothing happened. Well, it looked like it worked as the injector showed no errors and clearly found the switch in RCM mode.
But that's it. "Successfully" injected hekate but the screen remained black.

I quickly jumped to the conclusion that the right joy con issue and the black screen issue were connected, so I tried various things such as:
- Disconnect both joy cons and start console
- Clean the joy con pins

But to no avail. Nothing happened.

I gave up and googled this issue, but I didn't find anything that seemed to directly correspond to my specific issues. In the meantime I left the switch in the official dock.

A while later, hours maybe, I decided to try injecting again. And lo and behold: it worked! I successfully booted into CFW, and then successfully rebooted into Android. This was great news, maybe it just needed some extra charge?! But alas, nothing lasts forever and after rebooting again to enter CFW the feared black screen was back with the exact same symptoms as before.

I left the switch in the dock overnight, and today it successfully booted back into CFW. The right joy con was recognized as wireless again, though.
I also now couldn't start any games.

Error: Could not start the software. Please try again from the HOME Menu.

Since I couldn't play I decided to power off and boot into stock to see if I had any issues there. The right joy con was still wireless, but after a minute or two it connected properly, and I rebooted it again to get into CFW.

Now I seem to be stuck on a black screen in RCM. The console seems to respond to injections, but then locks up or stops working after that.
There is no output on the screen during these issues at all.


So, the question is...
Is this a known problem? A specific chip or anything that has gone bad? Anything joy con related shorting, maybe?

Something going wrong with the CFW which corrupts the Switch for a while?!

What should I do to figure out the culprit?

And if it's indeed a hardware issue: Are there anyone reputable in Europe who'd be willing to take a look and try a repair, for a price of course?


Thank you to anyone who actually read this wall of text.

TL;DR Right joy con (either the joy con itself or the right rails) was acting funny. Suddenly Switch remains on a black RCM screen, also after injecting. But: Sometimes injecting suddenly works.


Update 1
I've experimented a bit, and I'm confused so I really hope someone more knowledgeable can clear things up a bit.
But: It seems like all games (among other things Tinfoil) has gotten corrupted somehow. I reinstalled Tinfoil and now tinfoil starts with the error. I'll try wiping my SD card and redoing everything.
While I don't see how this could SD card corruption could lead to fusee-test not loading; it's definitely a thing to test!

Update 2
Successfully injected fusee-test now, after ~20 times of trying over - and over -and over.
It honestly seems completely random if it works or not...
 
Last edited by dkts,
General chit-chat
Help Users
    ChrisOwl @ ChrisOwl: Anyone knows something about this error on switch ? "Wrong PKG1 Flashed! Erista pkg1 on Mariko"