Switch OLED teardown V1/V2

malgamer

Member
Newcomer
Joined
May 8, 2022
Messages
6
Trophies
0
Age
44
Location
malaysia
XP
18
Country
Malaysia
New OLED specific chip from AliExpress installed successfully. Not recommended for quick and easy installs. The flex PCB for the CPU bends too much, puts a bit of pressure on the CPU resistors in my opinion, but it's strong enough to hold, I'm not worried. The flex PCB up top is just garbage...takes ALOT of time to get it right, I even cut off part of it and manually wired 3.3v and ground.

TLDR: This new OLED model is poorly designed, but works. Be prepared to put in extra time to install it properly.

Hopefully this helps you out if you get this revision :)
hi , how your modded oled ? i 'm facing a problem boot to hekate everytime i off my oled. everytime i on my oled it automatic boot to ofw directly and need restart few time to enter hekate. how bout yours?
 

Ichigo1990

Member
Newcomer
Joined
Feb 8, 2019
Messages
19
Trophies
0
Age
32
XP
58
Country
Indonesia
ask
help
switch oled hwfly
after apply tema and reboot not boot

blink cyan after that red solid and gone
no boot hekate menu
i try 10 time not work/not boot
 

OrganixXx

Member
Newcomer
Joined
Jan 6, 2019
Messages
13
Trophies
0
Age
37
XP
211
Country
Germany
Saturday Done 😎
 

Attachments

  • IMG_20220515_110454.jpg
    IMG_20220515_110454.jpg
    1.8 MB · Views: 16
  • Like
Reactions: kerelenko

irvingoh999

Member
Newcomer
Joined
Oct 10, 2021
Messages
9
Trophies
0
Age
22
XP
102
Country
Singapore
I haven't done it, but what happens if you ground out the D (CLK?) Point from scraping away too much at it?
Hi, so I was installing an oled v3 chip (locked chip) and then this happened, the cpu shield touched the clk point. Now I can't boot ofw at all, black screen. Any suggestions? Thanks!
 

kerelenko

Well-Known Member
Member
Joined
Jun 25, 2018
Messages
359
Trophies
0
XP
1,326
Country
Canada
ask
help
switch oled hwfly
after apply tema and reboot not boot

blink cyan after that red solid and gone
no boot hekate menu
i try 10 time not work/not boot
Sthetix posted a new video explaining and showing the solution to this issue. Mainly, this issue is caused by the DAT0 adapter only connecting to the DAT0 point via friction. Reflowing the EMMC and anchoring the DAT0 adapter solves the issue. I also experience this on my OLED and the way I make sure it boots again is to force it to shut down and wait for 24hrs before turning it on again.

 
  • Like
  • Love
Reactions: impeeza and peteruk

gokuz

Well-Known Member
Member
Joined
Jun 13, 2014
Messages
125
Trophies
0
XP
426
Country
Senegal
Sthetix posted a new video explaining and showing the solution to this issue. Mainly, this issue is caused by the DAT0 adapter only connecting to the DAT0 point via friction. Reflowing the EMMC and anchoring the DAT0 adapter solves the issue. I also experience this on my OLED and the way I make sure it boots again is to force it to shut down and wait for 24hrs before turning it on again.


I disagree with this method, solder balls might touch if you're not careful. Better be safe than sorry.

To secure it, just add UV mask around the sides of the whole dat0 adapter.
 
  • Like
Reactions: impeeza
General chit-chat
Help Users
  • No one is chatting at the moment.
    KenniesNewName @ KenniesNewName: You've only seen a small percent of the worst of it