Switch not charging (recently)

White_Raven_X

Hack everything, hack the world!
OP
Member
Joined
Sep 23, 2019
Messages
464
Trophies
0
Age
42
XP
809
Country
United States
Just recently my switch doesn't charge. Nothing.... It was working fine for years. You guys think it's the charging ic? Never had this happen on any of the switches I've had (6). How does this even happen...wtf...

*Update*
Seems like I had an issue with my trinket wiring... The 3v or the usb strap... I removed and resoldered and it's charging again.

Very strange.
 

Attachments

  • IMG_20211018_193836__01.jpg
    IMG_20211018_193836__01.jpg
    773.4 KB · Views: 7
Last edited by White_Raven_X,
  • Like
Reactions: bazamuffin

thesjaakspoiler

Well-Known Member
Member
Joined
Nov 20, 2018
Messages
470
Trophies
0
Age
121
XP
621
Country
Afghanistan
It could also be a USB-C connector not making proper contact or oxidation/dirt on the pins.
I guess some visual inspection is needed.
 

White_Raven_X

Hack everything, hack the world!
OP
Member
Joined
Sep 23, 2019
Messages
464
Trophies
0
Age
42
XP
809
Country
United States
Ok so I completely removed and reinstalled a new trinket m0 and all the wires and still draining better very quickly. Like 10% battery in 1 hour in sleep. Is there possibly a blown component? Like resistor or something that I soldered to for the trinket?

This is my 4th unit installing a trinket and first time having a parasitic drain like this.
 

White_Raven_X

Hack everything, hack the world!
OP
Member
Joined
Sep 23, 2019
Messages
464
Trophies
0
Age
42
XP
809
Country
United States
Strangely enough the 3v on my trinket gives me a reading of 0.5ohms to ground ... This doesn't seem right...it's like a direct short to ground... Is this right?
 

White_Raven_X

Hack everything, hack the world!
OP
Member
Joined
Sep 23, 2019
Messages
464
Trophies
0
Age
42
XP
809
Country
United States
So it's not my trinket that is the problem. I had noticed about two weeks ago that the charge wasn't keeping as well as it used to before I had started to use an unofficial charger. Ever since then, my switch wasn't the same... That's when I started to investigate and it appears that my switch has suffered damage to the charger IC or the display chip just behind it. I will be replacing them one at a time and documenting my finds here.
 
General chit-chat
Help Users
    The Real Jdbye @ The Real Jdbye: and stab it in the head while you're at it