Hacking SWITCH NOOB PARADISE - Ask questions here

kuok3

Member
Newcomer
Joined
Nov 24, 2021
Messages
9
Trophies
0
Location
New York
XP
33
Country
United States
Hi, so not too long ago my hacked switch v1 was banned and I'm trying to deduce what got me banned just so it won't happen again.

I originally planned on using it as a pkhex device to transfer gen'd Pokemon. So I prepared my switch, updated both CFW and stock FW to 13.1. I played ACNH until Pokemon BDSP came out, and I was fairly new to save editing using NHSE.

I only gave myself bells/nook miles/all DIY's added some of the new items from the update (gaming chair and stuff) modified some villagers (I'm pretty certain I did this correctly.)

And I tried editing the tiles on my Island and I think this is what got me banned but I'm still unsure. I added stone tiles to the floor via NHSE and upon inspection in-game they looked as if they weren't connected and on top of this I couldn't paint over or remove it using the in-game tools. Could this really be the reason why I got banned? Is there a guideline of what bans and what doesn't on ACNH? I'm buying a new hackable switch and would like to not make the same mistakes.

I'm also hesitant on transferring my island from my hacked switch to my switch lite but I'd like more information or confirmation that I wouldn't get banned even if my island being edited got me banned to begin with.

Thanks
 
  • Like
Reactions: GerbilSwimmingPool

BigOnYa

A Very-Large Member
Member
Joined
Jan 11, 2021
Messages
1,422
Trophies
1
Age
48
XP
2,930
Country
United States
No problem :)
I did run into another issue. Since I formatted my card I lost the few games I had on it in NSP format. I tried to reinstall them on my switch using Goldleaf and now I am getting an error screen. Error -An error has ocurred attempting to install the NSP. Error-2002-4518 (0x234C02) Module:File system (2). Description: Invalid NCA (might mean missing sigpatches or a too low firmware) (4518). I am using firmware 13.1.0 on the switch and most recent Atmosphere. I have tried downloading the NSP from 2 different sources with same error message. I tried to reinstall Tinfoil to see if I had the same issue, however, I get Tinfoil to install properly, I figured it was a compatability issue, so I tried Tinwoo, but get the same error screen. Do I need a sigpatch of some sort?
You need sigpatches... If you don't know which to use, then just use both sets of:
https://github.com/ITotalJustice/patches/releases
 
  • Like
Reactions: GerbilSwimmingPool

GerbilSwimmingPool

Well-Known Member
Member
Joined
Mar 7, 2018
Messages
115
Trophies
0
XP
260
Country
United States
I'm trying to update my CFW to play Diamond and Pearl even though I do not know which system update is required. Is the following correct?

-Download sd/atmopshere
-Download new version atmosphere/atmosphere-1.2.4-master-e256261b8+hbl-2.4.1+hbmenu-3.5.0.zip?
-Download and merge Hekate/hekate_ctcaer_5.6.5_Nyx_1.1.1.zip
-Then try to play the games?

Questions:
-Do I have to ground pin 10 again during this process to setup the auto launch of AutoRCM?
-Can I NOT update my firmware at this moment?

Current EmuMMC version: 11.0.1|AMS M.18.1|E
 
Last edited by GerbilSwimmingPool,

Draxzelex

Well-Known Member
Member
Joined
Aug 6, 2017
Messages
17,824
Trophies
1
Age
27
Location
New York City
XP
11,798
Country
United States
I'm trying to update my CFW to play Diamond and Pearl even though I do not know which system update is required. Is the following correct?

-Download sd/atmopshere
-Download new version atmosphere/atmosphere-1.2.4-master-e256261b8+hbl-2.4.1+hbmenu-3.5.0.zip?
-Download and merge Hekate/hekate_ctcaer_5.6.5_Nyx_1.1.1.zip
-Then try to play the games?

Questions:
-Do I have to ground pin 10 again during this process to setup the auto launch of AutoRCM?
-Can I NOT update my firmware at this moment?

Current EmuMMC version: 11.0.1|AMS M.18.1|E
I would recommend deleting any old Atmosphere/CFW files and folders before putting the new Atmopshere/CFW files & folders on your SD card. Hekate is meant to be merged so you don't have to change that step.

If you are updating your firmware online and without CFW, AutoRCM will be removed so you will need to manually re-enable AutoRCM if that is the case. However you do not need to update your firmware just because you are updating your CFW. Remember that CFW is meant to be compatible with all available firmware versions. Updates to CFW add support for newer firmware versions. Pokemon BD/SP should work on firmware 11.0.1
 
  • Like
Reactions: GerbilSwimmingPool

GerbilSwimmingPool

Well-Known Member
Member
Joined
Mar 7, 2018
Messages
115
Trophies
0
XP
260
Country
United States
I would recommend deleting any old Atmosphere/CFW files and folders before putting the new Atmopshere/CFW files & folders on your SD card. Hekate is meant to be merged so you don't have to change that step.

If you are updating your firmware online and without CFW, AutoRCM will be removed so you will need to manually re-enable AutoRCM if that is the case. However you do not need to update your firmware just because you are updating your CFW. Remember that CFW is meant to be compatible with all available firmware versions. Updates to CFW add support for newer firmware versions. Pokemon BD/SP should work on firmware 11.0.1
I'm getting this erorr message. I'm trying to troubleshoot it. I did the following:

-Deleted the atmosphere folder
-Dropped the new version atmosphere to the root of the sd
-Merge Hekate to the root the SD card,
-Injecting hekate_ctcaer_5.6.5.bin


Error while loading Fss0
atmosphere/fusee-secondary.bin
Wrong ini cfg or missing corrupt files
failed to launch HOS/
 

Draxzelex

Well-Known Member
Member
Joined
Aug 6, 2017
Messages
17,824
Trophies
1
Age
27
Location
New York City
XP
11,798
Country
United States
I'm getting this erorr message. I'm trying to troubleshoot it. I did the following:

-Deleted the atmosphere folder
-Dropped the new version atmosphere to the root of the sd
-Merge Hekate to the root the SD card,
-Injecting hekate_ctcaer_5.6.5.bin


Error while loading Fss0
atmosphere/fusee-secondary.bin
Wrong ini cfg or missing corrupt files
failed to launch HOS/
Recently, Atmosphere changed the names of some of its components. One of them was fusee-secondary.bin; it was renamed to package3. Go into your hekate_ipl.ini file and change all instances of 'fusee-secondary.bin' to 'package3' without the quotes.
 
  • Like
Reactions: GerbilSwimmingPool

GerbilSwimmingPool

Well-Known Member
Member
Joined
Mar 7, 2018
Messages
115
Trophies
0
XP
260
Country
United States
Recently, Atmosphere changed the names of some of its components. One of them was fusee-secondary.bin; it was renamed to package3. Go into your hekate_ipl.ini file and change all instances of 'fusee-secondary.bin' to 'package3' without the quotes.
Did I do this wrong? I was able to get into the EmuMMC which it auto loaded by editing hekate_ipl.ini file to package3. When I insert BDSP into my system, it says I need to do a system update still. System version: 11.0.1|AMS 1.2.4|E

Hekate notes: My apologizes for not reading.

Notice about Atmosphere 1.0.0 and up: The fss0=atmosphere/fusee-secondary.bin in hekate_ipl.ini must be changed to fss0=atmosphere/package3. And make sure that atmosphere/contents folder does not have old Atmosphere components.
Notice about resized emuMMC: Resized emuMMC does not have the slow bug anymore. You can create a new one or recreate it via Nyx and the issue will be gone.
 

megacubanx

New Member
Newbie
Joined
Nov 24, 2021
Messages
3
Trophies
0
Age
22
XP
16
Country
United States
Question. Any way to import a save file on a Switch that has never had that game installed. Trying to import a Pokemon Let's Go and SWSH save using save tools like JKSV, Checkpoint, or Edison. Problem is that all those tools only show titles of game that have only ever been installed. Is there anyway to import just the save without having to install the games?
 

GerbilSwimmingPool

Well-Known Member
Member
Joined
Mar 7, 2018
Messages
115
Trophies
0
XP
260
Country
United States
Question. Any way to import a save file on a Switch that has never had that game installed. Trying to import a Pokemon Let's Go and SWSH save using save tools like JKSV, Checkpoint, or Edison. Problem is that all those tools only show titles of game that have only ever been installed. Is there anyway to import just the save without having to install the games?
Why not start the game and save and import over it? Is there a reason you prefer not to do it this way?
 

megacubanx

New Member
Newbie
Joined
Nov 24, 2021
Messages
3
Trophies
0
Age
22
XP
16
Country
United States
Why not start the game and save and import over it? Is there a reason you prefer not to do it this way?
Was trying to import it to my brothers Switch. Don't want to risk installing any games. When you check those save tools on his Switch, it only shows the games he has installed. He just wants those saves without buying the games.
2021112416194600-7F4AACC644EAC4BF4E5897B413FFD611.jpg
 
Last edited by megacubanx,
  • Like
Reactions: GerbilSwimmingPool

Draxzelex

Well-Known Member
Member
Joined
Aug 6, 2017
Messages
17,824
Trophies
1
Age
27
Location
New York City
XP
11,798
Country
United States
Did I do this wrong? I was able to get into the EmuMMC which it auto loaded by editing hekate_ipl.ini file to package3. When I insert BDSP into my system, it says I need to do a system update still. System version: 11.0.1|AMS 1.2.4|E

Hekate notes: My apologizes for not reading.

Notice about Atmosphere 1.0.0 and up: The fss0=atmosphere/fusee-secondary.bin in hekate_ipl.ini must be changed to fss0=atmosphere/package3. And make sure that atmosphere/contents folder does not have old Atmosphere components.
Notice about resized emuMMC: Resized emuMMC does not have the slow bug anymore. You can create a new one or recreate it via Nyx and the issue will be gone.
Can you start the game without updating?
Question. Any way to import a save file on a Switch that has never had that game installed. Trying to import a Pokemon Let's Go and SWSH save using save tools like JKSV, Checkpoint, or Edison. Problem is that all those tools only show titles of game that have only ever been installed. Is there anyway to import just the save without having to install the games?
Nope, the game has to be run at least once.
 
  • Like
Reactions: GerbilSwimmingPool

GerbilSwimmingPool

Well-Known Member
Member
Joined
Mar 7, 2018
Messages
115
Trophies
0
XP
260
Country
United States
Can you start the game without updating?
The game doesn't appear on my Switch. It says I have to update. I was looking into it and it seems like it may only require 11.0.0 is the firmware version that I have. Is there anyway to run it without updating the firmware? Tinfoil or sigpatches? I was researching it.
 

Draxzelex

Well-Known Member
Member
Joined
Aug 6, 2017
Messages
17,824
Trophies
1
Age
27
Location
New York City
XP
11,798
Country
United States
The game doesn't appear on my Switch. It says I have to update. I was looking into it and it seems like it may only require 11.0.0 is the firmware version that I have. Is there anyway to run it without updating the firmware? Tinfoil or sigpatches? I was researching it.
I don't understand. Did you install the game? You said you inserted it earlier; is it on a cartridge?
 
  • Like
Reactions: GerbilSwimmingPool

Draxzelex

Well-Known Member
Member
Joined
Aug 6, 2017
Messages
17,824
Trophies
1
Age
27
Location
New York City
XP
11,798
Country
United States
Perhaps I misspoke. I was never able to install DBSP. I am using the legit cartridge.
Well the game definitely runs on lower firmware versions but its a different story if its on a cartridge. There is probably a firmware update stored on the cartridge that is forcing you to update. Since the cartridge is read-only, there isn't anything you can do; you will have to update your system firmware.
 

GerbilSwimmingPool

Well-Known Member
Member
Joined
Mar 7, 2018
Messages
115
Trophies
0
XP
260
Country
United States
Well the game definitely runs on lower firmware versions but its a different story if its on a cartridge. There is probably a firmware update stored on the cartridge that is forcing you to update. Since the cartridge is read-only, there isn't anything you can do; you will have to update your system firmware.
Do you have a guide or a tutorial that you recommend that I use? Should I go to the lately firmware update?
 

microchipman

Well-Known Member
Newcomer
Joined
Sep 1, 2018
Messages
63
Trophies
0
Age
46
XP
100
Country
Canada
No problem :)
I did run into another issue. Since I formatted my card I lost the few games I had on it in NSP format. I tried to reinstall them on my switch using Goldleaf and now I am getting an error screen. Error -An error has ocurred attempting to install the NSP. Error-2002-4518 (0x234C02) Module:File system (2). Description: Invalid NCA (might mean missing sigpatches or a too low firmware) (4518). I am using firmware 13.1.0 on the switch and most recent Atmosphere. I have tried downloading the NSP from 2 different sources with same error message. I tried to reinstall Tinfoil to see if I had the same issue, however, I get Tinfoil to install properly, I figured it was a compatability issue, so I tried Tinwoo, but get the same error screen. Do I need a sigpatch of some sort?
Yes, you more than likely need the sig patches. Install them from the link I put in the guide earlier. The link is just a link to this forum with the SIGpatches.

https://gbatemp.net/threads/switch-noob-paradise-ask-questions-here.488277/post-9665272
 

microchipman

Well-Known Member
Newcomer
Joined
Sep 1, 2018
Messages
63
Trophies
0
Age
46
XP
100
Country
Canada
Do you have a guide or a tutorial that you recommend that I use? Should I go to the lately firmware update?

You need sigpatches... If you don't know which to use, then just use both sets of:
https://github.com/ITotalJustice/patches/releases
@BigOnYa, Just a note, I've had the most luck with the SIGpatches right in this forum:
https://gbatemp.net/threads/sigpatches-for-atmosphere-hekate-fss0-fusee-package3.571543/

I saw a difference in the patches.ini file I believe, but don't quote me on that. Just my experience.
 
General chit-chat
Help Users
    Dark_Phoras @ Dark_Phoras: ^ related...