Hacking SWITCH NOOB PARADISE - Ask questions here

petspeed

Well-Known Member
Member
Joined
Nov 13, 2009
Messages
835
Trophies
0
Age
47
XP
857
Country
Denmark

Ibcap

Well-Known Member
Member
Joined
Dec 29, 2019
Messages
450
Trophies
0
XP
1,534
Country
United States
Any guides I can use to fix the issue?
Make sure that you are either using fusee primary or if you use hekate you have the line "kip1patch=nosigchk" in your hekate_ipl.ini. Otherwise fs patches will not be loaded, and a lot of guides intentionally do not tell you this because the people that made them are trying to give you setups that dont work well for installing games.
 

Sejo

Active Member
Newcomer
Joined
Jul 30, 2007
Messages
28
Trophies
0
XP
222
Country
United States
Make sure that you are either using fusee primary or if you use hekate you have the line "kip1patch=nosigchk" in your hekate_ipl.ini. Otherwise fs patches will not be loaded, and a lot of guides intentionally do not tell you this because the people that made them are trying to give you setups that dont work well for installing games.

I'm going to message you privately.
 

ThaDraGun

Well-Known Member
Member
Joined
Jul 15, 2007
Messages
336
Trophies
0
XP
340
Country
Canada
Fyi I tried searching "The search could not be completed. Please try again later."

I'm having issues starting Lego builders journey. It says "the software was closed because an error occurred"

I'm guessing it must be because my firmware is too old. I haven't updated in quite a while. I used choidujournx but forget how to use it.

I'm on 10.0.4 with atmosphere 18.0
Where do I find how to update? Or is there a different reason why it may not work?
 

Hayato213

..
Member
Joined
Dec 26, 2015
Messages
11,848
Trophies
1
Location
Aionios
XP
7,375
Country
United States
Fyi I tried searching "The search could not be completed. Please try again later."

I'm having issues starting Lego builders journey. It says "the software was closed because an error occurred"

I'm guessing it must be because my firmware is too old. I haven't updated in quite a while. I used choidujournx but forget how to use it.

I'm on 10.0.4 with atmosphere 18.0
Where do I find how to update? Or is there a different reason why it may not work?

Your firmware is too low, base on the game data, you need 12.0.1, you can get firmware files from that darth site, use Atmosphere daybreak to update.

1.PNG
 

shtonkalot

Can't hold on much longer, But I'll never let go!
Member
Joined
May 28, 2006
Messages
966
Trophies
0
Location
Gosford, Australia
Website
Visit site
XP
375
Country
I used choidujournx but forget how to use it.
I'm on 10.0.4 with atmosphere 18.0
Where do I find how to update? Or is there a different reason why it may not work?

choidujournx is outdated. As Hayato213 said above use Daybreak instead. You should find daybreak is already installed as part of Atmosphere and is available in the homebrew menu. It's very easy to use and you just need the same update files you would have used with choidujournx, again as Hayato213 mentioned.

You'll probably want to update your sigpatches after the firmware update too.

I did the same process recently and upgraded from 10.0.? (can't remember exactly) to 12.0.3 using daybreak for the first time. It was simple.
 

Lunatics

Well-Known Member
Member
Joined
Aug 9, 2010
Messages
191
Trophies
0
XP
488
Country
United States
Does anyone know if SX OS will work with emunand updated to 12.0? I see it looks like Zelda may require 12.0 and I am afraid of losing support for newer games, currently still on 11.0 for EMUnand. Can I update the emunand partition to 12.0 or will that cause issues with SX OS (I'm pretty sure I cannot update sysnand and do not want to). I am a bit worried about making the switch to Atmo but I fear more and more that I will have to as time goes on.
 

Hayato213

..
Member
Joined
Dec 26, 2015
Messages
11,848
Trophies
1
Location
Aionios
XP
7,375
Country
United States
Does anyone know if SX OS will work with emunand updated to 12.0? I see it looks like Zelda may require 12.0 and I am afraid of losing support for newer games, currently still on 11.0 for EMUnand. Can I update the emunand partition to 12.0 or will that cause issues with SX OS (I'm pretty sure I cannot update sysnand and do not want to). I am a bit worried about making the switch to Atmo but I fear more and more that I will have to as time goes on.

SX OS only support up to 11.0.0
 

JoeBrownz

New Member
Newbie
Joined
Jul 16, 2019
Messages
3
Trophies
0
Age
33
XP
34
Country
Mexico
Hi guys,

I've found that my son's modded switch is giving me an error "Unknown pkg1 version, hos version not supported". I have tried to update and reinstall atmosphere and hekate but no luck. I think my son pressed "update version'' by mistake, so I was wondering what's the next step, should I restore the OFW and update the console? Or format the SD and reinstall everything?

PS: I am a huge noob on switch modding
 

petspeed

Well-Known Member
Member
Joined
Nov 13, 2009
Messages
835
Trophies
0
Age
47
XP
857
Country
Denmark
Hi guys,

I've found that my son's modded switch is giving me an error "Unknown pkg1 version, hos version not supported". I have tried to update and reinstall atmosphere and hekate but no luck. I think my son pressed "update version'' by mistake, so I was wondering what's the next step, should I restore the OFW and update the console? Or format the SD and reinstall everything?

PS: I am a huge noob on switch modding
Latest firmware is supported by the latest versions of Atmosphere and Hekate so it should work. Did you remember to update the payload you use as well?
 

vree

Well-Known Member
Member
Joined
Sep 12, 2005
Messages
663
Trophies
0
XP
1,226
Country
United Kingdom
So I read somewhere that it's possible to overwrite the game language a game starts up in on per game basis. This using some tweak in atmosphere.

I thought I never need this. But now I actually do for one game. Since I want to play it in English without changing the switch language each time I want to play said specific game. Because that would mean injecting each time I change the switch language.

So could anyone point me in the right direction how to set this up for one game?

tl:dr How do I overwrite a games language on per game basis using atmosphere?

SOLVED; Found this and it worked like a charm:

https://gbatemp.net/threads/nx-loca...e-of-specific-titles-from-your-switch.584814/
 
Last edited by vree,

elecu

Member
Newcomer
Joined
Nov 15, 2015
Messages
18
Trophies
0
Age
33
XP
81
Country
Mexico
Hi, there is a way to play a backup that requires 11.0 firmware if I am using 10.2 without updating the Switch? Something like a patch for this specific game or something like that?

Otherwise, if I update my emu using Daybreak. It'll update my original sys as well?
 

petspeed

Well-Known Member
Member
Joined
Nov 13, 2009
Messages
835
Trophies
0
Age
47
XP
857
Country
Denmark
Hi, there is a way to play a backup that requires 11.0 firmware if I am using 10.2 without updating the Switch? Something like a patch for this specific game or something like that?

Otherwise, if I update my emu using Daybreak. It'll update my original sys as well?
There are different tools that can be used to patch a game to work on lower firmwares. Whether you can do it for the particular games you need depends on the SDK used to build the game (I think it's called that - anyway try it and see if it works for your games). These tools can be used:
Switch Army Knife (SAK): https://github.com/dezem/SAK
reNXpack: https://github.com/The-4n/reNXpack

Updating EmuMMC with Daybreak will NOT update SysMMC
 
  • Like
Reactions: elecu

elecu

Member
Newcomer
Joined
Nov 15, 2015
Messages
18
Trophies
0
Age
33
XP
81
Country
Mexico
There are different tools that can be used to patch a game to work on lower firmwares. Whether you can do it for the particular games you need depends on the SDK used to build the game (I think it's called that - anyway try it and see if it works for your games). These tools can be used:
Switch Army Knife (SAK): https://github.com/dezem/SAK
reNXpack: https://github.com/The-4n/reNXpack

Updating EmuMMC with Daybreak will NOT update SysMMC
Cool, I'll check it out. Thanks, mate.
 

askara

Well-Known Member
Member
Joined
Feb 12, 2013
Messages
228
Trophies
0
XP
713
Country
I just downloaded the latest Atmosphere, but the switch crash when i click ChoiDujourNX or All in one switch updater. anyone know why?

Error code 2144-0001(0x290)
 
Last edited by askara,

vree

Well-Known Member
Member
Joined
Sep 12, 2005
Messages
663
Trophies
0
XP
1,226
Country
United Kingdom
I just downloaded the latest Atmosphere, but the switch crash when i click ChoiDujourNX or All in one switch updater. anyone know why?

Error code 2144-0001(0x290)

Use 'Daybreak' instead. That is the 'go to' these days to update switch firmware. It should be default included with latest atmosphere.
 
Last edited by vree,
  • Like
Reactions: askara
General chit-chat
Help Users
    NeoGaming @ NeoGaming: yes