1. Finale

    OP Finale Member
    Newcomer

    Joined:
    Dec 6, 2019
    Messages:
    12
    Country:
    Brazil
    So, everything was normal up until yesterday. When i put my switch on the dock, it didnt connect properly and the green led started blinking without end. I manage to get it working again by disconecting the dock and powering it up with the cables being pluged in the adapter->hdmi-> switch order. However, hdmi signal started failing randomly again today, and the issue happened once more. Problem is, now the ac adapter wont charge the switch when connected directly and switch no longer charges on pc when connected to a usb-c cable.

    Naturally i thought the usb-c port of the switch died, but it still connects in rcm mode, which makes no sense to me.I wonder if anyone had a similar situation,i cant find the specifics of this one online.
     
  2. Nagaa

    Nagaa Newbie
    Newcomer

    Joined:
    Nov 8, 2020
    Messages:
    9
    Country:
    France
    Check the USB C port if there is any bend pin
    if it's good the problem is most likely the M92T36 chip and need to be changed
     
  3. Finale

    OP Finale Member
    Newcomer

    Joined:
    Dec 6, 2019
    Messages:
    12
    Country:
    Brazil
    But this is a charge chip right? If it doesnt output signal,surely something else has to be a problem right?
     
  4. CHTechRepair

    CHTechRepair Member
    Newcomer

    Joined:
    Jan 13, 2021
    Messages:
    41
    Country:
    United States
    M92 handles negotiation of voltage from the charger among other things. If your device isn't charging it is likely the culprit if your port is intact. P13 handles usb muxing including display port out. You'll need to get into the switch and test electrically to find this problem.
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - charging, working, adapter