1. Digitalcat

    OP Digitalcat Member
    Newcomer

    Joined:
    Dec 5, 2016
    Messages:
    44
    Country:
    So I got a bit of a issue, I haven't used my switch for a while now and for the first time in forever I decided I wanted to play some Splatoon, sadly the console no longer boots, I've tried the usual standard stuff off holding the power button for 15 sec to turn it off completely, checking if it was in AutoRCM which it isn't, and seeing if it charges and here is the funny part that confuses me the most, it does recognise power input, because as soon as I put it on the charger, the battery Icon on the top left starts flashing saying it's half full, which is probably a massive lie, but everytime I try turning the switch on while it's connected to power it will get to the Nintendo logo and then shut off, and when it isn't on power it won't start at all.

    Anyone experienced this before? Or know any fixes for this? Thanks in advanced.
     
    Last edited by Digitalcat, Feb 17, 2020
  2. Lacius

    Lacius GBAtemp Legend
    Member

    Joined:
    May 11, 2008
    Messages:
    12,119
    Country:
    United States
    Have you ever had AutoRCM installed? What is the battery percentage when viewed in Hekate?
     
  3. Digitalcat

    OP Digitalcat Member
    Newcomer

    Joined:
    Dec 5, 2016
    Messages:
    44
    Country:
    Oh shit, nvm. It just fixed it self and is on 92%. Wtf?

    Edit:
    Quick update, Switch is working again, it didn't have AutoRCM installed, and I genuinely have no idea what fixed it, it's fully charged now and working fine. Maybe something inside the switch lost charge after not being on for several months, but it's all working again.
     
    Last edited by Digitalcat, Feb 17, 2020
  4. Lacius

    Lacius GBAtemp Legend
    Member

    Joined:
    May 11, 2008
    Messages:
    12,119
    Country:
    United States
    Merely entering Hekate can fix battery sync issues.
     
  5. Digitalcat

    OP Digitalcat Member
    Newcomer

    Joined:
    Dec 5, 2016
    Messages:
    44
    Country:
    -snip-

    Ignore what I said, it's been a while since I last done anything with my Switch, and forgot a lot of the terms. Especially forgot Hekate is boot loader and not a cfw, oops. But yeah, idk what the issue is, I think it could be a battery Desync since my Hekate version is old, like proper old, old enough that I forgot what it was and that it hasn't been updated in years. I should probably update that and run it to see if that changes anything on the battery.
     
    Last edited by Digitalcat, Feb 17, 2020
    Lacius likes this.
  6. Digitalcat

    OP Digitalcat Member
    Newcomer

    Joined:
    Dec 5, 2016
    Messages:
    44
    Country:
    I think there might be a battery issue as you said? But merely entering Hekate didn't fix it, it shows the battery at 90% in hekate, the same when running the switch normally, but whenever it goes below 90% I get the big low power warning on the screen and the switch turns off, it does the same thing in hekate minus the big power warning, it just shuts down below 90%. But I can keep rebooting the system just fine as well as enter RCM. I just can't have it running for longer than a minute.

    Any idea's?
     
  7. Lacius

    Lacius GBAtemp Legend
    Member

    Joined:
    May 11, 2008
    Messages:
    12,119
    Country:
    United States
    Are you using the latest version of Hekate?
     
  8. Digitalcat

    OP Digitalcat Member
    Newcomer

    Joined:
    Dec 5, 2016
    Messages:
    44
    Country:
    Yup I am, also found out that once I hit 87% I can't turn on the console at all anymore unless it's connected to power, and even then it keeps shutting down until it hits above 90. Hekate reports the battery is doing fine, but for some reason the switch Pre-charges at 87 like it would when it's at 0. So I think the battery might just be completely dead due the few months it's been completely without charge. Unless I'm mistaken and there is something I'm not seeing here, which could be the case.
     
  9. PandFurr

    PandFurr Advanced Member
    Newcomer

    Joined:
    Nov 21, 2016
    Messages:
    99
    Country:
    Mexico
    Digitalcat likes this.
  10. Digitalcat

    OP Digitalcat Member
    Newcomer

    Joined:
    Dec 5, 2016
    Messages:
    44
    Country:
    Thanks for the tip fam, but I was able to fix it by draining my battery several times, I noticed the battery was able to go lower and lower by each full charge I was doing with the switch, and eventually it was able to get to 0% after it was able to reach 5 hours in a game on a single charge. Appreciate the help though! <3
     
    Last edited by Digitalcat, Feb 21, 2020
    PandFurr and Jayro like this.
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - AutoRCM, several, Switch