1. mvmiranda

    OP mvmiranda GBAtemp Maniac
    Member

    Joined:
    Oct 29, 2013
    Messages:
    1,299
    Country:
    Brazil
    Hello all,
    I have a customer's Switch Lite with some issues on the display side.
    The customer tried to install the SX Lite and, after a failed attempt, gave up.

    There is no missing cap on top of the APU, the board is missing the microSD cap for powering up the SX Lite, there seems to be no apparent short near the NAND points but spotted a weird "gunk" around the small crystal near the video connector. It looked like flux residue.
    When touching the crystal with my fingers it was super hot! I could not keep touching it for more than 4 seconds.
    Untitled.png (image from the internet)

    When powering on the console the backlight turns on (I can measure the 17v) and only a thin vertical "stripe" of image can be seen on the far right side of the screen and. after some minutes with the screen lit the image starts to appear with colors washed out, small stripes almost like scanlines and the screen flickers a lot turning on and off intermittently. Also, the icons does leave "burned" images where it was.
    IMG_20201126_131222260.jpg IMG_20201126_131251773.jpg



    Does anyone eve experienced this?
    I'm considering switching the crystal for testing purposes!

    Any tips are welcome!

    Thanks!
     
  2. godreborn

    godreborn GBAtemp Legend
    Member

    Joined:
    Oct 10, 2009
    Messages:
    14,316
    Country:
    United States
    can you imagine someone sending a switch in for repair by Nintendo that had the sx os logo burned into the screen? :P
     
    mvmiranda likes this.
  3. mvmiranda

    OP mvmiranda GBAtemp Maniac
    Member

    Joined:
    Oct 29, 2013
    Messages:
    1,299
    Country:
    Brazil
    I laughed loud!
     
    godreborn likes this.
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - flicker, quality, Switch