Switch doens't boot into RCM - auto RCM enabled, jig does nothing

realbout

Member
OP
Newcomer
Joined
Mar 15, 2009
Messages
22
Trophies
0
XP
225
Country
Austria
Hello,

my switch doesn't boot anymore in RCM mode. i've just powered it off to remove the SD card and copy some stuff over. Back in the switch and boom, nothing. Normally i inject the payload with Rekado via Android phone, this worked all the time. I'm on Atmosphere 13.1 and havent updated since then. I was just copying some .nsp in the games folder of the SD card, no update or something.

Is there anything i can do to get it into RCM? I've testet with a jig and volume up + Power - nothing. I've auto RCM enabled since .. since its possible i think, so normaly i dont use the jig. Rekado doesnt even push on the phone, normaly the display (on the phone) gets on and the payload is send. Battery on the Switch is fully charged. The cables is use are working, the USB OTG Adapter and the USB-C cable are Anker products, they normaly doesn't make any problems.

Thanks in advance for your help!
 

Draxzelex

Well-Known Member
Member
Joined
Aug 6, 2017
Messages
17,942
Trophies
1
Age
27
Location
New York City
XP
11,871
Country
United States
Hello,

my switch doesn't boot anymore in RCM mode. i've just powered it off to remove the SD card and copy some stuff over. Back in the switch and boom, nothing. Normally i inject the payload with Rekado via Android phone, this worked all the time. I'm on Atmosphere 13.1 and havent updated since then. I was just copying some .nsp in the games folder of the SD card, no update or something.

Is there anything i can do to get it into RCM? I've testet with a jig and volume up + Power - nothing. I've auto RCM enabled since .. since its possible i think, so normaly i dont use the jig. Rekado doesnt even push on the phone, normaly the display (on the phone) gets on and the payload is send. Battery on the Switch is fully charged. The cables is use are working, the USB OTG Adapter and the USB-C cable are Anker products, they normaly doesn't make any problems.

Thanks in advance for your help!
Did you update your firmware recently? That can remove AutoRCM.
 

realbout

Member
OP
Newcomer
Joined
Mar 15, 2009
Messages
22
Trophies
0
XP
225
Country
Austria
Thanks a lot for your replies! It was a faulty USB-C Port on my phone. This was quite a lot of figuring out, because charging the phone works well.

Thanks.
 
  • Like
Reactions: VDDZ

unfinishedsenten

New Member
Newbie
Joined
May 12, 2022
Messages
2
Trophies
0
Age
36
Location
Levanger
XP
3
Country
Norway
I have 2(!) faulty/weird USB cables. One USB-A -> C, and one USB-C -> C, NEVER had any problems with them before, they work for everything else, but I had to use a old phone-charging-cable to get RCM to register.
I've had this problem before, but only when the Switch was shut down due to battery being empty. If I shut it off and on myself, it seems to work every time.
But even when I left it charging over night just to be sure it had power, I still had to fidget allot before it worked, with different cables and turning it on and off again (I have autoRCM, so I have no idea if it's on or off..).. Reinstalled TegraRCM GUI drivers, turned my PC off and on a few times as well, new cables, new usb-ports, I don't know what specifically did it, but suddenly it worked :)
 
General chit-chat
Help Users
    NoobletCheese @ NoobletCheese: well scratching an itch is sort of pleasurable, in the same way taking a leak or a dump when you...