Hacking Switch Backlight On + RCM but Nothing else seems to work

rockjaw14

New Member
OP
Newbie
Joined
Sep 4, 2021
Messages
2
Trophies
0
Age
35
XP
6
Country
Italy
Hi guys, looking for help before turning completely mad.

I bought an unpatched Switch a couple of years ago and have used it without problems ever since with AMS + HEKATE with AUTO RCM active.

On day, I realize that the console had been disconnected from the charging dock for an indefinite time.
I tried to charge it but without success. Even after 48 hours charging, the battery indicator was absent and any attempt to connect it to the PC for payload injection failed.
I initially thought the battery was grounded. I took a replacement but it had no effect.
I then tried to restore the SD, but inserting it into the PC I realized that it had become unreadable by any device. I recovered a spare 16GB SD on which I installed the same version of the last working AMS release (I had a backup on my pc).

The problem seemed solved: Tegra showed Connected RCM, I successfully injected heckate payload and booted AMS. I navigated through the various menus to check the functionality of joycons, touchscreen and everything else, turned off the Switch, extracted the SD to load some NSP titles to be tested, loaded everything on the SD, got it in the Switch and plug the console to the PC.

Here the bad stuff happened: Tegra showed connected RCM, but upon injection of hekate, the console backlight turned on, but the screen stayed black.
Tegra's UI, which usually returns to red/disconnected when AMS successfully starts, now stays green, and I have no choice but to restart the Switch by holding the button down for 4-5 seconds.

After that i did dozens of retries, and I only managed to start the Switch once. I told myself that maybe upgrade to latest firmware using Daybreak would prove useful.
Firmware upgrade went smoothly and Switch was fully operational after the upgrade. But only until I turned of the console again to load some NTS on the SD.

And now it's gone for good.

Everytime I connect the switch to PC, tegra goes green and shows RCM connected, but when I try to inject any payload (hekate, fusee-primary, tegraexplorer), the backlight goes on but nothing boots, and the screen remains black and empty. After trying to inject fusee-primary, i tried to connect the Switch to TV dock, but it doesn't show anything.
The only difference between the payloads is with fusee, if I push the ON button, the backlight goes away for a second and comes back.

what is happening?!
 

Lenks

Well-Known Member
Newcomer
Joined
Mar 8, 2020
Messages
94
Trophies
0
Age
34
XP
457
Country
Bulgaria
Also try different device, or diffrent HIGH quality usb-c cable or even better RCM Loader device. Few weeks ago I had not the same, but similar problem where I was able to inject with RCM Loader, but not with my PC and turns out it was my usb-c cable going dead.
 
  • Like
Reactions: rockjaw14

rockjaw14

New Member
OP
Newbie
Joined
Sep 4, 2021
Messages
2
Trophies
0
Age
35
XP
6
Country
Italy
format the sd card as fat32 and put a clean copy of hetake and atmosphere on there.

I don't know man, you must be some kind of magician. I swear to gods I did this routine almost 4-5 times and never worked. After your post, I tried once again driven by the force of desperation and boom... everything works now.

Can I ask you some simple advice on how to win a lottery?
 

linkinworm

Well-Known Member
Member
Joined
May 30, 2008
Messages
1,548
Trophies
0
Age
31
Location
Birmingham (England)
XP
1,343
Country
I don't know man, you must be some kind of magician. I swear to gods I did this routine almost 4-5 times and never worked. After your post, I tried once again driven by the force of desperation and boom... everything works now.

Can I ask you some simple advice on how to win a lottery?
haha, closest thing would to be, buy cardano crypto before the 12th september
 
General chit-chat
Help Users
  • mr_switch @ mr_switch:
    Here is hoping 2022 is a good year for DC cinematic universe
    Gift
  • gudenau @ gudenau:
    Honestly don't really know what Dune is.
    Gift
  • gudenau @ gudenau:
    Anyone here know much about Jetbrains InteliJ Idea?
    Gift
  • Sonic Angel Knight @ Sonic Angel Knight:
    Oh, T-hug was here :blink:
    Gift
  • Sonic Angel Knight @ Sonic Angel Knight:
    Hey, where the admins at? Come in the chat. I got a idea. How bout a Sound notification or something when someone tags you in chat? :ninja:
    Gift
  • DinohScene @ DinohScene:
    Post it in the v8 feedback thread
    Gift
  • Gift
  • OzKenny1983 @ OzKenny1983:
    Post what sorry? I'm guessing we were talking about this ages ago, but I haven't been on GBATemp in almost a year so my memory is failing me :-/
    Gift
  • DinohScene @ DinohScene:
    feedback and or bugs that may have popped up since the migration to XenForo 2!
    Gift
  • OzKenny1983 @ OzKenny1983:
    Umm...I think you might have the wrong person, since that may as well have been written in Chinese. I have nothing to do with the management of this site, nor have I ever been involved. I'm just a member, and hardly even qualify as that...like I said my last post was almost a year ago lol
    Gift
  • DinohScene @ DinohScene:
    Lol no, Sonic Angel Knight had an idea, best would be to post it in that thread haha
    Gift
  • OzKenny1983 @ OzKenny1983:
    Sorry, don't know Sonic Angel Knight either...
    Gift
  • The Real Jdbye @ The Real Jdbye:
    this new xenforo version keeps logging me out, whyh
    Gift
  • godreborn @ godreborn:
    not sure. I haven't had that issue. the only computer related issue I've been having is with my isp and the smtp server getting authentication errors randomly. I'm going to have to call them again. this started happening again after changing my password.
    Gift
  • godreborn @ godreborn:
    you may have to check the box that says "stay signed in." psx place used to have a problem like this for random people, including myself. that will prevent being logged out or it did anyway.
    Gift
  • The Real Jdbye @ The Real Jdbye:
    it's happened 3 times already and of course i ticked the box
    Gift
  • linuxares @ linuxares:
    Yeah happened to me as well
    Gift
  • Gift
  • Julie_Pilgrim @ Julie_Pilgrim:
    just installed gentoo, i came out alive somehow
    Gift
  • Julie_Pilgrim @ Julie_Pilgrim:
    honestly the install itself wasn't that hard, the hard part was getting my hardware to work
    Gift
  • x65943 @ x65943:
    Is it true what they say, did your neck sprout hairs afterwards?
    Gift
  • The Real Jdbye @ The Real Jdbye:
    good luck actually using it
    Gift
  • Cnrisnm @ Cnrisnm:
    Hi
    Gift
  • SG854 @ SG854:
    When I see a red light all I know is go
    Gift
  • kenenthk @ kenenthk:
    Have you tried squid games based on your skills
    Gift
    kenenthk @ kenenthk: Have you tried squid games based on your skills