1. MockyLock

    OP MockyLock GBAtemp Fan
    Member

    Joined:
    Apr 21, 2011
    Messages:
    300
    Country:
    France
    Hello,
    So, as the title says, i can't get sounds from my sub-woofer in-game.
    When i run the surround test from the Switch menu, all 5 speakers AND the sub-woofer are working. But in game, the sub-woofer doesn't ouput anything.

    Before anyone gets out with some Dolby/DTS/Optical matters, this is what's known :
    - the Switch ouputs LPCM 5.1. It's a non compressed raw format (each channel seperately). Nothing to do with something Dolby/DTS.
    - LPCM 5.1, being a non compressed signal, it uses a very large bandwith. So it can't be carried by optical. Only HDMI.
    - my surround setup is fully working, test tone gives a signal through each 5 speakers AND the sub-woofer.
    - the Switch surround test gives a signal through each 5 speakers AND the sub-woofer.
    - the sub-woofer doesn't ouput in-game (tested with Starlink, Luigi's Mansion 3, Zelda BotW).
    - it's seems to be a bug that appeared in one of the last Switch update (Reddit/forums feedback).

    More than a solution, i'm looking for some other users' feedback about this issue (even if a solution would be welcome).

    Thank you.
     
    BvanBart likes this.
  2. BvanBart

    BvanBart Gaming addict #2 and some
    Member

    Joined:
    Apr 16, 2007
    Messages:
    1,307
    Country:
    Netherlands
    They changed the test sound from the menu I just noticed! Going to check if my subwoofer does something...
     
  3. MockyLock

    OP MockyLock GBAtemp Fan
    Member

    Joined:
    Apr 21, 2011
    Messages:
    300
    Country:
    France
    Nice, when did they change this ?
    I'll give a try hopefully this late.
     
  4. BvanBart

    BvanBart Gaming addict #2 and some
    Member

    Joined:
    Apr 16, 2007
    Messages:
    1,307
    Country:
    Netherlands
    I can confirm that my subwoofer works! Tried a various range of games and they all used the subwoofer.

    Xenoblade 2 actually has no surround sound but does give signal to the subwoofer
     
  5. redrum30

    redrum30 Advanced Member
    Newcomer

    Joined:
    May 17, 2018
    Messages:
    74
    Country:
    United States
    yeah my sub works
     
  6. MockyLock

    OP MockyLock GBAtemp Fan
    Member

    Joined:
    Apr 21, 2011
    Messages:
    300
    Country:
    France
    Hey nice² !
    I couldn't test it yesterday, so i'll give a try this WE !

    EDIT : I still wonder why there isn't more about this issue on the net...
     
    Last edited by MockyLock, Jan 7, 2021
  7. WarSpaz

    WarSpaz Advanced Member
    Newcomer

    Joined:
    Dec 26, 2017
    Messages:
    56
    Country:
    Sweden
    I'm getting sound from subwoofer on fw 11.0. Dunno why it's not working on your end, especially since it plays on the test

    Skickat från min ONEPLUS A6003 via Tapatalk
     
  8. MockyLock

    OP MockyLock GBAtemp Fan
    Member

    Joined:
    Apr 21, 2011
    Messages:
    300
    Country:
    France
    Last time i tried was about one year ago, and i can assure you that the subwoofer wasn't working in-game.
    Let's see this WE !
     
  9. WarSpaz

    WarSpaz Advanced Member
    Newcomer

    Joined:
    Dec 26, 2017
    Messages:
    56
    Country:
    Sweden
    Haha, didn't even notice the thread was from a year ago

    Skickat från min ONEPLUS A6003 via Tapatalk
     
  10. MockyLock

    OP MockyLock GBAtemp Fan
    Member

    Joined:
    Apr 21, 2011
    Messages:
    300
    Country:
    France
    So, i made a quick test this WE, and i'm pretty sure that i don't have sound in-game out of the sub-woofer. I tested with Zelda BOTW and Starlink.
    Although the test gives me a real woof-sound from it, i feel there's nothing in-game.
    Do you have a game (and a moment in this game) that surely has some huge sound from the sub ?
     
  11. Darvan

    Darvan Newbie
    Newcomer

    Joined:
    Jan 17, 2021
    Messages:
    1
    Country:
    United States
    I signed up to reply to you since your the only person as of late that is talking about the same exact issue that I'm having with the switch. I currently have tried everything and it completely looks like either this is a switch issue ie,x, firmware etc. BTW my findings are just like yours if you run the test in the setup for the switch the sub works no issue when you go to Mario Kart 8 DX there is no use of the sub. The only thing I found on the net is that on the Wii U it did the same thing which sadly I owned and played the hell out of and I don't remember it doing that to the sub. I'm not sure what steps need to be taken but if your saying it's happening in two games I don't own Zelda and Starlink this is a issue.
     
  12. Rahkeesh

    Rahkeesh GBAtemp Advanced Maniac
    Member

    Joined:
    Apr 3, 2018
    Messages:
    1,842
    Country:
    United States
    A confusing factor is a common receiver feature like crossover, which analyzes speaker channels for low frequencies and moves or adds them to the sub. You need to shut that off if you want to test whether the game itself outputs anything to the subwoofer channel. (This is clearly not OP's problem though.) I'm not sure how many games actually use the channel themselves or they just expect you to use crossover feature instead...
     
  13. BvanBart

    BvanBart Gaming addict #2 and some
    Member

    Joined:
    Apr 16, 2007
    Messages:
    1,307
    Country:
    Netherlands
    I think that a lot of gamers mis out on the beauty of good surround sound and only look at the FPS...
     
  14. MockyLock

    OP MockyLock GBAtemp Fan
    Member

    Joined:
    Apr 21, 2011
    Messages:
    300
    Country:
    France
    It's really nice from you, because i was starting to doubt about my own truth :D
    Anyway, it motivates me a bit more about digging in this issue.
    i was wondering if it could have something to do with the usual small/large setting.
    The strange thing is still that the Switch menu surround test still makes the sub woofing :/
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - surround, working, Switch