Hacking Super Mario RPG Randomizer in PAL60, a very strange case

pidgezero_one

New Member
OP
Newbie
Joined
Jan 2, 2018
Messages
1
Trophies
0
Age
34
XP
55
Country
Canada
Hi all,

Occasionally I have been streaming Super Mario RPG Randomizer. Because SMRPG and SMRPG romhacks are not compatible with flashcarts, I have been using Wii VC injection to play it.

Since SMRPG uses the SA-1 chip and is a humongous rom file, SMRPG roms can pretty much only be injected into SMRPG WADs. Using ShowMiiWads but trying to put the J version in a US rom and vice versa will not load.

I live in Canada so my Wii is NTSC, and I've just been using ShowMiiWads to inject a randomized NTSC rom into a NTSC WAD and stream via s-video, and so far this has been fine, but recently I acquired a Datapath capture card which only accepts DVI. My DVI switch only has two ports, so I've converted my entire setup to only use either HDMI or SCART, and then convert those signals to DVI. (I sold all my other capture devices so these are my only options now.)

I was recently given a Wii scart cable, so I used Anyregion Changer to change my Wii to PAL, and use the system menu to change to PAL60 output. I then used Anyregion Changer again to switch my Wii back to NTSC, but keep the video output on PAL. It looks awesome!

However there is the problem of VC games. NTSC SMRPG on a SCART cable is just all red. "Force PAL60" in Gecko OS and USBLoaderGX has no effect on this.

I attempted to inject a randomized NTSC ROM into a PAL SMRPG wad and use Freethewads to remove the region lock, but that just gives a "This channel cannot be used" error when installing to the NAND, and just crashing my Wii entirely when I load it through Gecko OS or USBLoaderGX's EmuNAND. I used the same steps to produce that same ROM injected into a NTSC wad which booted up fine in all its red glory, so I know it's not an injection error on my part. I also know it's not a problem with the wad as the vanilla wad also runs fine and looks fantastic. I also tried running the injected PAL wad and the injected NTSC wad on the latest stable Dolphin build for testing purposes, the NTSC wad works while the PAL wad says the system memory has been corrupted.

I also tried extracting the ROM from the PAL SMRPG wad and decompressing it with gbalzss, and then running that through the randomizer, but despite the randomizer working for J and U roms, it does not work for the extracted PAL one. The extracted rom also will not load in any emulators (likely since it's of the unusual ".rom" filetype?)

I'm running out of ideas. Does anyone have any suggestions on what I can do to play an SMRPG romhack in Virtual Console on PAL60? Would prefer not to have to use a homebrew emulator over VC injection :(
 
Last edited by pidgezero_one,
  • Like
Reactions: SaulFabre

Site & Scene News

Popular threads in this forum

General chit-chat
Help Users
    M4GM43L @ M4GM43L: wsgg