Homebrew Super Mario 64 Port - Wii U

Fladulator

Well-Known Member
Newcomer
Joined
Feb 18, 2021
Messages
78
Trophies
0
Age
34
XP
608
Country
Germany
Sorry for the double post but yea, that looked golden. :)

Anything I missed here?

1653127667842.png
 

CrisMod

Well-Known Member
Member
Joined
May 4, 2020
Messages
376
Trophies
0
Age
37
XP
923
Country
Italy
By masking the problem away. Please stop this false hints.

Pacman is a package manager, sudo is a command to switch the user. Completely different things and nothing with Win or Lin.
What you talking about.....
He need the help, I give him with some congruent stuff and it works.... after, if you have some other solution not for the port but for the ex version of sm64, welcome (if it's really working).

I cannot understand your problems....
 

V10lator

Well-Known Member
Member
Joined
Apr 21, 2019
Messages
976
Trophies
0
Age
34
XP
2,360
Country
Germany
@Fladulator Wait, you cloned the git repo to opt/devkitro/wut ? So tar tries to install it into the folder its coming from which seems to create an endless loop. Clone the repo to some other folder instead.

What you talking about.....
This:
The error message sais KPADShutdown() couldn't be found so you need to update WUT by compiling it for youself as this function has been added at the fourth of February 2022 while latest WUT release is from the first of November 2021.
I really don't want to sound mean and I appreciate all you do for the community but telling the error is in SM64s sources is just wrong. The problem was outdated WUT from the beginning and you removing the KPADShutdown() call from SM64s sources is just backporting it / masking the problem with invalid API usage.
 

CrisMod

Well-Known Member
Member
Joined
May 4, 2020
Messages
376
Trophies
0
Age
37
XP
923
Country
Italy
@Fladulator Wait, you cloned the git repo to opt/devkitro/wut ? So tar tries to install it into the folder its coming from which seems to create an endless loop. Clone the repo to some other folder instead.


This:

I really don't want to sound mean and I appreciate all you do for the community but telling the error is in SM64s sources is just wrong. The problem was outdated WUT from the beginning and you removing the KPADShutdown() call from SM64s sources is just backporting it / masking the problem with invalid API usage.
I believe, you were a bit toxic with your comments to me, and calm down my friend....

What I gave to @Fladulator it's not the modified version to mask of the compiling error, it's just the previous version of the original repo from sm64-port....I don't mask anything with some modification from the original, please before comment in toxic way, try to understand what the people make and respect.
 

V10lator

Well-Known Member
Member
Joined
Apr 21, 2019
Messages
976
Trophies
0
Age
34
XP
2,360
Country
Germany
As I said: I don't want to sound mean and I respect you and your work but now you just confirmed what I said:
it's just the previous version
So backported instead of fixed, right? ;)

//EDIT: Just to make this clear: I really, really appreciate all your work. In fact a ton of your codes are running on my Wii U. You're a great developer and a great human beeing. There was just one little mistake (telling the issue is in SM64s sources) and it seemed like you overlooked my posts and as a result derailed the thread (away from the WUT problem to an artifical SM64 sourcecode problem). That's why I tried to make you aware of your issue more and more with each of my posts. Really sorry if that sounded mean/toxic. That really wasn't my intention.
 
Last edited by V10lator,

Fladulator

Well-Known Member
Newcomer
Joined
Feb 18, 2021
Messages
78
Trophies
0
Age
34
XP
608
Country
Germany
@Fladulator Wait, you cloned the git repo to opt/devkitro/wut ? So tar tries to install it into the folder its coming from which seems to create an endless loop. Clone the repo to some other folder instead.

Hmmm did, but seems to do the same thing now.

1653128960668.png


I typed 1 and pressed enter. But nothing happened.

Btw. this message only pops up if I want to close msys2.


@V10lator and @CrisMod please relax. Man, I'm glad you two help me. There's no need to fight. CrisMod referred to the compiled version of sm64-port in terms of "Good , so now it's working." So for now I have a playable version which is totally nice. Next step is to eliminate the KPADShutdown thing so I can compile sm64ex nightly :)

I'm still at wut :D
 

V10lator

Well-Known Member
Member
Joined
Apr 21, 2019
Messages
976
Trophies
0
Age
34
XP
2,360
Country
Germany
Hmmm did, but seems to do the same thing now.
Sorry to say but your opt/devkitpro folder is probably corrupted beyond repair, so the best way might be to just delete everything and start over from scratch.
This time git clone to new/empty folders only. The folder from the git clone command I gave above is needed temporarily only (it's save to delete it after executing make install). Also keep in mind that this temporary folder should not be the folder you want to install wut to.

In case it still hangs after restarting from scratch there's probably something wrong with tar but we will be able to work around that, so don't worry. Let's do one step after the other through, so I'll tell you how to work around it after you tried to start from scratch. :)

Btw. this message only pops up if I want to close msys2.
When you look close at your screenshot you see that the make install command did not finish. All msys2 tells you in that message is exactly that: The command is still running so you should not close it.
 

Fladulator

Well-Known Member
Newcomer
Joined
Feb 18, 2021
Messages
78
Trophies
0
Age
34
XP
608
Country
Germany
When you look close at your screenshot you see that the make install command did not finish. All msys2 tells you in that message is exactly that: The command is still running so you should not close it.
So I arrived home and it's still at the same screen :D
Since I know a little more than yesterday I will try it by tomorrow from scratch. That's ok :) So You say I have to deinstall msys2 and install DEVKITPRO and then reinstall msys2 + repeat the steps from the tutorial to receive all the files needed?

I will post the new status quo tomorrow then.

Thank you guys very much!

@CrisMod
Are those glitchy texts in the German version gone in the newer version? Do you know sth about that?

Best,
TuF
 

CrisMod

Well-Known Member
Member
Joined
May 4, 2020
Messages
376
Trophies
0
Age
37
XP
923
Country
Italy
So I arrived home and it's still at the same screen :D
Since I know a little more than yesterday I will try it by tomorrow from scratch. That's ok :) So You say I have to deinstall msys2 and install DEVKITPRO and then reinstall msys2 + repeat the steps from the tutorial to receive all the files needed?

I will post the new status quo tomorrow then.

Thank you guys very much!

@CrisMod
Are those glitchy texts in the German version gone in the newer version? Do you know sth about that?

Best,
TuF
Hi @Fladulator ,

I try to help you, in concise and simple way.

After further investigation of your case, I found that your problem is not isolated but has already been mentioned by two users on the AboodXD Git page here: https://github.com/aboood40091/sm64-port/issues/25 .

The main problem does not seem to be a @AboodXD pseudo error or yours, but the problem is that WUT in the latest version dating back to 02-Nov-2021, did not include this KPADShutdown() function. And from my part, reading now, that's what the other V10lator user was trying to tell you yesterday.

It seems (according to another user in Git, but I can't prove it) that he solved it by downloading the source file master (you can download it from here: https://github.com/devkitPro/wut , via the git clone in Terminal), since the master source files are in working-progress before releasing another beta or definitive version of the WUT libraries.

And when you go to download / search the WUT library via pacman -Sl , pacman rightly makes you download the latest version of WUT 1.0.0_beta12-1 which DID NOT include the KPADShutdown() function. And that's why you should install yourself manually WUT in Working progress, if you want to test around and for your information only (till will not come out a WUT new version).

What happened?!
Checking all the code of my older AboodXD working SM64-port version with the new one of AboodXD, AboodXD introduced 78 Fixes in the code (many of them inherited from the open SM64 project) compared to the working version I passed you yesterday.
Reading the source code of the new SM64-port application, I see that in the new version of SM64-port there are several inherent fixes, it have fixes in text and compatibility in the versions / regions of SM64, but to tell you for sure if in the new version of SM64-port it has been fixed the German \text (because it is not mentioned in the fix list) unfortunately I cannot say for sure if yes or not.
If I am not mistaken, by memory (because I am European too), in the past I have tried and I have heard that in the European version of SM64 Wii U port someone had exposed the problem about some bug but now to tell you what exactly it was I can not say for sure, maybe it was also adjusted by AboodXD in the various SM64-port output versions. In the end, for my part in the past, I have always installed SM64-port in the USA-NTSC version as it is more compatible with the Compiling process and which has the advantage of 60Hz compared to the PAL version.

My advise on what you can do now are:

1) For now, you have a working sm64-port version that the whole community played perfectly "until yesterday", and that is not that old version but is the older version than the one you can't compile now. So the new fixes, I don't think they can be so striking as to change your gaming experience.

2) Delete everything related to the Wii U environment on your PC, including the settings of MSYS2 / Mingw64 and environmental variables; because, reading your previous posts I believe that when you getting informing around (and you were good at it) by assimilating a lot of information in a short time, you made confusion between the compilation settings for SM64-Wii U and SM64-PC version which in the simplest way are set separately (you can set up all in one like I did, but you have to manually set multiple configurations).

3) Once everything is deleted, restart your PC and start to setting up again the Wii-U environment for Windows by going here: https://github.com/devkitPro/installer/releases , once downloaded devkitProUpdater-3.0.3 .exe run it and let the software do the settings automatically for you. The software will do everything by itself, you don't have to put any key or set the environmental variables (always check that it has set it automatically).

4) You will find your new Mingw64/32 in the following address C:\devkitPro\msys2 .

5) Once everything is installed and Mingw64 opened, type pacman -Sy then pacman -Syu.

6) Then, always remaining in Mingw64, download all the libraries necessary to start to set the compiler, with pacman -S wiiu-dev and then continue with the installation of the libraries required by AboodXD for the compilation of SM64.

7) Check that you have all the libraries installed via the pacman -Sl function.

8) For Windows as you can see, you don't need to do any more steps, the extra steps you have probably read here: https://devkitpro.org/wiki/devkitPro_pacman , are extra steps for other operating systems like Linux and MacOS.

After you have everything set up and running well, you could experiment with installing WUT in "working-progress version" and you can experiment also with SM64-Ex for Wii-U.

Remember one thing, SM64-Ex for Wii-U is not a stable version and AboodXD also mentions it, and the EX version is a version to inject MODs into the game as also AboodXD mentions in its GIT.... it is not a stable version yet, so get it as a pure experiment on your side.

I hope I was helpful......
 
Last edited by CrisMod,

V10lator

Well-Known Member
Member
Joined
Apr 21, 2019
Messages
976
Trophies
0
Age
34
XP
2,360
Country
Germany
@Fladulator now that @CrisMod wrote that great guide I'll also tell you the workaround in case it's needed:

First we look into the Makefile to see what make install does: https://github.com/devkitPro/wut/blob/master/Makefile#L110-L112

Now we see that it executes mkdir -p $(DESTDIR)$(DEVKITPRO)/wut. You already have that path so that's unimportant. Let's jump directly to the next line: bzip2 -cd wut-$(VERSION).tar.bz2 | tar -xf - -C $(DESTDIR)$(DEVKITPRO)/wut - so there must be a tar.bz2 file. Do you see it? Good. First let's try to use a better command to extract: tar xjf wut-*.tar.bz2 -C /path/to/devktipro/wut (remember to replace "/path/to/devktipro" with the real path. No need to exchange anything else through).

In case this simplified tar command still hangs let's not use tar altogether but directly copy the files:
Code:
cp -ar include /path/to/devktipro/wut/
cp -ar lib /path/to/devktipro/wut/
cp -ar share /path/to/devktipro/wut/
 

AboodXD

I hack NSMB games, and other shiz.
OP
Member
Joined
Oct 11, 2014
Messages
2,873
Trophies
1
Location
Not under a rock.
XP
2,877
Country
United Arab Emirates
Man, I really need your help. I read the tutorial from the discord + additional posts (since parts of the tut seems outdated). I also read the whole 20 pages of this thread even if I just understood half of what you guys say since I never had anything to do with compiling before...

It doesn't matter what I try I will always get this error message:
View attachment 310781

It doesn't matter if I try to compile the sm64ex version which I totally prefer or the sm64-port. I didn't forget the environmental variables or anything else which was mentioned. I googled the "KPADShutdown" error and found "a solution" which I am totally not able to achieve:

View attachment 310782



When I try to install wut via the command make install it won't do the job and just gives me an error message. When I try updating it via the command pacman -S wut-msys2 it just gives me two error messages saying

error: failed retrieving file 'wiiu-fling.db' from wii.leseratte10.de : The requested URL returned error: 404
error: failed to synchronize all databases (unexpected error)

--> I started with
[wiiu-fling]
Server = https://fling.heyquark.com


but found out in the thread that this page is outdated. By visiting the site it clearly stated that the waybackmachine link still stores the files so I changed https://fling.heyquark.com to https://web.archive.org/web/20200705125529/https://fling.heyquark.com/. This way I received the files needed for that period. Since Wling isn't needed anymore, I chose to ignore it. But trying to figure out how the KPAD error could be solved makes me dying right now... In the end it doesn't matter if I try updating wut-tools using different commands, I always end up here:

warning: wut-tools-1.3.1-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

MSYS2 just tells me that wut or wut-tools is up to date. The official GitHub pages tell me otherwise. I don't know how to solve this problem. I donwloaded wut-tools-1.3.2 but I don't know how to install it manually. And it makes me crazy seeing so many other people achieving it without any stress while I'm sitting here losing my mind :D Man, it was a piece of cake compiling a pc version for testing purpose. Please, can anyone of you, @AboodXD or anyone else, help me with an up-to-date tutorial or just help me solving this KPADShutdown problem? It would be great! I just want to play this freaking awesome port on my WiiU... :(

Thank you very much in advance!

Best,
TuF

Hello. Sorry for taking a while to reply, but I don't use GBATemp often.

The problem is that I am using a function (KPADShutdown()) that is only available in the newest source code of WUT. The build has not been updated with it yet.

Furthermore, although not quite related to the current issue with WUT, I see that you have problems with updating the WUT build anyway. I've recently been made aware of this problem and I will try to update my tutorial to reflect upon it.

As for installing WUT from source code, don't worry about "make install" not working. It does not work for me either. You should just copy the "include" and "lib" files to the "opt" folder of wherever you have devkitPro (should be in the msys2 folder if you followed the tutorial to get devkitPro too).

Lastly, coming back to the issue of the function KPADShutdown(), there are other fixes to the issue, instead of updating WUT, which I only briefly touched on, but I should've tried explaining a bit further.

1. You can revert the change by adding a declaration of the function to the top of the file. That means you should simply just add this line in the beginning of the file:
C++:
extern "C" void KPADShutdown();
2. You can use WPADShutdown() instead, as, IIRC, this function does the same and is already available in older builds of WUT.
3. You can simply just remove the call to KPADShutdown(), as, IIRC, it's harmless to leave it without deinitializing it. (I should've done this)
 

AboodXD

I hack NSMB games, and other shiz.
OP
Member
Joined
Oct 11, 2014
Messages
2,873
Trophies
1
Location
Not under a rock.
XP
2,877
Country
United Arab Emirates
As for installing WUT from source code, don't worry about "make install" not working. It does not work for me either. You should just copy the "include" and "lib" files to the "opt" folder of wherever you have devkitPro (should be in the msys2 folder if you followed the tutorial to get devkitPro too).
(I'll explain further on this when I am on my PC again so that I can post screenshots as well.)
 
  • Like
Reactions: Fladulator

Fladulator

Well-Known Member
Newcomer
Joined
Feb 18, 2021
Messages
78
Trophies
0
Age
34
XP
608
Country
Germany
Alright, sorry for the latew reply. I put everything together now so other people may be able to find my post. I hope it can help somebody in the future :)

Hi @Fladulator ,

I try to help you, in concise and simple way.

[...]

My advise on what you can do now are:

1) For now, you have a working sm64-port version that the whole community played perfectly "until yesterday", and that is not that old version but is the older version than the one you can't compile now. So the new fixes, I don't think they can be so striking as to change your gaming experience.

2) Delete everything related to the Wii U environment on your PC, including the settings of MSYS2 / Mingw64 and environmental variables; because, reading your previous posts I believe that when you getting informing around (and you were good at it) by assimilating a lot of information in a short time, you made confusion between the compilation settings for SM64-Wii U and SM64-PC version which in the simplest way are set separately (you can set up all in one like I did, but you have to manually set multiple configurations).

3) Once everything is deleted, restart your PC and start to setting up again the Wii-U environment for Windows by going here: https://github.com/devkitPro/installer/releases , once downloaded devkitProUpdater-3.0.3 .exe run it and let the software do the settings automatically for you. The software will do everything by itself, you don't have to put any key or set the environmental variables (always check that it has set it automatically).

4) You will find your new Mingw64/32 in the following address C:\devkitPro\msys2 .

5) Once everything is installed and Mingw64 opened, type pacman -Sy then pacman -Syu.

6) Then, always remaining in Mingw64, download all the libraries necessary to start to set the compiler, with pacman -S wiiu-dev and then continue with the installation of the libraries required by AboodXD for the compilation of SM64.

7) Check that you have all the libraries installed via the pacman -Sl function.

[...]

So now I started with everything CrisMod told me within the following steps because I totally want to learn and understand this. I did the following:

1) Uninstalling all the related stuff and restarted the PC

2) Getting DevitPRO from https://github.com/devkitPro/installer/releases and during the install process I always checked Y for replacing the files displayed.

3) Using Mingw64 I did:
pacman -Sy
pacman -Syu
pacman -S wiiu-dev
pacman -Sl --> a few listed files were marked as [installed]

4) After receiving the error message -bash: git: command not found I checked this entry in the discord and added pacman -S wiiu-dev wiiu-sdl2 git make python3 mingw-w64-x86_64-gcc --noconfirm


wut-tools is not wut! So try the following:
Code:
git clone https://github.com/devkitPro/wut.git
cd wut
make
make install
The first command will copy latest wut sources from github to your PC. Second command will switch into the directory the first one created an the other two are hopefully familiar already. ;)

BTW: The issue on the picture is: "no makefile found", so whatever you have there in the wut-tools folder isn't meaned to be compiled with make.

//EDIT:

No! The problem is outdated WUT. You're just masking the problem but not fix it.

5) I grabbed wut:
git clone https://github.com/devkitPro/wut.git
cd wut
make
make install

6) I downloaded the sm64-port and sm64ex source files into my new folder (C:\devkitPro\WiiU):
cd /c/devkitPro/WiiU
git clone https://github.com/aboood40091/sm64-port.git
git clone https://github.com/aboood40091/sm64ex

7) I copied the baseroms into the folders, navigated (cd) into sm64-port and compiled it:
cd sm64-port
make VERSION=eu

8) profit :)
1653652603854.png


It works fine with the EU version being a little bit too fast paced but I'm going with the US version. German text in those old games just have a nostalgic place in my heart, that's why I always try out the EU versions first. So next step is get knowledge of how to add thumbnails for the rpx-files right here [EDIT: accomplished by looking at the apps and what is stored inside their folders :D --> icon.png]

1653653586076.png


and how to make forwarders with artwork (I did a lot of converting GameCube games and stuff as VC Injects, so I know anbout the TGA file format and the bit depths.). Could anyone of you maybe give me a small hint or post a link to where I can find small tutorials or sth like that? These would be the last steps for completing my WiiU journey for now :)

Ah, and 1 additional question: How can I change the button layout? I want to have:
- (B) jump
- (A)(L2)(R2) Dash/duck/stomp
- (Y) Punch
while the rest can stay untouched :)
Is there any possibility to do so? I found some lines that can be added somewhere but I'm not sure where to put them.
[EDIT: It's weird but after deleting both sm64ex versions and the EU version of sm64-port and starting the game again my savegame was gone and the button layout switched to (B)=Jump, (Y)=Punch. So that's almost perfect. Now I only need the Z button mapped to both L2 and R2 :D]


Thank you guys so much <3

Best,
TuF
 
Last edited by Fladulator,
General chit-chat
Help Users
  • Veho @ Veho:
    pls no
    Gift
  • Veho @ Veho:
    We have enough bots here as it is.
    Gift
  • Dark_Phoras @ Dark_Phoras:
    I'm going to brew an espresso
    Gift
  • Veho @ Veho:
    Describe your process.
    Gift
  • Dark_Phoras @ Dark_Phoras:
    My grandmother had just made it.
    Gift
  • Dark_Phoras @ Dark_Phoras:
    The process is: I pour 300ml of water in the coffee maker, then I add 20g of coffee dusted grains, then I heat it on the stove
    Gift
  • Dark_Phoras @ Dark_Phoras:
    That's the equivalent of 3/5 of a pint of water and 12 bees of coffee in american units
    Gift
  • KenniesNewName @ KenniesNewName:
    Is your first name Jordan
    Gift
  • Veho @ Veho:
    You use a moka pot?
    Gift
  • Dark_Phoras @ Dark_Phoras:
    I didn't know the expression moka pot, but it is that
    Gift
  • Veho @ Veho:
    I want to buy a moka pot for shits and giggles. We have an espresso machine at home, and a french press for when we want variety, and I want a moka just for the collection.
    Gift
  • Dark_Phoras @ Dark_Phoras:
    I don't know if I'll get an espresso machine, but I know I don't want to use capsules
    Gift
  • KenniesNewName @ KenniesNewName:
    Use the cubes
    Gift
  • Dark_Phoras @ Dark_Phoras:
    How is an espresso machine in terms of maintenance, do I have to wash it often?
    Gift
  • Veho @ Veho:
    Every few months or so you have to fill the water tank with a cleaning agent and run it through the machine, so that it cleans limescale and other stuff. Other than that, just wipe it down after every use, and run some water through it to flush out the "shower".
    Gift
  • Veho @ Veho:
    If you leave coffee stains on the shower overnight it gets nasty.
    Gift
  • Veho @ Veho:
    And rinse the portafilter.
    Gift
  • Dark_Phoras @ Dark_Phoras:
    It sounds manageable
    Gift
  • KenniesNewName @ KenniesNewName:
    Isn't vinegar enough to clean most coffee machines
    Gift
  • Veho @ Veho:
    Yeah, but it doesn't clean the coffee grime that builds up.
    Gift
  • Dark_Phoras @ Dark_Phoras:
    We don't want the grime to remain, do we?
    Gift
  • Dark_Phoras @ Dark_Phoras:
    I'm unconsciously adopting Dr. Glaucomflecken's speech pattern
    Gift
  • KenniesNewName @ KenniesNewName:
    Grime adds flavor
    Gift
  • KenniesNewName @ KenniesNewName:
    Theirs probably some at home chemical you can use without needing to buy special crap
    Gift
  • Veho @ Veho:
    Yeah, bicarb.
    Gift
    Veho @ Veho: Yeah, bicarb.